aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2012-05-20 12:18:29 +0800
committerrakuco <rakuco@FreeBSD.org>2012-05-20 12:18:29 +0800
commit6a3bd0ab5e0b396d97b857325f7f093304c5b7e6 (patch)
treefb43cb0146085fb6f43623cf55ad611b6324edd8
parent195b52cb0e55e936ad9101bf29b8bc1937968d46 (diff)
downloadfreebsd-ports-gnome-6a3bd0ab5e0b396d97b857325f7f093304c5b7e6.tar.gz
freebsd-ports-gnome-6a3bd0ab5e0b396d97b857325f7f093304c5b7e6.tar.zst
freebsd-ports-gnome-6a3bd0ab5e0b396d97b857325f7f093304c5b7e6.zip
Make the port build with the upcoming Qt 4.8.x series.
Since 4.8.0 [1], Qt itself does not automatically include GLU's headers and libraries with its OpenGL module, so applications which relied on Qt to get these need to be adjusted. PORTREVISION bumped since we now explicitly depend on GLU via USE_GL=glu. [1] http://qt.gitorious.org/qt/qt/commit/e7eed096a0c33607a7a37baaf06e5952dc9d556b Approved by: miwi (for Qt 4.8.1 to pass the exp-run)
-rw-r--r--cad/meshlab/Makefile3
-rw-r--r--cad/meshlab/files/patch-meshlab_meshlab.pro9
2 files changed, 11 insertions, 1 deletions
diff --git a/cad/meshlab/Makefile b/cad/meshlab/Makefile
index 46f90ebf5f0e..9fde058248ea 100644
--- a/cad/meshlab/Makefile
+++ b/cad/meshlab/Makefile
@@ -8,6 +8,7 @@
PORTNAME= meshlab
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/MeshLab%20v${PORTVERSION}/
DISTNAME= MeshLabSrc_AllInc_v123a
@@ -16,7 +17,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= A tool for processing and editing 3D triangular meshes
-USE_GL= glew
+USE_GL= glew glu
USE_QT_VER= 4
QT_COMPONENTS= qmake corelib gui xml opengl network moc uic rcc
diff --git a/cad/meshlab/files/patch-meshlab_meshlab.pro b/cad/meshlab/files/patch-meshlab_meshlab.pro
new file mode 100644
index 000000000000..542c3f15ed30
--- /dev/null
+++ b/cad/meshlab/files/patch-meshlab_meshlab.pro
@@ -0,0 +1,9 @@
+--- meshlab/meshlab.pro~ 2012-05-20 01:14:08.000000000 -0300
++++ meshlab/meshlab.pro 2012-05-20 01:14:53.000000000 -0300
+@@ -1,3 +1,6 @@
++# Qt 4.8 does not add -lGLU automatically with QT=opengl anymore
++LIBS += -lGLU
++
+ VCGDIR = ../../../vcglib
+ GLEWDIR = ../external/glew-1.5.1
+ #CONFIG += debug_and_release