aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-04-23 02:31:13 +0800
committerrene <rene@FreeBSD.org>2014-04-23 02:31:13 +0800
commit6a7bb20bffbcaf6ff81f423bdedf04ce3a1cd734 (patch)
treead203d2d673a8968a0d99559741727cdf0f9bff7
parent5f716218fad9335019b104a6327ecbe8b5e5e53f (diff)
downloadfreebsd-ports-gnome-6a7bb20bffbcaf6ff81f423bdedf04ce3a1cd734.tar.gz
freebsd-ports-gnome-6a7bb20bffbcaf6ff81f423bdedf04ce3a1cd734.tar.zst
freebsd-ports-gnome-6a7bb20bffbcaf6ff81f423bdedf04ce3a1cd734.zip
- Stage support [1]
- Clean up pkg-plist a bit [1] - Use modern LIB_DEPENDS PR: ports/188037 Submitted by: Danilo G. Baio <dbaio@bsd.com.br> Approved by: maintainer timeout (<pakhom706@gmail.com> , 3 weeks)
-rw-r--r--net-mgmt/zabbix22-agent/Makefile1
-rw-r--r--net-mgmt/zabbix22-frontend/Makefile5
-rw-r--r--net-mgmt/zabbix22-proxy/Makefile1
-rw-r--r--net-mgmt/zabbix22-server/Makefile31
-rw-r--r--net-mgmt/zabbix22-server/pkg-plist1
-rw-r--r--net-mgmt/zabbix22-server/pkg-plist.agent3
-rw-r--r--net-mgmt/zabbix22-server/pkg-plist.frontend20
7 files changed, 29 insertions, 33 deletions
diff --git a/net-mgmt/zabbix22-agent/Makefile b/net-mgmt/zabbix22-agent/Makefile
index eb5c5f641c0e..c68bc0f342b5 100644
--- a/net-mgmt/zabbix22-agent/Makefile
+++ b/net-mgmt/zabbix22-agent/Makefile
@@ -13,6 +13,5 @@ OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
OPTIONS_DEFINE= IPV6
OPTIONS_DEFAULT= IPV6
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/zabbix22-frontend/Makefile b/net-mgmt/zabbix22-frontend/Makefile
index 34d4df4c3727..840949361155 100644
--- a/net-mgmt/zabbix22-frontend/Makefile
+++ b/net-mgmt/zabbix22-frontend/Makefile
@@ -20,7 +20,6 @@ OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
OPTIONS_DEFAULT= MYSQL MYSQLI
MYSQLI_DESC= MySQLI backend
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -45,7 +44,7 @@ CONFIGURE_ARGS+= --with-oracle
.endif
do-install:
- @${INSTALL} -d ${WWWDIR}
- @cd ${WRKSRC}/frontends/php/ && ${COPYTREE_SHARE} . ${WWWDIR}
+ @${INSTALL} -d ${STAGEDIR}${WWWDIR}
+ @cd ${WRKSRC}/frontends/php/ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/zabbix22-proxy/Makefile b/net-mgmt/zabbix22-proxy/Makefile
index e7c26d598bbd..8e1d778c01e7 100644
--- a/net-mgmt/zabbix22-proxy/Makefile
+++ b/net-mgmt/zabbix22-proxy/Makefile
@@ -6,5 +6,4 @@ PKGNAMESUFFIX= -proxy
MASTERDIR= ${.CURDIR}/../zabbix22-server
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/zabbix22-server/Makefile b/net-mgmt/zabbix22-server/Makefile
index ab50fc7a0b72..222947b45d3e 100644
--- a/net-mgmt/zabbix22-server/Makefile
+++ b/net-mgmt/zabbix22-server/Makefile
@@ -27,11 +27,8 @@ ZABBIX_BUILD= ${PKGNAMESUFFIX:S/^-//}
.if ${ZABBIX_BUILD} != "frontend" # frontend only needs the version/distribution settings
.if ${ZABBIX_BUILD} != "agent"
-MAN8+= zabbix_${ZABBIX_BUILD}.8
USE_RC_SUBR= zabbix_${ZABBIX_BUILD}
.else
-MAN1+= zabbix_get.1 zabbix_sender.1
-MAN8+= zabbix_${ZABBIX_BUILD}d.8
USE_RC_SUBR= zabbix_${ZABBIX_BUILD}d
.endif
@@ -63,8 +60,8 @@ CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD} \
--with-iconv=${ICONV_PREFIX}
.if ${ZABBIX_BUILD} != "agent"
-LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
- execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
SUB_FILES= pkg-message
@@ -92,7 +89,6 @@ OPTIONS_SINGLE= DB ODBC
OPTIONS_SINGLE_DB= MYSQL PGSQL SQLITE ORACLE
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -119,7 +115,7 @@ CONFIGURE_ARGS+= --with-oracle
.endif
.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-libcurl
.endif
@@ -129,12 +125,12 @@ CONFIGURE_ARGS+= --with-ldap
.endif
.if ${PORT_OPTIONS:MIPMI}
-LIB_DEPENDS+= OpenIPMI:${PORTSDIR}/sysutils/openipmi
+LIB_DEPENDS+= libOpenIPMI.so:${PORTSDIR}/sysutils/openipmi
CONFIGURE_ARGS+= --with-openipmi
.endif
.if ${PORT_OPTIONS:MJABBER}
-LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel
+LIB_DEPENDS+= libiksemel.so:${PORTSDIR}/textproc/iksemel
CONFIGURE_ARGS+= --with-jabber
.endif
@@ -143,17 +139,17 @@ RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
.if ${PORT_OPTIONS:MSSH}
-LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
+LIB_DEPENDS+= libssh2.so:${PORTSDIR}/security/libssh2
CONFIGURE_ARGS+= --with-ssh2
.endif
.if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+= --with-iodbc
.endif
.if ${PORT_OPTIONS:MUNIXODBC}
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+= --with-unixodbc
.endif
.endif # if ${ZABBIX_BUILD} != "agent"
@@ -177,7 +173,7 @@ PLIST_SUB+= JAVAGW="@comment "
.endif
.if ${PORT_OPTIONS:MLIBXML2}
-LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
CONFIGURE_ARGS+= --with-libxml2
.endif
@@ -203,14 +199,13 @@ post-patch:
post-install:
.if defined(WITH_JAVAGW)
- @${MV} ${PREFIX}/sbin/zabbix_java/settings.sh ${PREFIX}/sbin/zabbix_java/settings.sh.sample
+ @${MV} ${STAGEDIR}${PREFIX}/sbin/zabbix_java/settings.sh ${STAGEDIR}${PREFIX}/sbin/zabbix_java/settings.sh.sample
.endif
.if ${ZABBIX_BUILD} != "agent"
- @${MKDIR} "${DATADIR}/${ZABBIX_BUILD}/database"
- @cd ${WRKSRC}/upgrades/ && ${COPYTREE_SHARE} dbpatches ${DATADIR}/${ZABBIX_BUILD}/upgrades/
- @cd ${WRKSRC}/database/ && ${COPYTREE_SHARE} "ibm_db2 mysql oracle postgresql sqlite3" ${DATADIR}/${ZABBIX_BUILD}/database/
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} "${STAGEDIR}${DATADIR}/${ZABBIX_BUILD}/database"
+ @cd ${WRKSRC}/upgrades/ && ${COPYTREE_SHARE} dbpatches ${STAGEDIR}${DATADIR}/${ZABBIX_BUILD}/upgrades/
+ @cd ${WRKSRC}/database/ && ${COPYTREE_SHARE} "ibm_db2 mysql oracle postgresql sqlite3" ${STAGEDIR}${DATADIR}/${ZABBIX_BUILD}/database/
.endif
.endif # if ${ZABBIX_BUILD} != "frontend"
diff --git a/net-mgmt/zabbix22-server/pkg-plist b/net-mgmt/zabbix22-server/pkg-plist
index 1736f8de93cb..c95655212642 100644
--- a/net-mgmt/zabbix22-server/pkg-plist
+++ b/net-mgmt/zabbix22-server/pkg-plist
@@ -1,4 +1,5 @@
%%ETCDIR%%/zabbix_%%ZABBIX_BUILD%%.conf.sample
+man/man8/zabbix_%%ZABBIX_BUILD%%.8.gz
sbin/zabbix_%%ZABBIX_BUILD%%
%%DATADIR%%/%%ZABBIX_BUILD%%/database/mysql/data.sql
%%DATADIR%%/%%ZABBIX_BUILD%%/database/mysql/schema.sql
diff --git a/net-mgmt/zabbix22-server/pkg-plist.agent b/net-mgmt/zabbix22-server/pkg-plist.agent
index 589cb8a158cb..bef621895412 100644
--- a/net-mgmt/zabbix22-server/pkg-plist.agent
+++ b/net-mgmt/zabbix22-server/pkg-plist.agent
@@ -7,3 +7,6 @@ sbin/zabbix_agentd
@dirrmtry %%ETCDIR%%/zabbix_agentd.conf.d
@dirrmtry %%ETCDIR%%/zabbix_agent.conf.d
@dirrmtry %%ETCDIR%%
+man/man1/zabbix_get.1.gz
+man/man1/zabbix_sender.1.gz
+man/man8/zabbix_%%ZABBIX_BUILD%%d.8.gz
diff --git a/net-mgmt/zabbix22-server/pkg-plist.frontend b/net-mgmt/zabbix22-server/pkg-plist.frontend
index a6fdcb7673b0..6468c28bfe27 100644
--- a/net-mgmt/zabbix22-server/pkg-plist.frontend
+++ b/net-mgmt/zabbix22-server/pkg-plist.frontend
@@ -820,7 +820,7 @@
@dirrm %%WWWDIR%%/audio
@dirrm %%WWWDIR%%/include/views/js
@dirrm %%WWWDIR%%/include/views
-@dirrm %%WWWDIR%%/include/classes/graphdraw/
+@dirrm %%WWWDIR%%/include/classes/graphdraw
@dirrm %%WWWDIR%%/include/classes/import/formatters
@dirrm %%WWWDIR%%/include/classes/import/readers
@dirrm %%WWWDIR%%/include/classes/import/importers
@@ -846,7 +846,7 @@
@dirrm %%WWWDIR%%/include/classes/validators/host
@dirrm %%WWWDIR%%/include/classes/validators/string
@dirrm %%WWWDIR%%/include/classes/validators/object
-@dirrm %%WWWDIR%%/include/classes/validators/
+@dirrm %%WWWDIR%%/include/classes/validators
@dirrm %%WWWDIR%%/include/classes
@dirrm %%WWWDIR%%/include
@dirrm %%WWWDIR%%/api/rpc
@@ -913,14 +913,14 @@
@dirrm %%WWWDIR%%/locale/tr
@dirrm %%WWWDIR%%/locale/sk/LC_MESSAGES
@dirrm %%WWWDIR%%/locale/sk
-@dirrm %%WWWDIR%%/locale/en_US/LC_MESSAGES/
-@dirrm %%WWWDIR%%/locale/en_US/
-@dirrm %%WWWDIR%%/locale/bg/LC_MESSAGES/
-@dirrm %%WWWDIR%%/locale/bg/
-@dirrm %%WWWDIR%%/locale/lt/LC_MESSAGES/
-@dirrm %%WWWDIR%%/locale/lt/
-@dirrm %%WWWDIR%%/locale/ro/LC_MESSAGES/
-@dirrm %%WWWDIR%%/locale/ro/
+@dirrm %%WWWDIR%%/locale/en_US/LC_MESSAGES
+@dirrm %%WWWDIR%%/locale/en_US
+@dirrm %%WWWDIR%%/locale/bg/LC_MESSAGES
+@dirrm %%WWWDIR%%/locale/bg
+@dirrm %%WWWDIR%%/locale/lt/LC_MESSAGES
+@dirrm %%WWWDIR%%/locale/lt
+@dirrm %%WWWDIR%%/locale/ro/LC_MESSAGES
+@dirrm %%WWWDIR%%/locale/ro
@dirrm %%WWWDIR%%/locale
@dirrm %%WWWDIR%%/conf
@dirrm %%WWWDIR%%/js/jquery