aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2011-02-11 04:35:33 +0800
committeraz <az@FreeBSD.org>2011-02-11 04:35:33 +0800
commit6b60b063753c1aabea01c1d12ae7f9f91d68d432 (patch)
treeaf6247eb5844466a2ce4e1e3dcb76306974f237c
parentbeb6cd25e6ffa13a3363b02f5a7303c0c55e4a1b (diff)
downloadfreebsd-ports-gnome-6b60b063753c1aabea01c1d12ae7f9f91d68d432.tar.gz
freebsd-ports-gnome-6b60b063753c1aabea01c1d12ae7f9f91d68d432.tar.zst
freebsd-ports-gnome-6b60b063753c1aabea01c1d12ae7f9f91d68d432.zip
- Fix not real world communications via gen_eth (FreeBSD's libpcap) issue [1]
- Add LICENSE [2] - Remove MD5 from distinfo PR: ports/154521 Submitted by: Alexander V. Chernikov <melifaro@ipfw.ru> [1] Pavel Volkov <pavelivolkov@googlemail.com> [2] (maintainer) Approved by: maintainer
-rw-r--r--emulators/dynamips-devel/Makefile3
-rw-r--r--emulators/dynamips-devel/distinfo1
-rw-r--r--emulators/dynamips-devel/files/patch-gen_eth.c26
3 files changed, 28 insertions, 2 deletions
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index 2cccf4a0956e..1971a54c45c1 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dynamips
DISTVERSION= 0.2.8-RC2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
PKGNAMESUFFIX= -devel
@@ -18,6 +18,7 @@ COMMENT= Cisco 1700/2600/3600/3700/7200 Simulator
LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
CONFLICTS= dynamips-[0-9]*
+LICENSE= GPLv2
USE_GMAKE= yes
ALL_TARGET= ${PORTNAME} nvram_export
diff --git a/emulators/dynamips-devel/distinfo b/emulators/dynamips-devel/distinfo
index c7c1ca17bd78..8a537d24e534 100644
--- a/emulators/dynamips-devel/distinfo
+++ b/emulators/dynamips-devel/distinfo
@@ -1,3 +1,2 @@
-MD5 (dynamips-0.2.8-RC2.tar.gz) = 8d12d28684d164fe3312a3fe43c84d2e
SHA256 (dynamips-0.2.8-RC2.tar.gz) = a8b377ce631119e285c401fdb7cb4d0bcc600a15508bdffcf337546957e252de
SIZE (dynamips-0.2.8-RC2.tar.gz) = 578935
diff --git a/emulators/dynamips-devel/files/patch-gen_eth.c b/emulators/dynamips-devel/files/patch-gen_eth.c
new file mode 100644
index 000000000000..97f60cdd3222
--- /dev/null
+++ b/emulators/dynamips-devel/files/patch-gen_eth.c
@@ -0,0 +1,26 @@
+--- gen_eth.c.orig 2007-05-26 18:52:33.000000000 +0900
++++ gen_eth.c 2009-07-21 03:18:35.194759073 +0900
+@@ -22,6 +22,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/wait.h>
++#include <sys/ioctl.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <pthread.h>
+@@ -45,8 +46,13 @@
+ if (!(p = pcap_open_live(device,2048,TRUE,10,pcap_errbuf)))
+ goto pcap_error;
+
+- /* Accept only incoming packets */
+- pcap_setdirection(p,PCAP_D_IN);
++ pcap_setdirection(p,PCAP_D_INOUT);
++#ifdef BIOCFEEDBACK
++ {
++ int on = 1;
++ ioctl(pcap_fileno(p), BIOCFEEDBACK, &on);
++ }
++#endif
+ #else
+ p = pcap_open(device,2048,
+ PCAP_OPENFLAG_PROMISCUOUS |