aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-08-07 10:20:26 +0800
committerswills <swills@FreeBSD.org>2011-08-07 10:20:26 +0800
commit6d9c92d6797d3c3aef69a4cd1794a622d94602ba (patch)
tree1498b3678533a40c442bc7a21fba0d829d1e47e0
parenta0a97e0d7c4c9537c34478e5ec65c200b34a2c54 (diff)
downloadfreebsd-ports-gnome-6d9c92d6797d3c3aef69a4cd1794a622d94602ba.tar.gz
freebsd-ports-gnome-6d9c92d6797d3c3aef69a4cd1794a622d94602ba.tar.zst
freebsd-ports-gnome-6d9c92d6797d3c3aef69a4cd1794a622d94602ba.zip
Source code spell checker.
WWW: http://git.profusion.mobi/cgit.cgi/lucas/codespell/ PR: ports/159564 Submitted by: Glen Barber <gjb at FreeBSD.org>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/codespell/Makefile49
-rw-r--r--textproc/codespell/distinfo2
-rw-r--r--textproc/codespell/files/pkg-message.in7
-rw-r--r--textproc/codespell/pkg-descr3
5 files changed, 62 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3e993f37803c..43f8e467795b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -69,6 +69,7 @@
SUBDIR += clucene-contrib
SUBDIR += coco
SUBDIR += code2html
+ SUBDIR += codespell
SUBDIR += cole
SUBDIR += colordiff
SUBDIR += confget
diff --git a/textproc/codespell/Makefile b/textproc/codespell/Makefile
new file mode 100644
index 000000000000..4cd754fe04da
--- /dev/null
+++ b/textproc/codespell/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: codespell
+# Date created: 6 August 2011
+# Whom: Glen Barber <gjb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= codespell
+PORTVERSION= 1.1
+CATEGORIES= textproc
+MASTER_SITES= http://www.glenbarber.us/ports/${CATEGORIES}/${PORTNAME}/
+
+MAINTAINER= gjb@FreeBSD.org
+COMMENT= Source code spelling checker
+
+LICENSE= GPLv2
+
+USE_PYTHON= 3.1+
+
+PLIST_FILES= bin/codespell
+PORTDOCS= COPYING README TODO
+PORTEXAMPLES= *
+
+SUB_FILES+= pkg-message
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ ${REINPLACE_CMD} 's|#!/usr/bin/env python3|#!${LOCALBASE}/bin/${PYTHON_VERSION}|' \
+ ${WRKSRC}/codespell.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/codespell.py ${PREFIX}/bin/codespell
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
+.endif
+
+.for i in data example
+ @${MKDIR} ${EXAMPLESDIR}/${i}
+ @${INSTALL_DATA} ${WRKSRC}/${i}/* ${EXAMPLESDIR}/${i}
+.endfor
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/codespell/distinfo b/textproc/codespell/distinfo
new file mode 100644
index 000000000000..a91f9149ca8b
--- /dev/null
+++ b/textproc/codespell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (codespell-1.1.tar.gz) = 0cdab2474ab1aacf830ab57280615935b745eb299fde0d50235a6dc2d423ea2e
+SIZE (codespell-1.1.tar.gz) = 42289
diff --git a/textproc/codespell/files/pkg-message.in b/textproc/codespell/files/pkg-message.in
new file mode 100644
index 000000000000..ed2513f20f20
--- /dev/null
+++ b/textproc/codespell/files/pkg-message.in
@@ -0,0 +1,7 @@
+***************************************************************
+
+You have successfully installed codespell!
+The dictionary file has been installed to:
+%%EXAMPLESDIR%%/data/dictionary.txt
+
+***************************************************************
diff --git a/textproc/codespell/pkg-descr b/textproc/codespell/pkg-descr
new file mode 100644
index 000000000000..9472a444f66f
--- /dev/null
+++ b/textproc/codespell/pkg-descr
@@ -0,0 +1,3 @@
+Source code spell checker.
+
+WWW: http://git.profusion.mobi/cgit.cgi/lucas/codespell/