aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-24 10:43:51 +0800
committermarcus <marcus@FreeBSD.org>2006-04-24 10:43:51 +0800
commit6df82295ef20e65f47f8b725d24c2e314ca5236f (patch)
treecb4232c5ead82bd53da0dd8e344083fd5deab97f
parent37b6e8cd0b47f39c992166363632442b48f3b296 (diff)
downloadfreebsd-ports-gnome-6df82295ef20e65f47f8b725d24c2e314ca5236f.tar.gz
freebsd-ports-gnome-6df82295ef20e65f47f8b725d24c2e314ca5236f.tar.zst
freebsd-ports-gnome-6df82295ef20e65f47f8b725d24c2e314ca5236f.zip
Fix the adns library version so it matches the internal soname. This sets
the lib version back to 1, but since the dependencies still linked to libadns.so.1 even when the installed file was libadns.so.12, a new PORTREVISION bump is not needed.
-rw-r--r--devel/liboop/Makefile2
-rw-r--r--dns/adns/Makefile3
-rw-r--r--dns/adns/files/patch-configure2
-rw-r--r--dns/adns/files/patch-configure.in2
-rw-r--r--dns/fastresolve/Makefile2
-rw-r--r--dns/py-adns/Makefile2
-rw-r--r--net-im/gale/Makefile2
-rw-r--r--net/ethereal/Makefile2
-rw-r--r--net/nepenthes/Makefile2
-rw-r--r--net/wireshark/Makefile2
-rw-r--r--textproc/modlogan/Makefile2
11 files changed, 12 insertions, 11 deletions
diff --git a/devel/liboop/Makefile b/devel/liboop/Makefile
index 8fcd4c1dc158..6d7e3422e6ef 100644
--- a/devel/liboop/Makefile
+++ b/devel/liboop/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= A low-level event loop management library for POSIX-based OS
-LIB_DEPENDS= adns.12:${PORTSDIR}/dns/adns \
+LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns \
tcl84.1:${PORTSDIR}/lang/tcl84 \
wwwcore.1:${PORTSDIR}/www/libwww
diff --git a/dns/adns/Makefile b/dns/adns/Makefile
index da428dae8563..a7fab6bd8982 100644
--- a/dns/adns/Makefile
+++ b/dns/adns/Makefile
@@ -7,6 +7,7 @@
PORTNAME= adns
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= ftp://ftp.chiark.greenend.org.uk/users/ian/adns/ \
http://www.chiark.greenend.org.uk/~ian/adns/ftp/
@@ -18,7 +19,7 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-LIBVERSION= 12
+LIBVERSION= 1
PLIST_SUB+= LIBVERSION="${LIBVERSION}"
DOCS= COPYING GPL-vs-LGPL INSTALL LICENCE.WAIVERS README README.html TODO changelog
diff --git a/dns/adns/files/patch-configure b/dns/adns/files/patch-configure
index 2b4bfdac9c7f..cb1c4952408c 100644
--- a/dns/adns/files/patch-configure
+++ b/dns/adns/files/patch-configure
@@ -5,7 +5,7 @@
SHLIBFORLINK='libadns.so'
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
-+SHLIBFILE='$(SHLIBSONAME)$(MINOR)'
++SHLIBFILE='$(SHLIBSONAME)'
SHLIBCC='$(CC) $(CFLAGS) -fpic'
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'
diff --git a/dns/adns/files/patch-configure.in b/dns/adns/files/patch-configure.in
index 9e0b4ab7d960..74b94f6d1b02 100644
--- a/dns/adns/files/patch-configure.in
+++ b/dns/adns/files/patch-configure.in
@@ -5,7 +5,7 @@
SHLIBFORLINK='libadns.so'
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
-+SHLIBFILE='$(SHLIBSONAME)$(MINOR)'
++SHLIBFILE='$(SHLIBSONAME)'
SHLIBCC='$(CC) $(CFLAGS) -fpic'
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index 29459a50444c..18992e72bf99 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.djmnet.org/sw/dist/
MAINTAINER= martin@matuska.org
COMMENT= Programs that process web logs to get DNS and domain ownership info
-LIB_DEPENDS= adns.12:${PORTSDIR}/dns/adns
+LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
USE_BZIP2= yes
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index 3dfcfa6ab0d8..93b5eced4d13 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -16,7 +16,7 @@ DISTNAME= adns-python-${PORTVERSION}
MAINTAINER= perky@FreeBSD.org
COMMENT= A Python Interface to adns, the asynchronous DNS library
-LIB_DEPENDS= adns.12:${PORTSDIR}/dns/adns
+LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
index 0ff5fe7b1ab9..e0f3a701eefc 100644
--- a/net-im/gale/Makefile
+++ b/net-im/gale/Makefile
@@ -17,7 +17,7 @@ COMMENT= A secure instant messaging system
BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww \
- adns.12:${PORTSDIR}/dns/adns
+ adns.1:${PORTSDIR}/dns/adns
USE_ICONV= yes
USE_GNOME= glib12
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index 7ce493f1563c..8ab3c6279c36 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -108,7 +108,7 @@ CONFIGURE_ARGS+= --enable-snmp=no --with-ucd-snmp=no --with-net-snmp=no
.endif
.if !defined(WITHOUT_ADNS) && !defined(LITE)
-LIB_DEPENDS+= adns.12:${PORTSDIR}/dns/adns
+LIB_DEPENDS+= adns.1:${PORTSDIR}/dns/adns
CONFIGURE_ARGS+= --with-adns=${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --with-adns=no
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index 0baaee9ea2ba..a03980144f43 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -18,7 +18,7 @@ COMMENT= Determine the malware activity on a network
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
magic.1:${PORTSDIR}/sysutils/file \
pcre.0:${PORTSDIR}/devel/pcre \
- adns.12:${PORTSDIR}/dns/adns
+ adns.1:${PORTSDIR}/dns/adns
USE_PERL5= yes
GNU_CONFIGURE= yes
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 7ce493f1563c..8ab3c6279c36 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -108,7 +108,7 @@ CONFIGURE_ARGS+= --enable-snmp=no --with-ucd-snmp=no --with-net-snmp=no
.endif
.if !defined(WITHOUT_ADNS) && !defined(LITE)
-LIB_DEPENDS+= adns.12:${PORTSDIR}/dns/adns
+LIB_DEPENDS+= adns.1:${PORTSDIR}/dns/adns
CONFIGURE_ARGS+= --with-adns=${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --with-adns=no
diff --git a/textproc/modlogan/Makefile b/textproc/modlogan/Makefile
index 617ce96ef1b2..75d1c730c3f3 100644
--- a/textproc/modlogan/Makefile
+++ b/textproc/modlogan/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= modlogan
MAINTAINER= netchild@FreeBSD.org
COMMENT= A modular log file analysis program
-LIB_DEPENDS= adns.12:${PORTSDIR}/dns/adns \
+LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns \
gd.4:${PORTSDIR}/graphics/gd \
pcre.0:${PORTSDIR}/devel/pcre \
expat.6:${PORTSDIR}/textproc/expat2