aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-03-05 22:01:55 +0800
committeroliver <oliver@FreeBSD.org>2005-03-05 22:01:55 +0800
commit6fa09ef996b9c5e8466b43aef1394c27637c9c76 (patch)
tree1115c009552484a56f4b5148ef881b3b920de874
parent594926be101c0c486a4856ee981cbd657ad83004 (diff)
downloadfreebsd-ports-gnome-6fa09ef996b9c5e8466b43aef1394c27637c9c76.tar.gz
freebsd-ports-gnome-6fa09ef996b9c5e8466b43aef1394c27637c9c76.tar.zst
freebsd-ports-gnome-6fa09ef996b9c5e8466b43aef1394c27637c9c76.zip
update to 4.0.2
migrate to OPTIONS add WITH_SYSLOG_FACILITY knob [1] Submitted by: Sascha Holzleiter <sascha@daemonground.de> [1]
-rw-r--r--mail/courier-imap/Makefile44
-rw-r--r--mail/courier-imap/distinfo4
2 files changed, 28 insertions, 20 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index a401c7bb1833..b4d80a73214d 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= courier-imap
-PORTVERSION= 4.0.1
+PORTVERSION= 4.0.2
PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= mail ipv6
@@ -41,14 +41,16 @@ CONFIGURE_ENV= CFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
#
# options available:
#
-# WITHOUT_OPENSSL: Don't build in TLS support
-# WITH_FAM: Build in fam support for IDLE command
-# WITH_DRAC: Build in DRAC support
-# WITH_TRASHQUOTA: Include deleted mails in the quota
-# WITH_GDBM: Use gdbm files instead of bdb
-# WITHOUT_IPV6 Don't build ipv6 support
+# WITH_SYSLOG_FACILITY: The syslogfacility to use
#
+OPTIONS= OPENSSL "Build with OpenSSL support" on \
+ FAM "Build in fam support for IDLE command" off \
+ DRAC "Build in DRAC support" off \
+ TRASHQUOTA "Include deleted mails in the quota" off \
+ GDBM "Use gdbm files instead of bdb" off \
+ IPV6 "Build with IPv6 support" on
+
CONFDIR?= ${PREFIX}/etc/${PORTNAME}
RCDIR?= ${PREFIX}/etc/rc.d
USERDB?= ${PREFIX}/etc/userdb
@@ -69,22 +71,30 @@ CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
--disable-root-check \
--with-locking-method=fcntl
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SSL)
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+PLIST_SUB+= OPENSSLFLAG=
+CONFIGURE_ARGS+=--enable-ssl
+.else
+PLIST_SUB+= OPENSSLFLAG="@comment "
+.endif
+
+.if defined(WITH_SYSLOG_FACILITY)
+CONFIGURE_ARGS+=--with-syslog=${WITH_SYSLOG_FACILITY}
+.endif
+
# Without explicitly mentioning this, if gdbm libraries are present,
# they are silently picked up and used by courier-imap in place of
# the standard db (v1) files.
#
.if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
-CONFIGURE_ARGS+= --with-db=gdbm
-.else
-CONFIGURE_ARGS+= --with-db=db
-.endif
-
-.if !defined(WITHOUT_OPENSSL)
-USE_OPENSSL= YES
-PLIST_SUB+= OPENSSLFLAG=
+CONFIGURE_ARGS+=--with-db=gdbm
.else
-PLIST_SUB+= OPENSSLFLAG="@comment "
+CONFIGURE_ARGS+=--with-db=db
.endif
.if defined(WITHOUT_IPV6)
@@ -128,8 +138,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|@LIBS@|@LIBS@ -rpath=:${LOCALBASE}/lib/courier-authlib|' \
${WRKSRC}/imap/Makefile.in
-.include <bsd.port.pre.mk>
-
post-install:
.for i in imapd pop3d
${INSTALL_DATA} ${WRKSRC}/imap/${i}.cnf ${CONFDIR}/${i}.cnf.dist
diff --git a/mail/courier-imap/distinfo b/mail/courier-imap/distinfo
index b830f2133ffd..eef7572af384 100644
--- a/mail/courier-imap/distinfo
+++ b/mail/courier-imap/distinfo
@@ -1,2 +1,2 @@
-MD5 (courier-imap-4.0.1.tar.bz2) = f8578d1a3d04ffdb99c75b550dd190a7
-SIZE(courier-imap-4.0.1.tar.bz2) = 3032350
+MD5 (courier-imap-4.0.2.tar.bz2) = 9061583ef8e7b3fd69ef77dbfc0656eb
+SIZE(courier-imap-4.0.2.tar.bz2) = 3036089