aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2006-02-08 11:06:22 +0800
committerbrooks <brooks@FreeBSD.org>2006-02-08 11:06:22 +0800
commit6fd8159e2097bbaf4ac1be692fb72aa597207449 (patch)
tree4c5c688415bbc92f5c899a69bd72bc29690a4482
parent0dfa77a8b1acc9afdc15f8ac43a55f5e5c12cde9 (diff)
downloadfreebsd-ports-gnome-6fd8159e2097bbaf4ac1be692fb72aa597207449.tar.gz
freebsd-ports-gnome-6fd8159e2097bbaf4ac1be692fb72aa597207449.tar.zst
freebsd-ports-gnome-6fd8159e2097bbaf4ac1be692fb72aa597207449.zip
Add www/mod_pubcookie:
Pubcookie is an open-source package for intra-institutional single-sign-on end-user web authentication. More generally, it is an approach to identifying users as they browse to an institution's many websites that require authentication. It helps an institution reuse existing authentication services (like Kerberos, LDAP, or NIS), and it limits the exposure of end-user passwords by ensuring they're only sent to a trusted login service. This port contains the apache module portion of the Pubcookie system.
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_pubcookie/Makefile59
-rw-r--r--www/mod_pubcookie/pkg-descr11
-rw-r--r--www/mod_pubcookie/pkg-plist8
4 files changed, 79 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 58410a6e111a..730be414143b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -345,6 +345,7 @@
SUBDIR += mod_php5
SUBDIR += mod_proxy_add_forward
SUBDIR += mod_proxy_html
+ SUBDIR += mod_pubcookie
SUBDIR += mod_put
SUBDIR += mod_python
SUBDIR += mod_python3
diff --git a/www/mod_pubcookie/Makefile b/www/mod_pubcookie/Makefile
new file mode 100644
index 000000000000..6b81b84cd7f9
--- /dev/null
+++ b/www/mod_pubcookie/Makefile
@@ -0,0 +1,59 @@
+# Ports collection makefile for: pubcookie
+# Date created: Sat Jan 21, 2006
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pubcookie
+DISTVERSION= 3.3.0-beta2
+CATEGORIES= www security
+MASTER_SITES= http://pubcookie.org/downloads/
+PKGNAMEPREFIX= mod_
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= A single sign-on system for websites (apache module)
+
+CONFLICTS= pubcookie-login-server-[0-9]*
+
+FILESDIR= ${.CURDIR}/../pubcookie-login-server/files
+MD5_FILE= ${.CURDIR}/../pubcookie-login-server/distinfo
+PATCHDIR= ${.CURDIR}/../pubcookie-login-server/files
+
+HAS_CONFIGURE= YES
+# GNU_CONFIGURE things since we're not installing directly in PREFIX
+CONFIGURE_ARGS+= --prefix=${PC_DIR} ${CONFIGURE_TARGET}
+
+# We want to build the module server
+CONFIGURE_ARGS+= --enable-apache --disable-login
+
+# mod_pubcookie supports other Apache versions, but the port doesn't yet
+USE_APACHE= 20
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+MODULENAME= mod_${PORTNAME}
+#SHORTMODNAME= ${PORTNAME}
+
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
+
+PC_BASE?= ${PORTNAME}
+PC_DIR= ${PREFIX}/${PC_BASE}
+
+SUB_FILES+= pkg-install
+SUB_LIST+= CONF_FILES="${CONF_FILES}" CONF_DIRS="${CONF_DIRS}"
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${PKGINSTALL}
+CONF_FILES+= ${PC_BASE}/config.sample:${PC_BASE}/config
+
+# XXX Add Kerberos
+
+do-install:
+ ${MKDIR} ${PC_DIR}/keys
+ ${INSTALL_PROGRAM} ${WRKSRC}/keyclient ${PC_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/config.sample ${PC_DIR}
+ ${APXS} -i -A -n ${SHORTMODNAME} ${WRKSRC}/module/${MODULENAME}.${AP_BUILDEXT}
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/www/mod_pubcookie/pkg-descr b/www/mod_pubcookie/pkg-descr
new file mode 100644
index 000000000000..12f80ba8cfed
--- /dev/null
+++ b/www/mod_pubcookie/pkg-descr
@@ -0,0 +1,11 @@
+Pubcookie is an open-source package for intra-institutional
+single-sign-on end-user web authentication. More generally, it is an
+approach to identifying users as they browse to an institution's many
+websites that require authentication. It helps an institution reuse
+existing authentication services (like Kerberos, LDAP, or NIS), and it
+limits the exposure of end-user passwords by ensuring they're only sent
+to a trusted login service.
+
+This port contains the Apache module portion of the Pubcookie system.
+
+WWW: http://pubcookie.org/
diff --git a/www/mod_pubcookie/pkg-plist b/www/mod_pubcookie/pkg-plist
new file mode 100644
index 000000000000..1db9dd53fb39
--- /dev/null
+++ b/www/mod_pubcookie/pkg-plist
@@ -0,0 +1,8 @@
+pubcookie/config.sample
+pubcookie/keyclient
+@dirrmtry pubcookie/keys
+@dirrmtry pubcookie
+@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%%APACHEMODDIR%%/%%AP_MODULE%%
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all ${MODULENAME}-related directives in your httpd.conf"