aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2011-12-12 01:07:16 +0800
committernivit <nivit@FreeBSD.org>2011-12-12 01:07:16 +0800
commit702e1b909072d1438033b51aa35f3cd8d42f37f3 (patch)
treefadf3f14488410ccd02e01fbcc9e129db1ea0d86
parent577648314337322aaa488eecebcfd9daf634be2b (diff)
downloadfreebsd-ports-gnome-702e1b909072d1438033b51aa35f3cd8d42f37f3.tar.gz
freebsd-ports-gnome-702e1b909072d1438033b51aa35f3cd8d42f37f3.tar.zst
freebsd-ports-gnome-702e1b909072d1438033b51aa35f3cd8d42f37f3.zip
- Add STOCKFISH option (default off) to install the stockfish chess engine
Submitted by: Gautam Mani <execve at gmail.com> (via private email) Feature safe: yes
-rw-r--r--games/py-pychess/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/py-pychess/Makefile b/games/py-pychess/Makefile
index f4cee1b35a9e..e65f4f91c64a 100644
--- a/games/py-pychess/Makefile
+++ b/games/py-pychess/Makefile
@@ -26,7 +26,8 @@ OPTIONS= PYGSTREAMER "Install gst-python for audio support" off \
GNUCHESS "Install gnuchess (chess engine)" off \
PHALANX "Install phalanx (chess engine)" off \
SJENG "Install sjeng (chess engine)" off \
- STRONGPLAYER "Install psyco/gmpy (strong player)" off
+ STRONGPLAYER "Install psyco/gmpy (strong player)" off \
+ STOCKFISH "Install stockfish (chess engine)" off
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
@@ -76,4 +77,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psyco>=1.6:${PORTSDIR}/devel/py-psyco
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gmpy>=1.13:${PORTSDIR}/math/py-gmpy
.endif
+.if defined (WITH_STOCKFISH)
+RUN_DEPENDS+= stockfish:${PORTSDIR}/games/stockfish
+.endif
+
.include <bsd.port.post.mk>