aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-18 18:29:26 +0800
committeredwin <edwin@FreeBSD.org>2006-01-18 18:29:26 +0800
commit703a16b94eb23335d392fd57fd871228e844c9df (patch)
treea52f39cebd68bfb9d077669a42def84cebd70a01
parent03d2ba1c961e9dec90be61e884023858a975a607 (diff)
downloadfreebsd-ports-gnome-703a16b94eb23335d392fd57fd871228e844c9df.tar.gz
freebsd-ports-gnome-703a16b94eb23335d392fd57fd871228e844c9df.tar.zst
freebsd-ports-gnome-703a16b94eb23335d392fd57fd871228e844c9df.zip
[patch] misc/tinderbox shouldn't allow no database to be selected
PR: ports/91943 Submitted by: Vasil Dimov <vd@datamax.bg> Approved by: edwin@mavetju.org
-rw-r--r--misc/tinderbox/Makefile4
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile4
-rw-r--r--ports-mgmt/tinderbox/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/misc/tinderbox/Makefile b/misc/tinderbox/Makefile
index 250e373b34bd..a6dc44d731a4 100644
--- a/misc/tinderbox/Makefile
+++ b/misc/tinderbox/Makefile
@@ -29,6 +29,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL)
+BROKEN= "Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 250e373b34bd..a6dc44d731a4 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -29,6 +29,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL)
+BROKEN= "Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 250e373b34bd..a6dc44d731a4 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -29,6 +29,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL)
+BROKEN= "Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql