aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2009-01-09 01:36:31 +0800
committererwin <erwin@FreeBSD.org>2009-01-09 01:36:31 +0800
commit70e8f66c70439ebaae2f2869968758d15d1e8679 (patch)
tree9b7c63ef0ff8587341e59296c404f4ab905ede07
parentad5849299be76fcb76bf5f0f01a7ae275d9aa077 (diff)
downloadfreebsd-ports-gnome-70e8f66c70439ebaae2f2869968758d15d1e8679.tar.gz
freebsd-ports-gnome-70e8f66c70439ebaae2f2869968758d15d1e8679.tar.zst
freebsd-ports-gnome-70e8f66c70439ebaae2f2869968758d15d1e8679.zip
Mark BROKEN on HEAD after the import of strndup(3).
As OSVERSION was not bumped at the time, approximate with 800058. Submitted by: pointyhat
-rw-r--r--graphics/ophoto/Makefile8
-rw-r--r--lang/eperl/Makefile4
-rw-r--r--lang/p5-ePerl/Makefile8
-rw-r--r--mail/smfsav/Makefile8
-rw-r--r--net/httping/Makefile8
5 files changed, 32 insertions, 4 deletions
diff --git a/graphics/ophoto/Makefile b/graphics/ophoto/Makefile
index e88c30f149e8..2b6bc0e615e2 100644
--- a/graphics/ophoto/Makefile
+++ b/graphics/ophoto/Makefile
@@ -20,4 +20,10 @@ PLIST_FILES= bin/ophoto
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ophoto ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index 2c2c97794ea2..77cf413847d5 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -36,6 +36,10 @@ MAN1= eperl.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
test:
@(cd ${WRKSRC}; ${MAKE} test)
diff --git a/lang/p5-ePerl/Makefile b/lang/p5-ePerl/Makefile
index 7074b139eb87..a2a121e35bd1 100644
--- a/lang/p5-ePerl/Makefile
+++ b/lang/p5-ePerl/Makefile
@@ -19,4 +19,10 @@ PERL_CONFIGURE= yes
MAN3= Parse::ePerl.3 Apache::ePerl.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/smfsav/Makefile b/mail/smfsav/Makefile
index 2104dc4bb085..bbfe0b1d53f8 100644
--- a/mail/smfsav/Makefile
+++ b/mail/smfsav/Makefile
@@ -56,4 +56,10 @@ post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 5f26b33c8827..7f5a1fc7edbf 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -22,4 +22,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>