aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-11-19 07:06:23 +0800
committerlioux <lioux@FreeBSD.org>2001-11-19 07:06:23 +0800
commit71f1aa633be7c436ac96f6bad8675bc5db6aa17a (patch)
tree970979131eda760cf94023fe4c3c4297aa8512dc
parent81cfc066fb8e8d78a2cd586aae3c32ef07206508 (diff)
downloadfreebsd-ports-gnome-71f1aa633be7c436ac96f6bad8675bc5db6aa17a.tar.gz
freebsd-ports-gnome-71f1aa633be7c436ac96f6bad8675bc5db6aa17a.tar.zst
freebsd-ports-gnome-71f1aa633be7c436ac96f6bad8675bc5db6aa17a.zip
o slave port handling enhancements
- special support for NO_WRKSUBDIR - support slaveport-post-install target Approved by: maintainer
-rw-r--r--games/hlserver-cs/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/games/hlserver-cs/Makefile b/games/hlserver-cs/Makefile
index 1f3477b41262..a1484fd7ed9b 100644
--- a/games/hlserver-cs/Makefile
+++ b/games/hlserver-cs/Makefile
@@ -31,10 +31,12 @@ NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
.if (${PORTNAME}==cs)
PORTREVISION= 1
-BUILD_DEPENDS= ${NONEXISTENT}:${HALFLIFESERVER_PORT}:patch
+BUILD_DEPENDS+= ${NONEXISTENT}:${HALFLIFESERVER_PORT}:patch
WRKSRC?= ${WRKDIR}/cstrike
.else
+.ifndef(NO_WRKSUBDIR)
WRKSRC?= ${WRKDIR}/${PORTNAME}
+.endif # NO_WRKSUBDIR
.endif
PLIST_SUB+= ${PLIST_SUB_MASTER}
@@ -85,6 +87,7 @@ install-parse-plist: generate-plist
-e 'chop($$file = <FHANDLER>);' \
-e '$$dir = $$file_partial = $$file;' \
-e '$$file_partial =~ s!^${HLDSDIR:S!^/!!}!!;' \
+ -e '$$file_partial =~ s!^[^/]+/!! if defined(${NO_WRKSUBDIR});' \
-e 'print FDIR "${INSTALL_DIR}", \
" ", "\"${PREFIX}/$$dir\"", \
"\n" if $$dir =~ s!(^\@dirrm\s+)!!;' \
@@ -104,7 +107,11 @@ install-run-scripts:
@${SH} ${WRKDIR}/${script}.sh
.endfor
-post-install:
+.if !target(slaveport-post-install)
+slaveport-post-install:
+.endif
+
+post-install: slaveport-post-install
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>