aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-09-03 05:24:00 +0800
committermi <mi@FreeBSD.org>2002-09-03 05:24:00 +0800
commit74753937cbdb4eabe12e11ad07b15a9a9b8a69db (patch)
tree78e58923b9243659705f99d4c7949a1f13ea7293
parenta2288137d13fcce9e626d7d2bcfc8e2ac182ae8d (diff)
downloadfreebsd-ports-gnome-74753937cbdb4eabe12e11ad07b15a9a9b8a69db.tar.gz
freebsd-ports-gnome-74753937cbdb4eabe12e11ad07b15a9a9b8a69db.tar.zst
freebsd-ports-gnome-74753937cbdb4eabe12e11ad07b15a9a9b8a69db.zip
Fix the conditional post-patch target to look in ${WRKSRC}, rather
than in the hardcoded hylafax-4.1 I goofed, when I implemented this back then, and the upgrader did not notice, because this is only invoked, when PREFIX is different from /usr/local Predicate USE_REINPLACE on PREFIX not being /usr/local too -- there is no need to demand the new sed otherwise. Set the REINPLACE_ARGS to -i "". I don't know, why this is not a default...
-rw-r--r--comms/hylafax/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 6b67bbaa4490..bc5a5e76ff86 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -36,7 +36,6 @@ CONFIGURE_ARGS+=--nointeractive
.endif
MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER
-USE_REINPLACE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
@@ -75,10 +74,12 @@ post-install:
.include <bsd.port.pre.mk>
.if ${LOCALBASE} != /usr/local
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
post-patch:
${REINPLACE_CMD} -e 's^/usr/local^${LOCALBASE}^g' \
- `find work/hylafax-4.1 -type f -print0 | \
- xargs -0 fgrep -l --mmap /usr/local`
+ `find ${WRKSRC} -type f -print0 | \
+ xargs -0 ${GREP} -F -l --mmap /usr/local`
.endif
.include <bsd.port.post.mk>