aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2010-02-12 06:44:25 +0800
committerdougb <dougb@FreeBSD.org>2010-02-12 06:44:25 +0800
commit7568b7c494da00c473f85730dd94bc39d87b21f6 (patch)
treeec0e758f24a4d75939bab2bb941b8152cc84363b
parent8b65a8231891051c992ad7719218dd8791d16868 (diff)
downloadfreebsd-ports-gnome-7568b7c494da00c473f85730dd94bc39d87b21f6.tar.gz
freebsd-ports-gnome-7568b7c494da00c473f85730dd94bc39d87b21f6.tar.zst
freebsd-ports-gnome-7568b7c494da00c473f85730dd94bc39d87b21f6.zip
Turns out the right place to fix the problem of subbing for
@BOOST_SYSTEM_LIB@ is in the libtorrent pkg-config file. While I'm here, mark libtorrent MAKE_JOBS_SAFE. Submitted by: Christophe Dumez (qbittorrent author)
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile7
-rw-r--r--net-p2p/qbittorrent-22/Makefile4
-rw-r--r--net-p2p/qbittorrent/Makefile4
-rw-r--r--net-p2p/rblibtorrent-devel/Makefile7
4 files changed, 14 insertions, 8 deletions
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index df698da0cbf1..39ab8974ed85 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libtorrent
PORTVERSION= 0.14.8
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.googlecode.com/files/
PKGNAMEPREFIX= rb
@@ -16,6 +17,8 @@ DISTNAME= ${PORTNAME}-rasterbar-${PORTVERSION}
MAINTAINER= dougb@FreeBSD.org
COMMENT= A C++ library implementing a BitTorrent client (devel version)
+MAKE_JOBS_SAFE= yes
+
LIB_DEPENDS= boost_date_time.4:${PORTSDIR}/devel/boost-libs
CONFLICTS= rblibtorrent-[0-9]*
@@ -50,4 +53,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|^AM_CFLAGS|AM_CPPFLAGS|g ; \
s|@BOOST_SYSTEM_LIB@||g' ${WRKSRC}/src/Makefile.am
+post-configure:
+ @${REINPLACE_CMD} -e 's|@BOOST_SYSTEM_LIB@|-lboost_system|' \
+ ${WRKSRC}/libtorrent-rasterbar.pc
+
.include <bsd.port.post.mk>
diff --git a/net-p2p/qbittorrent-22/Makefile b/net-p2p/qbittorrent-22/Makefile
index 2de4cde6c015..bde921d754ea 100644
--- a/net-p2p/qbittorrent-22/Makefile
+++ b/net-p2p/qbittorrent-22/Makefile
@@ -47,10 +47,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/configure
-post-configure:
- @${REINPLACE_CMD} -e 's|@BOOST_SYSTEM_LIB@|-lboost_system|' \
- ${WRKSRC}/conf.pri
-
post-install:
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 2de4cde6c015..bde921d754ea 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -47,10 +47,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/configure
-post-configure:
- @${REINPLACE_CMD} -e 's|@BOOST_SYSTEM_LIB@|-lboost_system|' \
- ${WRKSRC}/conf.pri
-
post-install:
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
diff --git a/net-p2p/rblibtorrent-devel/Makefile b/net-p2p/rblibtorrent-devel/Makefile
index df698da0cbf1..39ab8974ed85 100644
--- a/net-p2p/rblibtorrent-devel/Makefile
+++ b/net-p2p/rblibtorrent-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libtorrent
PORTVERSION= 0.14.8
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.googlecode.com/files/
PKGNAMEPREFIX= rb
@@ -16,6 +17,8 @@ DISTNAME= ${PORTNAME}-rasterbar-${PORTVERSION}
MAINTAINER= dougb@FreeBSD.org
COMMENT= A C++ library implementing a BitTorrent client (devel version)
+MAKE_JOBS_SAFE= yes
+
LIB_DEPENDS= boost_date_time.4:${PORTSDIR}/devel/boost-libs
CONFLICTS= rblibtorrent-[0-9]*
@@ -50,4 +53,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|^AM_CFLAGS|AM_CPPFLAGS|g ; \
s|@BOOST_SYSTEM_LIB@||g' ${WRKSRC}/src/Makefile.am
+post-configure:
+ @${REINPLACE_CMD} -e 's|@BOOST_SYSTEM_LIB@|-lboost_system|' \
+ ${WRKSRC}/libtorrent-rasterbar.pc
+
.include <bsd.port.post.mk>