aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-01-06 12:34:01 +0800
committerpat <pat@FreeBSD.org>2002-01-06 12:34:01 +0800
commit76db93f952d8ec74eec0905bd6bb08a66cfce895 (patch)
tree56a37fa752110c92a263e07258a3d7f74d5ec656
parent1309ab5bb44c03ee627e8607a5770896801db1e8 (diff)
downloadfreebsd-ports-gnome-76db93f952d8ec74eec0905bd6bb08a66cfce895.tar.gz
freebsd-ports-gnome-76db93f952d8ec74eec0905bd6bb08a66cfce895.tar.zst
freebsd-ports-gnome-76db93f952d8ec74eec0905bd6bb08a66cfce895.zip
Add port net/wmlj - a dockapp that monitors your friends on livejournal.com
PR: 33594 Submitted by: Sergei Barbarash <sgt@outline.ru>
-rw-r--r--net/Makefile1
-rw-r--r--net/wmlj/Makefile24
-rw-r--r--net/wmlj/distinfo1
-rw-r--r--net/wmlj/pkg-comment1
-rw-r--r--net/wmlj/pkg-descr7
-rw-r--r--net/wmlj/pkg-plist1
6 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 91914a3b229b..4b3067448406 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -480,6 +480,7 @@
SUBDIR += walker
SUBDIR += whatmask
SUBDIR += wide-dhcp
+ SUBDIR += wmlj
SUBDIR += wmnd
SUBDIR += wmnet
SUBDIR += wmnet2
diff --git a/net/wmlj/Makefile b/net/wmlj/Makefile
new file mode 100644
index 000000000000..d2a9a0cbc3dc
--- /dev/null
+++ b/net/wmlj/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: wmlj
+# Date created: 6 January 2002
+# Whom: Sergei Barbarash <sgt@outline.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmlj
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://telia.dl.sourceforge.net/wmlj/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sgt@outline.ru
+
+LIB_DEPENDS= curl.2:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_GTK= yes
+
+MAN1= wmlj.1
+
+.include <bsd.port.mk>
diff --git a/net/wmlj/distinfo b/net/wmlj/distinfo
new file mode 100644
index 000000000000..0f4fede6d40b
--- /dev/null
+++ b/net/wmlj/distinfo
@@ -0,0 +1 @@
+MD5 (wmlj-0.1.tar.gz) = 4ff2c46aef91013409680e717aaac9b3
diff --git a/net/wmlj/pkg-comment b/net/wmlj/pkg-comment
new file mode 100644
index 000000000000..f1fc48278b95
--- /dev/null
+++ b/net/wmlj/pkg-comment
@@ -0,0 +1 @@
+A dockapp that monitors your friends list at LiveJournal.com
diff --git a/net/wmlj/pkg-descr b/net/wmlj/pkg-descr
new file mode 100644
index 000000000000..46bf1446d17f
--- /dev/null
+++ b/net/wmlj/pkg-descr
@@ -0,0 +1,7 @@
+wmlj monitors your Friends List at LiveJournal.com, an online
+journaling service. It's designed to sit at your WindowMaker dock
+panel. It checks the Friends List for updates every given time
+interval, and if some of your friends post new entries, it signals
+you with a neat graphic animation sequence.
+
+WWW: http://wmlj.sourceforge.net/
diff --git a/net/wmlj/pkg-plist b/net/wmlj/pkg-plist
new file mode 100644
index 000000000000..8d32ffa1f7be
--- /dev/null
+++ b/net/wmlj/pkg-plist
@@ -0,0 +1 @@
+bin/wmlj