aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-03-07 04:25:38 +0800
committermm <mm@FreeBSD.org>2011-03-07 04:25:38 +0800
commit7736d958988f5d6bcf61aa048b5ecee16cc95159 (patch)
tree6ce48792c57ed6202e9a2bb2583cd0129c4f7c7d
parent28f65301d7005388b63b517ee87cfa1341888695 (diff)
downloadfreebsd-ports-gnome-7736d958988f5d6bcf61aa048b5ecee16cc95159.tar.gz
freebsd-ports-gnome-7736d958988f5d6bcf61aa048b5ecee16cc95159.tar.zst
freebsd-ports-gnome-7736d958988f5d6bcf61aa048b5ecee16cc95159.zip
- Fix library linking in libevent.pc [1]
- Add compatibility include to libevent.pc [2] PR: ports/155315 [1], ports/155293 [2] Submitted by: Jeremy Messenger <mezz@FreeBSD.org> [1] Suggested by: swell.k@gmail.com [2]
-rw-r--r--devel/libevent2/Makefile1
-rw-r--r--devel/libevent2/files/patch-libevent.pc.in12
-rw-r--r--devel/libevent2/files/patch-libevent_openssl.pc.in12
-rw-r--r--devel/libevent2/files/patch-libevent_pthreads.pc.in12
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/libevent2/Makefile b/devel/libevent2/Makefile
index 3459c0b47088..041b2669728d 100644
--- a/devel/libevent2/Makefile
+++ b/devel/libevent2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libevent2
DISTVERSION= 2.0.10
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://monkey.org/~provos/
DISTNAME= ${PORTNAME:S/2//}-${DISTVERSION}-stable
diff --git a/devel/libevent2/files/patch-libevent.pc.in b/devel/libevent2/files/patch-libevent.pc.in
new file mode 100644
index 000000000000..484bec3f07de
--- /dev/null
+++ b/devel/libevent2/files/patch-libevent.pc.in
@@ -0,0 +1,12 @@
+--- libevent.pc.in.orig 2010-08-15 15:21:18.000000000 +0200
++++ libevent.pc.in 2011-03-06 21:15:00.816214067 +0100
+@@ -10,7 +10,7 @@
+ Version: @VERSION@
+ Requires:
+ Conflicts:
+-Libs: -L${libdir} -levent
++Libs: -L${libdir} -levent-2.0
+ Libs.private: @LIBS@
+-Cflags: -I${includedir}
++Cflags: -I${includedir} -I${includedir}/event2/compat
+
diff --git a/devel/libevent2/files/patch-libevent_openssl.pc.in b/devel/libevent2/files/patch-libevent_openssl.pc.in
new file mode 100644
index 000000000000..0b8bfd49d663
--- /dev/null
+++ b/devel/libevent2/files/patch-libevent_openssl.pc.in
@@ -0,0 +1,12 @@
+--- libevent_openssl.pc.in.orig 2010-08-16 18:56:09.000000000 +0200
++++ libevent_openssl.pc.in 2011-03-06 21:15:11.687161250 +0100
+@@ -10,7 +10,7 @@
+ Version: @VERSION@
+ Requires: libevent
+ Conflicts:
+-Libs: -L${libdir} -levent_openssl
++Libs: -L${libdir} -levent_openssl-2.0
+ Libs.private: @LIBS@ -lcrypto -lssl
+-Cflags: -I${includedir}
++Cflags: -I${includedir} -I${includedir}/event2/compat
+
diff --git a/devel/libevent2/files/patch-libevent_pthreads.pc.in b/devel/libevent2/files/patch-libevent_pthreads.pc.in
new file mode 100644
index 000000000000..a2d3d7d77435
--- /dev/null
+++ b/devel/libevent2/files/patch-libevent_pthreads.pc.in
@@ -0,0 +1,12 @@
+--- libevent_pthreads.pc.in.orig 2010-08-16 18:56:09.000000000 +0200
++++ libevent_pthreads.pc.in 2011-03-06 21:15:25.621208481 +0100
+@@ -10,7 +10,7 @@
+ Version: @VERSION@
+ Requires: libevent
+ Conflicts:
+-Libs: -L${libdir} -levent_pthreads
++Libs: -L${libdir} -levent_pthreads-2.0
+ Libs.private: @LIBS@ @PTHREAD_LIBS@
+-Cflags: -I${includedir} @PTHREAD_CFLAGS@
++Cflags: -I${includedir} -I${includedir}/event2/compat @PTHREAD_CFLAGS@
+