aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-31 18:40:21 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-31 18:40:21 +0800
commit77a19315143cab4c6741aa41df232634c102e1af (patch)
treecab1c961f5250ffaf039013f8ee7f8776fa3bab1
parent423282be5c48d94c58e8af1f138bd9e01b094639 (diff)
downloadfreebsd-ports-gnome-77a19315143cab4c6741aa41df232634c102e1af.tar.gz
freebsd-ports-gnome-77a19315143cab4c6741aa41df232634c102e1af.tar.zst
freebsd-ports-gnome-77a19315143cab4c6741aa41df232634c102e1af.zip
- Add LICENSE
- Use PYDISTUTILS_AUTOPLIST - Use USES=twisted - Bump PORTREVISION for dependency change - Reformat pkg-descr
-rw-r--r--net/pythondirector/Makefile16
-rw-r--r--net/pythondirector/pkg-descr30
-rw-r--r--net/pythondirector/pkg-plist38
3 files changed, 23 insertions, 61 deletions
diff --git a/net/pythondirector/Makefile b/net/pythondirector/Makefile
index dc5a44d34c46..50277c396fa1 100644
--- a/net/pythondirector/Makefile
+++ b/net/pythondirector/Makefile
@@ -3,22 +3,24 @@
PORTNAME= pydirector
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= SF/pythondirector/pythondirector/pythondirector-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= TCP load balancer written in Python
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted
+LICENSE= MIT
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PORTDOCS= *
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+USES= twisted:run
-OPTIONS_DEFINE= DOCS
+PORTDOCS= *
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/net/pythondirector/pkg-descr b/net/pythondirector/pkg-descr
index 5be105a4ee86..5023da89ce85 100644
--- a/net/pythondirector/pkg-descr
+++ b/net/pythondirector/pkg-descr
@@ -1,20 +1,18 @@
-This is a pure-python TCP load balancer. It takes inbound TCP
-connections and connects them to one of a number of backend servers.
+This is a pure-python TCP load balancer. It takes inbound TCP connections and
+connects them to one of a number of backend servers.
Features:
- * async i/o based, so much less overhead than fork/thread based
- balancers.
- * Multiple scheduling algorithms (random, round robin, leastconns,
- leastconns+roundrobin)
- * If a server fails to answer, it's removed from the pool - the
- client that failed to connect gets transparently failed over to a
- new host.
- * xml based configuration file
- * separate management thread that periodically re-adds failed hosts
- if they've come back up.
- * optional builtin webserver for admin (sample of the running
- screen)
- * webserver has methods suitable for both interactive and automated
- systems
+- async i/o based, so much less overhead than fork/thread based balancers. Can
+ use either twisted or python's standard asyncore library (twisted is
+ recommended, and asyncore support will be removed in a future version).
+- Multiple scheduling algorithms (random, round robin, leastconns,
+ leastconns+roundrobin)
+- If a server fails to answer, it's removed from the pool - the client that
+ failed to connect gets transparently failed over to a new host.
+- xml based configuration file (see a sample)
+- seperate management thread that periodically re-adds failed hosts if they've
+ come back up.
+- optional builtin webserver for admin (sample of the running screen)
+- webserver has methods suitable for both interactive and automated systems
WWW: http://pythondirector.sourceforge.net/
diff --git a/net/pythondirector/pkg-plist b/net/pythondirector/pkg-plist
deleted file mode 100644
index 62609e06969d..000000000000
--- a/net/pythondirector/pkg-plist
+++ /dev/null
@@ -1,38 +0,0 @@
-bin/pydir.py
-%%PYTHON_SITELIBDIR%%/pydirector/__init__.py
-%%PYTHON_SITELIBDIR%%/pydirector/__init__.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/__init__.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/compareconf.py
-%%PYTHON_SITELIBDIR%%/pydirector/compareconf.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/compareconf.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/micropubl.py
-%%PYTHON_SITELIBDIR%%/pydirector/micropubl.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/micropubl.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdadmin.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdadmin.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdadmin.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdconf.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdconf.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdconf.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdlogging.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdlogging.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdlogging.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdmain.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdmain.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdmain.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdmanager.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdmanager.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdmanager.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetwork.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetwork.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetwork.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetworkasyncore.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetworkasyncore.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetworkasyncore.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetworktwisted.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetworktwisted.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdnetworktwisted.pyo
-%%PYTHON_SITELIBDIR%%/pydirector/pdschedulers.py
-%%PYTHON_SITELIBDIR%%/pydirector/pdschedulers.pyc
-%%PYTHON_SITELIBDIR%%/pydirector/pdschedulers.pyo
-@dirrm %%PYTHON_SITELIBDIR%%/pydirector