aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-03 23:25:41 +0800
committerbapt <bapt@FreeBSD.org>2013-09-03 23:25:41 +0800
commit7891699e17e40d001853a94b5e24e9d59bfe0eb9 (patch)
tree684b0feb12b2ef6df078c657dbd67257aba8102f
parent542fc866c4c8a722a822fe50c7b3ad9db8c9c54a (diff)
downloadfreebsd-ports-gnome-7891699e17e40d001853a94b5e24e9d59bfe0eb9.tar.gz
freebsd-ports-gnome-7891699e17e40d001853a94b5e24e9d59bfe0eb9.tar.zst
freebsd-ports-gnome-7891699e17e40d001853a94b5e24e9d59bfe0eb9.zip
Add en explicit dependency on pkgconf
-rw-r--r--devel/seed/Makefile3
-rw-r--r--graphics/evince/Makefile3
-rw-r--r--mail/evolution/Makefile3
-rw-r--r--net/vinagre/Makefile3
-rw-r--r--ports-mgmt/gnome-packagekit/Makefile3
-rw-r--r--sysutils/brasero/Makefile3
6 files changed, 6 insertions, 12 deletions
diff --git a/devel/seed/Makefile b/devel/seed/Makefile
index ec7b11fa5fd5..3e15889de243 100644
--- a/devel/seed/Makefile
+++ b/devel/seed/Makefile
@@ -25,12 +25,11 @@ CONFLICTS= seed-3.[0-9]*
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= gnomehack gtk20 intltool libxml2
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
USE_SQLITE= yes
-USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--enable-gtk-doc=no --with-webkit=1.0
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 80c280025374..5f3e7d100622 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -25,9 +25,8 @@ USE_LDCONFIG= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
INSTALLS_ICONS= yes
-USE_GMAKE= yes
INSTALLS_OMF= yes
-USES= desktop-file-utils gettext pathfix
+USES= desktop-file-utils gettext pathfix gmake pkgconfig
USE_GNOME= intlhack gnomeprefix gnomedocutils ltasneededhack gconf2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index cd2f9c4c9727..b28d99fe69a3 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORT
CONFLICTS= evolution-3.[0-9]*
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= bison desktop-file-utils gettext pathfix
+USES= bison desktop-file-utils gettext pathfix gmake pkgconfig
USE_GNOME= gnomeprefix intlhack evolutiondataserver gtkhtml3 \
gnomedocutils ltasneededhack gnomedesktop
USE_AUTOTOOLS= libtool
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
index 144625d09eea..7ec91a150ee2 100644
--- a/net/vinagre/Makefile
+++ b/net/vinagre/Makefile
@@ -21,9 +21,8 @@ LIB_DEPENDS= gtk-vnc-1.0:${PORTSDIR}/net/gtk-vnc \
CONFLICTS= vinagre-3.[0-9]*
USE_BZIP2= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix intlhack vte gconf2 gnomedocutils gnomepanel
-USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
diff --git a/ports-mgmt/gnome-packagekit/Makefile b/ports-mgmt/gnome-packagekit/Makefile
index 8ff4e441221c..af3536e0dd52 100644
--- a/ports-mgmt/gnome-packagekit/Makefile
+++ b/ports-mgmt/gnome-packagekit/Makefile
@@ -19,10 +19,9 @@ LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
upower-glib:${PORTSDIR}/sysutils/upower \
canberra-gtk:${PORTSDIR}/audio/libcanberra
-USE_GMAKE= yes
USE_BZIP2= yes
USE_GNOME= gnomeprefix intlhack gconf2 gnomemenus gnomedocutils
-USES= desktop-file-utils gettext iconv pathfix
+USES= desktop-file-utils gettext iconv pathfix gmake pkgconfig
USE_PYTHON_BUILD=-2.7
GCONF_SCHEMAS= gnome-packagekit.schemas
INSTALLS_ICONS= yes
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index e734eb207376..ef48ae9393f1 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -24,9 +24,8 @@ CONFLICTS= brasero-3.[0-9]*
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_XORG= sm
-USES= pathfix gettext shared-mime-info
+USES= pathfix gettext shared-mime-info gmake pkgconfig
USE_GNOME= intlhack gnomeprefix gnomedocutils
USE_LDCONFIG= yes
USE_GSTREAMER= gconf core