aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-11-28 21:06:27 +0800
committerhq <hq@FreeBSD.org>2005-11-28 21:06:27 +0800
commit79176b7b34109fcd9fb5ad09bda50a2181931cb9 (patch)
tree245939a4417ad4dd72c6c17e3cadfc13007b7792
parent4149afe5e055ea9b261f5569a24bc413e6ec17a2 (diff)
downloadfreebsd-ports-gnome-79176b7b34109fcd9fb5ad09bda50a2181931cb9.tar.gz
freebsd-ports-gnome-79176b7b34109fcd9fb5ad09bda50a2181931cb9.tar.zst
freebsd-ports-gnome-79176b7b34109fcd9fb5ad09bda50a2181931cb9.zip
- Disable Jikes to avoid trouble with JDK 1.3
- Disable building extra documentation when not using JDK 1.5 as the Xalan processor used to tranform the XML source files seems to try and use X11 (which fails if built by superuser in a console) [1] NOTE: When using JDK 1.5 (java/jdk15) this error does not occur so it seems like we could find a fix for that. Otherwise I will probably convert the port to a binary one. Reported by: pointyhat [1]
-rw-r--r--textproc/xerces-j/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/textproc/xerces-j/Makefile b/textproc/xerces-j/Makefile
index e16ef205a655..35327f8817fd 100644
--- a/textproc/xerces-j/Makefile
+++ b/textproc/xerces-j/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= xml4j-4.*
USE_JAVA= yes
JAVA_VERSION= 1.3+
USE_ANT= yes
+USE_JIKES= no
WRKSRC= ${WRKDIR}/xerces-${PORTVERSION:S/./_/g}
@@ -32,7 +33,10 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
ALL_TARGET= jars
.if !defined(NOPORTDOCS)
-ALL_TARGET+= javadocs docs
+ALL_TARGET+= javadocs
+.if ${JAVA_PORT_VERSION:C/[0-9]\.([0-9])\.[0-9]/\1/} == "5"
+ALL_TARGET+= docs
+.endif
PORTDOCS= *
.endif