aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-24 19:49:37 +0800
committeredwin <edwin@FreeBSD.org>2005-11-24 19:49:37 +0800
commit7917871d5c061a20ad84cbcac8038c5c3640ec8b (patch)
tree3b0c9e3153e88ce6b7105249f3f215c1c87c535b
parent48d2fb520d2152dc2cf72bdd5014d2985f37ec9e (diff)
downloadfreebsd-ports-gnome-7917871d5c061a20ad84cbcac8038c5c3640ec8b.tar.gz
freebsd-ports-gnome-7917871d5c061a20ad84cbcac8038c5c3640ec8b.tar.zst
freebsd-ports-gnome-7917871d5c061a20ad84cbcac8038c5c3640ec8b.zip
New port: comm/uticom
usbcomm driver for TUSB3410 uart-to-usb converter WWW: http://sf.net/projects/uticom PR: ports/87809 Submitted by: Dmitry Komissaroff <dxi@mail.ru>
-rw-r--r--comms/Makefile1
-rw-r--r--comms/uticom/Makefile38
-rw-r--r--comms/uticom/distinfo2
-rw-r--r--comms/uticom/pkg-descr3
-rw-r--r--comms/uticom/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 75f74418bf03..46a428de9b29 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -102,6 +102,7 @@
SUBDIR += trustedqsl
SUBDIR += twpsk
SUBDIR += uird
+ SUBDIR += uticom
SUBDIR += viewfax
SUBDIR += vpb-driver
SUBDIR += vpb2
diff --git a/comms/uticom/Makefile b/comms/uticom/Makefile
new file mode 100644
index 000000000000..76e61d7554d1
--- /dev/null
+++ b/comms/uticom/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: uticom
+# Date created: 17-10-2005
+# Whom: Dmitry Komissaroff <dxi@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uticom
+PORTVERSION= 0.1
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= uticom-${PORTVERSION}
+
+MAINTAINER= dxi@mail.ru
+COMMENT= A FreeBSD Driver for TUSB3410 uart-to-usb converter
+
+NO_PACKAGE= "Should be in sync with the kernel to work correctly"
+
+ONLY_FOR_ARCHS= i386
+SRCPREFIX?= /usr/src
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+LOCALBASE= /boot/kernel
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD < 5.0 are not supported
+.endif
+
+# Make sure kernel sources are present before going any further
+.if ! exists(${SRCPREFIX}/sys/dev/usb/usb.c)
+IGNORE= You need to extract kernel source tree before building this package
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/uticom/distinfo b/comms/uticom/distinfo
new file mode 100644
index 000000000000..bd09634ceca4
--- /dev/null
+++ b/comms/uticom/distinfo
@@ -0,0 +1,2 @@
+MD5 (uticom-0.1.tar.gz) = c59c6bca627a5aa546d476ee25f510c1
+SIZE (uticom-0.1.tar.gz) = 14552
diff --git a/comms/uticom/pkg-descr b/comms/uticom/pkg-descr
new file mode 100644
index 000000000000..4116cb2821cb
--- /dev/null
+++ b/comms/uticom/pkg-descr
@@ -0,0 +1,3 @@
+FreeBSD Driver for TUSB3410 uart-to-usb converter.
+
+WWW: http://sf.net/projects/uticom
diff --git a/comms/uticom/pkg-plist b/comms/uticom/pkg-plist
new file mode 100644
index 000000000000..d2d381ac8ead
--- /dev/null
+++ b/comms/uticom/pkg-plist
@@ -0,0 +1 @@
+uticom.ko