aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-03-28 00:05:35 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-03-28 00:05:35 +0800
commit79b2f68f57175f7868ebda5cec0fcd8f96a124f9 (patch)
treeb3629c116f4fa693e225f0ae6e6cf800e0a63580
parentdc2426614238a17405f845932dd142643edc0be3 (diff)
downloadfreebsd-ports-gnome-79b2f68f57175f7868ebda5cec0fcd8f96a124f9.tar.gz
freebsd-ports-gnome-79b2f68f57175f7868ebda5cec0fcd8f96a124f9.tar.zst
freebsd-ports-gnome-79b2f68f57175f7868ebda5cec0fcd8f96a124f9.zip
PR: 45711
Submitted by: Olivier Tharan <olive@oban.frmug.org> Approved by: MAINTAINER Upgrade to 0.2.4, and switch MAINTAINERship.
-rw-r--r--mail/gbuffy/Makefile4
-rw-r--r--mail/gbuffy/distinfo2
-rw-r--r--mail/gbuffy/files/patch-imap64
3 files changed, 3 insertions, 67 deletions
diff --git a/mail/gbuffy/Makefile b/mail/gbuffy/Makefile
index 734486e3be1a..69679d51a5a8 100644
--- a/mail/gbuffy/Makefile
+++ b/mail/gbuffy/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= gbuffy
-PORTVERSION= 0.2.2
+PORTVERSION= 0.2.4
CATEGORIES= mail
MASTER_SITES= http://www.fiction.net/blong/programs/gbuffy/
-MAINTAINER= rasmus@kaj.se
+MAINTAINER= olive@oban.frmug.org
COMMENT= A GTK+ multiple mailbox "biff" program
LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList \
diff --git a/mail/gbuffy/distinfo b/mail/gbuffy/distinfo
index 1d1ae0eff0db..dfe4c721d8e3 100644
--- a/mail/gbuffy/distinfo
+++ b/mail/gbuffy/distinfo
@@ -1 +1 @@
-MD5 (gbuffy-0.2.2.tar.gz) = eaad334173654185ef9560f47ba54d74
+MD5 (gbuffy-0.2.4.tar.gz) = aae7b2b88edb6e1a0969346b355fce68
diff --git a/mail/gbuffy/files/patch-imap b/mail/gbuffy/files/patch-imap
deleted file mode 100644
index b92e29d36adc..000000000000
--- a/mail/gbuffy/files/patch-imap
+++ /dev/null
@@ -1,64 +0,0 @@
---- imap.c.orig Mon Aug 2 09:41:38 1999
-+++ imap.c Sat Jul 15 19:49:45 2000
-@@ -318,12 +318,12 @@
- static int parse_fetch (BOX_INFO *ibox, CONNECTION *conn, GList *headers,
- int unseen)
- {
-- char from[STRING] = "";
-- char subject[STRING] = "";
-- char xface[STRING] = "";
-+ char from[LONG_STRING] = "";
-+ char subject[LONG_STRING] = "";
-+ char xface[LONG_STRING] = "";
- char buf[LONG_STRING];
- char seq[8];
-- char *s;
-+ char *s, *last_head;
- int recent = 0;
-
-
-@@ -339,8 +339,7 @@
- return (-1);
- }
-
-- if (buf[0] == '*')
-- {
-+ if (buf[0] == '*') {
- s = imap_next_word (buf);
- if (!isdigit (*s))
- continue;
-@@ -377,10 +376,12 @@
- if (!strncasecmp (buf, "From:", 5))
- {
- rfc2047_decode (from, buf, sizeof (from));
-+ last_head = from;
- }
- else if (!strncasecmp (buf, "Subject:", 8))
- {
- rfc2047_decode (subject, buf, sizeof (subject));
-+ last_head = subject;
- }
- else if (!strncasecmp (buf, "X-Face:", 7))
- {
-@@ -389,6 +390,21 @@
- strfcpy (xface, s, sizeof (xface));
- if (strlen (s) > sizeof (xface))
- g_print ("-E- xface header is larger than buffer\n");
-+ last_head = xface;
-+ }
-+ else if (ISSPACE(buf[0])) {
-+ s = buf;
-+ while (*s && ISSPACE (*s)) s++;
-+ if(strlen(s) + strlen(last_head) + 1 > LONG_STRING)
-+ g_print ("-E- a continuing header is larger than buffer\n");
-+ else {
-+ /* If this is an X-Face line the space don't matter, but if this
-+ * is any other header the space is required. */
-+ strcat(last_head, " ");
-+ strncat(last_head, s, LONG_STRING - strlen(last_head));
-+ }
-+ } else {
-+ last_head = NULL;
- }
- }
- }