aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-14 00:56:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-14 00:56:26 +0800
commit7c083a5ee781df4f16ed786c31cab1e4f3be1137 (patch)
tree0d11f4acda6470be8c44ea5d758f9f0fd7cc8387
parent4cdf38b4a7e912576c63eb1e626df59b6d19e7d6 (diff)
downloadfreebsd-ports-gnome-7c083a5ee781df4f16ed786c31cab1e4f3be1137.tar.gz
freebsd-ports-gnome-7c083a5ee781df4f16ed786c31cab1e4f3be1137.tar.zst
freebsd-ports-gnome-7c083a5ee781df4f16ed786c31cab1e4f3be1137.zip
- Add p5-XML-LibXML-Cache 0.10
XML::LibXML::Cache is a cache for XML::LibXML documents loaded from files. It is useful to speed up loading of XML files in persistent web applications. This module caches the document object after the first load and returns the cached version on subsequent loads. Documents are reloaded whenever the document file changes. Changes to other files referenced during parsing also cause a reload. This includes external DTDs, external entities or XIncludes. WWW: http://search.cpan.org/dist/XML-LibXML-Cache/ Feature safe: yes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-LibXML-Cache/Makefile33
-rw-r--r--textproc/p5-XML-LibXML-Cache/distinfo2
-rw-r--r--textproc/p5-XML-LibXML-Cache/pkg-descr9
-rw-r--r--textproc/p5-XML-LibXML-Cache/pkg-plist11
5 files changed, 56 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 76ab63f47d84..bb3fba8e6bf2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -915,6 +915,7 @@
SUBDIR += p5-XML-Handler-YAWriter
SUBDIR += p5-XML-Hash-LX
SUBDIR += p5-XML-LibXML
+ SUBDIR += p5-XML-LibXML-Cache
SUBDIR += p5-XML-LibXML-Iterator
SUBDIR += p5-XML-LibXML-PrettyPrint
SUBDIR += p5-XML-LibXML-SAX-ChunkParser
diff --git a/textproc/p5-XML-LibXML-Cache/Makefile b/textproc/p5-XML-LibXML-Cache/Makefile
new file mode 100644
index 000000000000..d238f10d7e74
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Cache/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-XML-LibXML-Cache
+# Date created: 2011-09-11
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXML-Cache
+PORTVERSION= 0.10
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Document cache for XML::LibXML
+
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-LibXML>=1.59:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-XML-LibXSLT>=1.59:${PORTSDIR}/textproc/p5-XML-LibXSLT
+RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-LibXML>=1.59:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-XML-LibXSLT>=1.59:${PORTSDIR}/textproc/p5-XML-LibXSLT
+
+TEST_DEPENDS= p5-File-Touch>=0:${PORTSDIR}/devel/p5-File-Touch \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::LibXML::Cache.3 \
+ XML::LibXML::Cache::Base.3 \
+ XML::LibXSLT::Cache.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-LibXML-Cache/distinfo b/textproc/p5-XML-LibXML-Cache/distinfo
new file mode 100644
index 000000000000..235bfa99a477
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Cache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XML-LibXML-Cache-0.10.tar.gz) = 975dd0b3ce73c24fdf4da87e01dd851d7e6719ba7833e20d5e30c963054eced0
+SIZE (XML-LibXML-Cache-0.10.tar.gz) = 11534
diff --git a/textproc/p5-XML-LibXML-Cache/pkg-descr b/textproc/p5-XML-LibXML-Cache/pkg-descr
new file mode 100644
index 000000000000..08dd360da235
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Cache/pkg-descr
@@ -0,0 +1,9 @@
+XML::LibXML::Cache is a cache for XML::LibXML documents loaded from files. It is
+useful to speed up loading of XML files in persistent web applications.
+
+This module caches the document object after the first load and returns the
+cached version on subsequent loads. Documents are reloaded whenever the document
+file changes. Changes to other files referenced during parsing also cause a
+reload. This includes external DTDs, external entities or XIncludes.
+
+WWW: http://search.cpan.org/dist/XML-LibXML-Cache/
diff --git a/textproc/p5-XML-LibXML-Cache/pkg-plist b/textproc/p5-XML-LibXML-Cache/pkg-plist
new file mode 100644
index 000000000000..7f2a47a2ca97
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Cache/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/XML/LibXML/Cache.pm
+%%SITE_PERL%%/XML/LibXML/Cache/Base.pm
+%%SITE_PERL%%/XML/LibXSLT/Cache.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML/Cache/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML/Cache
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/LibXSLT
+@dirrm %%SITE_PERL%%/XML/LibXML/Cache
+@dirrmtry %%SITE_PERL%%/XML/LibXML
+@dirrmtry %%SITE_PERL%%/XML