aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-09-14 00:49:28 +0800
committersobomax <sobomax@FreeBSD.org>2002-09-14 00:49:28 +0800
commit7c87c06e5b4d234930300e071e8fc03b1fb163b9 (patch)
tree732b26612830a843046ad53ef8d1a342814f3e78
parent0995f919972ed6837445211cafd5965688286c20 (diff)
downloadfreebsd-ports-gnome-7c87c06e5b4d234930300e071e8fc03b1fb163b9.tar.gz
freebsd-ports-gnome-7c87c06e5b4d234930300e071e8fc03b1fb163b9.tar.zst
freebsd-ports-gnome-7c87c06e5b4d234930300e071e8fc03b1fb163b9.zip
Add frontline 0.5.1, an autotrace GUI FRONTend like streamLINE(TM).
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/frontline/Makefile30
-rw-r--r--graphics/frontline/distinfo1
-rw-r--r--graphics/frontline/pkg-comment1
-rw-r--r--graphics/frontline/pkg-descr12
-rw-r--r--graphics/frontline/pkg-plist22
6 files changed, 67 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f2c02bcfce35..7aebd0f18f2b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -71,6 +71,7 @@
SUBDIR += fly
SUBDIR += fnlib
SUBDIR += fractorama
+ SUBDIR += frontline
SUBDIR += fujiplay
SUBDIR += fxtv
SUBDIR += g2
diff --git a/graphics/frontline/Makefile b/graphics/frontline/Makefile
new file mode 100644
index 000000000000..82c2d05a2ef9
--- /dev/null
+++ b/graphics/frontline/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: frontline
+# Date created: 12 September 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= frontline
+PORTVERSION= 0.5.1
+CATEGORIES= graphics gnome
+MASTER_SITES= http://autotrace.sourceforge.net/frontline/
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= autotrace.1:${PORTSDIR}/graphics/autotrace \
+ art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs imlib
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/graphics/frontline/distinfo b/graphics/frontline/distinfo
new file mode 100644
index 000000000000..dc1e13bf89e9
--- /dev/null
+++ b/graphics/frontline/distinfo
@@ -0,0 +1 @@
+MD5 (frontline-0.5.1.tar.gz) = 5a1f5d7b5bf8ef7d54a8531592b56a61
diff --git a/graphics/frontline/pkg-comment b/graphics/frontline/pkg-comment
new file mode 100644
index 000000000000..ba8965d1fe6a
--- /dev/null
+++ b/graphics/frontline/pkg-comment
@@ -0,0 +1 @@
+An autotrace GUI FRONTend like streamLINE(TM)
diff --git a/graphics/frontline/pkg-descr b/graphics/frontline/pkg-descr
new file mode 100644
index 000000000000..c1e5e9120053
--- /dev/null
+++ b/graphics/frontline/pkg-descr
@@ -0,0 +1,12 @@
+Frontline provides a gtk+/gnome based GUI frontend for
+autotrace (http://autotrace.sourceforge.net) in 4 ways.
+
+1. Stand alone program. A command `frontline' runs as a stand alone
+ program. It will work well with Gnome desktop and nautilus.
+
+2. Reusable library. A library `libfrontline.a' could be used as a
+ building block of your application that needs the autotrace function.
+ APIs are listed in frontline.h. The stand alone program frontline
+ itself uses libfrontline.a.
+
+WWW: http://autotrace.sourceforge.net/frontline/
diff --git a/graphics/frontline/pkg-plist b/graphics/frontline/pkg-plist
new file mode 100644
index 000000000000..2a769315a69f
--- /dev/null
+++ b/graphics/frontline/pkg-plist
@@ -0,0 +1,22 @@
+bin/frontline
+bin/frontline-config
+include/frontline/fl_ask.h
+include/frontline/fl_dialog.h
+include/frontline/fl_ext.h
+include/frontline/fl_fsel.h
+include/frontline/fl_opt.h
+include/frontline/fl_preview.h
+include/frontline/fl_prog.h
+include/frontline/frontline.h
+include/gundo/gundo.h
+include/gundo/gundo_ui.h
+lib/libfrontline.a
+lib/libgundo.a
+libdata/pkgconfig/frontline.pc
+share/aclocal/frontline.m4
+share/gnome/apps/Graphics/frontline.desktop
+share/gnome/mime-info/frontline.keys
+share/gnome/mime-info/frontline.mime
+share/gnome/pixmaps/frontline.png
+@dirrm include/gundo
+@dirrm include/frontline