aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-02-26 03:02:30 +0800
committerknu <knu@FreeBSD.org>2001-02-26 03:02:30 +0800
commit7cb0619ff297809b7938c669b1ec182c5ff3b5dc (patch)
treeae150aeb07e14c59dbc453190af9bd4fd53b440e
parentae7e8ba4c71baba5dd378539815b3eda1e23454b (diff)
downloadfreebsd-ports-gnome-7cb0619ff297809b7938c669b1ec182c5ff3b5dc.tar.gz
freebsd-ports-gnome-7cb0619ff297809b7938c669b1ec182c5ff3b5dc.tar.zst
freebsd-ports-gnome-7cb0619ff297809b7938c669b1ec182c5ff3b5dc.zip
Conditionalize the IPv6 support. (${OSVERSION} >= 400014)
-rw-r--r--japanese/xchat/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/japanese/xchat/Makefile b/japanese/xchat/Makefile
index 043fdef2d94c..9988373f16f1 100644
--- a/japanese/xchat/Makefile
+++ b/japanese/xchat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xchat
PORTVERSION= 1.4.3
PORTREVISION= 2
-CATEGORIES= japanese irc gnome ipv6
+CATEGORIES= japanese irc gnome
MASTER_SITES= http://xchat.org/files/source/1.4/ \
http://xchat.linuxpower.org/files/source/1.4/
@@ -27,7 +27,7 @@ PLIST= ${.CURDIR}/pkg-plist
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-japanese-conv --enable-ipv6
+CONFIGURE_ARGS= --enable-japanese-conv
MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv -lintl"
@@ -44,6 +44,11 @@ CONFIGURE_ARGS+=--disable-python
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 400014
+CATEGORIES+= ipv6
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
+
.if defined(WITH_SOCKS)
# Assign with `+=' for slave ports
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5