aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-05-31 21:46:04 +0800
committerpawel <pawel@FreeBSD.org>2014-05-31 21:46:04 +0800
commit7d05c0b0aaafe4d673eaac8b42e1c534080342ae (patch)
treec9e9227bc5d57097298065e4472f3942340a7c24
parent8b4067381a09d312288a4339b5dde8a616829663 (diff)
downloadfreebsd-ports-gnome-7d05c0b0aaafe4d673eaac8b42e1c534080342ae.tar.gz
freebsd-ports-gnome-7d05c0b0aaafe4d673eaac8b42e1c534080342ae.tar.zst
freebsd-ports-gnome-7d05c0b0aaafe4d673eaac8b42e1c534080342ae.zip
- Add staging support
- Convert to new options framework
-rw-r--r--java/jcckit/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/java/jcckit/Makefile b/java/jcckit/Makefile
index 7daa4a94edc7..a60372c29a12 100644
--- a/java/jcckit/Makefile
+++ b/java/jcckit/Makefile
@@ -15,20 +15,17 @@ USES= zip
USE_JAVA= yes
WRKSRC= ${WRKDIR}/JCCKit
NO_BUILD= yes
-PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
-.if !defined(NOPORTDOCS)
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
PORTDOCS= *
-.endif
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${JAVAJARDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in LICENSE.txt README.html docs
- ${CP} -R ${WRKSRC}/${file} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>