aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-25 15:05:48 +0800
committermiwi <miwi@FreeBSD.org>2011-06-25 15:05:48 +0800
commit7d0a7e0ec4e486029dfe78494b7fa6759c93feb7 (patch)
tree719b89d28b97859fd1b618777861177413f71f37
parent1e560babf80658942d73ef7c10185a17a9eb9fb7 (diff)
downloadfreebsd-ports-gnome-7d0a7e0ec4e486029dfe78494b7fa6759c93feb7.tar.gz
freebsd-ports-gnome-7d0a7e0ec4e486029dfe78494b7fa6759c93feb7.tar.zst
freebsd-ports-gnome-7d0a7e0ec4e486029dfe78494b7fa6759c93feb7.zip
This is a small but growing collection of ASN.1 data structures expressed in
Python terms using pyasn1 data model. WWW: http://sourceforge.net/projects/pyasn1/ PR: ports/155715 Submitted by: Ruslan Mahmatkhanov <cvs-src at yandex.ru>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-asn1-modules/Makefile41
-rw-r--r--devel/py-asn1-modules/distinfo2
-rw-r--r--devel/py-asn1-modules/pkg-descr4
-rw-r--r--devel/py-asn1-modules/pkg-plist4
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fabc7c397c17..de4d16069026 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2818,6 +2818,7 @@
SUBDIR += py-apipkg
SUBDIR += py-argparse
SUBDIR += py-asn1
+ SUBDIR += py-asn1-modules
SUBDIR += py-aspects
SUBDIR += py-aspyct
SUBDIR += py-astng
diff --git a/devel/py-asn1-modules/Makefile b/devel/py-asn1-modules/Makefile
new file mode 100644
index 000000000000..510617a042d9
--- /dev/null
+++ b/devel/py-asn1-modules/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-asn1-modules
+# Date created: 20 March 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asn1-modules
+PORTVERSION= 0.0.1a
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP \
+ SF/pyasn1/py${PORTNAME}/${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= cvs-src@yandex.ru
+COMMENT= Collection of ASN.1 data structures for py-asn1
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= pyasn1-modules
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+BASEDOCS= CHANGES \
+ README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${BASEDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-asn1-modules/distinfo b/devel/py-asn1-modules/distinfo
new file mode 100644
index 000000000000..5263f3593b99
--- /dev/null
+++ b/devel/py-asn1-modules/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyasn1-modules-0.0.1a.tar.gz) = 4600d0acb9ecef20e9aa0d08922a0a11c541dc6841893cb5bb01063dfe103eca
+SIZE (pyasn1-modules-0.0.1a.tar.gz) = 12202
diff --git a/devel/py-asn1-modules/pkg-descr b/devel/py-asn1-modules/pkg-descr
new file mode 100644
index 000000000000..ddb1cd835556
--- /dev/null
+++ b/devel/py-asn1-modules/pkg-descr
@@ -0,0 +1,4 @@
+This is a small but growing collection of ASN.1 data structures expressed in
+Python terms using pyasn1 data model.
+
+WWW: http://sourceforge.net/projects/pyasn1/
diff --git a/devel/py-asn1-modules/pkg-plist b/devel/py-asn1-modules/pkg-plist
new file mode 100644
index 000000000000..cd24bcd9c312
--- /dev/null
+++ b/devel/py-asn1-modules/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%