aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-07-14 09:28:09 +0800
committergerald <gerald@FreeBSD.org>2012-07-14 09:28:09 +0800
commit7d5b746abf7c1809c4bfa0eb38e4df63ba3541a3 (patch)
treed0b51ce486522943e33e51ebd3b3552b1ae45b65
parent2d8a8101037e4d35d295f3e2b2af2e621de02748 (diff)
downloadfreebsd-ports-gnome-7d5b746abf7c1809c4bfa0eb38e4df63ba3541a3.tar.gz
freebsd-ports-gnome-7d5b746abf7c1809c4bfa0eb38e4df63ba3541a3.tar.zst
freebsd-ports-gnome-7d5b746abf7c1809c4bfa0eb38e4df63ba3541a3.zip
Adapt to the new options framework.
Reviewed by: David Naylor <naylor.b.david@gmail.com>
-rw-r--r--emulators/wine-devel/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 417724b1b435..0f15ef510c34 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -62,59 +62,56 @@ USE_XORG= xcursor xi xpm xrandr xrender
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" Off \
- DOSBOX "Use DOSBox to run MS-DOS programs" Off \
- GNUTLS "Use GnuTLS" Off \
- HAL "Use HAL (Hardware Abstraction Layer)" Off \
- LDAP "Use LDAP" Off \
- LIBXSLT "Use libxslt (only used by msxml3.dll)" Off \
- OPENAL "Use OpenAL (3D audio library)" Off \
- WINEMAKER "Fully support winemaker (requires Perl)" Off
+OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER
+
+DOSBOX_DESC= Use DOSBox to run MS-DOS programs
+LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
+WINEMAKER_DESC= Fully support winemaker (requires Perl)
PORTDATA= fonts/ generic.ppd l_intl.nls wine.inf
.include <bsd.port.pre.mk>
-.ifdef WITHOUT_CUPS
-CONFIGURE_ARGS+= --without-cups
-.else
+.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+= --with-cups
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
+.else
+CONFIGURE_ARGS+= --without-cups
.endif
-.ifdef WITH_DOSBOX
+.if ${PORT_OPTIONS:MDOSBOX}
RUN_DEPENDS+= dosbox:${PORTSDIR}/emulators/dosbox
.endif
-.ifdef WITH_GNUTLS
+.if ${PORT_OPTIONS:MGNU_TLS}
CONFIGURE_ARGS+= --with-gnutls
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
.else
CONFIGURE_ARGS+= --without-gnutls
.endif
-.ifdef WITH_HAL
+.if ${PORT_OPTIONS:MHAL}
CONFIGURE_ARGS+= --with-hal
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
.else
CONFIGURE_ARGS+= --without-hal
.endif
-.ifdef WITH_LDAP
+.if ${PORT_OPTIONS:MLDAP}
CONFIGURE_ARGS+= --with-ldap
USE_OPENLDAP= yes
.else
CONFIGURE_ARGS+= --without-ldap
.endif
-.ifdef WITH_LIBXSLT
+.if ${PORT_OPTIONS:MLIBXSLT}
CONFIGURE_ARGS+= --with-xslt
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
.else
CONFIGURE_ARGS+= --without-xslt
.endif
-.ifdef WITH_OPENAL
+.if ${PORT_OPTIONS:MOPENAL}
CONFIGURE_ARGS+= --with-openal
USE_OPENAL= yes
PLIST_SUB+= OPENAL=""
@@ -123,7 +120,7 @@ CONFIGURE_ARGS+= --without-openal
PLIST_SUB+= OPENAL="@comment "
.endif
-.ifdef WITH_WINEMAKER
+.if ${PORT_OPTIONS:MWINEMAKER}
RUN_DEPENDS+= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
.endif