aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-01-14 13:01:25 +0800
committeradamw <adamw@FreeBSD.org>2005-01-14 13:01:25 +0800
commit7e4f87297d9611bac0ad31dfb7ecf3f55689a402 (patch)
treed84c90a4e399e55c0440a2dbfa6ba64b913a1825
parentcc30be36f878403762916af5420473277bdecbe9 (diff)
downloadfreebsd-ports-gnome-7e4f87297d9611bac0ad31dfb7ecf3f55689a402.tar.gz
freebsd-ports-gnome-7e4f87297d9611bac0ad31dfb7ecf3f55689a402.tar.zst
freebsd-ports-gnome-7e4f87297d9611bac0ad31dfb7ecf3f55689a402.zip
Fix build on >4.x.
-rw-r--r--security/libgnomesu/Makefile2
-rw-r--r--security/libgnomesu/files/patch-pam-backend_pam.c11
2 files changed, 13 insertions, 0 deletions
diff --git a/security/libgnomesu/Makefile b/security/libgnomesu/Makefile
index e0b020e7426c..ed672ccd0dab 100644
--- a/security/libgnomesu/Makefile
+++ b/security/libgnomesu/Makefile
@@ -18,6 +18,8 @@ USE_GETOPT_LONG=yes
USE_LIBTOOL_VER=15
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
CONFLICTS= gnomesu-*
diff --git a/security/libgnomesu/files/patch-pam-backend_pam.c b/security/libgnomesu/files/patch-pam-backend_pam.c
new file mode 100644
index 000000000000..e43d290cc2df
--- /dev/null
+++ b/security/libgnomesu/files/patch-pam-backend_pam.c
@@ -0,0 +1,11 @@
+--- pam-backend/pam.c.orig Thu Jan 13 23:43:53 2005
++++ pam-backend/pam.c Thu Jan 13 23:43:59 2005
+@@ -17,7 +17,7 @@
+ */
+
+ #include <security/pam_appl.h>
+-#include <security/pam_misc.h>
++#include <security/pam_mod_misc.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/types.h>