aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-01-16 00:06:39 +0800
committerdinoex <dinoex@FreeBSD.org>2010-01-16 00:06:39 +0800
commit7f3debf23ab496772245b6a7cd8f9149bae66a4c (patch)
treec07b09b54ec1849fefab2e17ec7d3a2ed40e779d
parent68f64326bd2b77483556ffc9643296a83c233a12 (diff)
downloadfreebsd-ports-gnome-7f3debf23ab496772245b6a7cd8f9149bae66a4c.tar.gz
freebsd-ports-gnome-7f3debf23ab496772245b6a7cd8f9149bae66a4c.tar.zst
freebsd-ports-gnome-7f3debf23ab496772245b6a7cd8f9149bae66a4c.zip
- fix option WITHOUT_GHOSTSCRIPT
- new option WITH_XPDF PR: 142846 Submitted by: Chen-Yu Tsai
-rw-r--r--print/cups-base/Makefile21
-rw-r--r--print/cups-base/pkg-plist2
2 files changed, 16 insertions, 7 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 9402785914b0..04743baf8851 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -47,7 +47,8 @@ OPTIONS?= GNUTLS "Build with GNUTLS library" on \
LDAP "Build with LDAP support" off \
DBUS "Build with DBUS support" off \
LIBUSB "Build with USB support" off \
- GHOSTSCRIPT "Build pdftps with GHOSTSCRIPT" on \
+ GHOSTSCRIPT "Build pdftops with GHOSTSCRIPT" on \
+ XPDF "Build pdftops with XPDF" off \
XDG_OPEN "Build with XDG_OPEN as browser" off
CUPS_ETCDIR= ${PREFIX}/etc/cups
@@ -124,12 +125,20 @@ CONFIGURE_ARGS+= --without-php
PLIST_SUB+= PHP="@comment "
.endif
-.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && defined(WITH_GHOSTSCRIPT)
+.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && !defined(WITHOUT_GHOSTSCRIPT)
+.if defined(WITH_XPDF)
+IGNORE= "Pick ghostscript or xpdf, not both"
+.endif
USE_GHOSTSCRIPT= yes
-CONFIGURE_ARGS+= --enable-pdftops --with-pdftops=gs
-PLIST_SUB+= WITH_GHOSTSCRIPT=""
+CONFIGURE_ARGS+= --enable-pdftops --with-pdftops=${LOCALBASE}/bin/gs
+PLIST_SUB+= WITH_PDFTOPS=""
+.elif !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && defined(WITH_XPDF)
+BUILD_DEPENDS+= pdftops:${PORTSDIR}/graphics/xpdf
+RUN_DEPENDS+= pdftops:${PORTSDIR}/graphics/xpdf
+CONFIGURE_ARGS+= --enable-pdftops --with-pdftops=${LOCALBASE}/bin/pdftops
+PLIST_SUB+= WITH_PDFTOPS=""
.else
-PLIST_SUB+= WITH_GHOSTSCRIPT="@comment "
+PLIST_SUB+= WITH_PDFTOPS="@comment "
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && defined(WITH_PYTHON)
@@ -323,7 +332,7 @@ pre-su-install:
.endif
post-install:
-.if defined(WITH_GHOSTSCRIPT)
+.if !defined(WITHOUT_GHOSTSCRIPT) || defined(WITH_XPDF)
${INSTALL_PROGRAM} ${WRKSRC}/filter/pdftops ${PREFIX}/libexec/cups/filter/
.endif
${INSTALL} -d ${CUPS_ETCDIR}/
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index 7ba9593f83c5..536083546fec 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -89,7 +89,7 @@ libexec/cups/daemon/cups-lpd
libexec/cups/daemon/cups-polld
libexec/cups/filter/commandtoescpx
libexec/cups/filter/commandtopclx
-%%WITH_GHOSTSCRIPT%%libexec/cups/filter/pdftops
+%%WITH_PDFTOPS%%libexec/cups/filter/pdftops
libexec/cups/filter/rastertoescpx
libexec/cups/filter/rastertopclx
libexec/cups/monitor/bcp