aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-09-06 13:10:03 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-09-06 13:10:03 +0800
commit7fb1d2e2e3ca1b563e3b42e2deb927e5b4677339 (patch)
tree4fa098f29351d18ccaff651f09b297625563ed66
parent5cab9a39d0affc4cd448f06168c5ed983f52fb1a (diff)
downloadfreebsd-ports-gnome-7fb1d2e2e3ca1b563e3b42e2deb927e5b4677339.tar.gz
freebsd-ports-gnome-7fb1d2e2e3ca1b563e3b42e2deb927e5b4677339.tar.zst
freebsd-ports-gnome-7fb1d2e2e3ca1b563e3b42e2deb927e5b4677339.zip
Add a MAKE_ENV= CXX=${CXX}. I have no idea why this is needed.
CXX=asdf make properly uses asdf instead of c++, but USE_NEWGCC=yes in the Makefile isn't sending it through. Noticed by: bento.freebsd.org
-rw-r--r--x11-wm/toolbox/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/x11-wm/toolbox/Makefile b/x11-wm/toolbox/Makefile
index deada3e52adb..b00ce8fce1e4 100644
--- a/x11-wm/toolbox/Makefile
+++ b/x11-wm/toolbox/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= qt2.2:${PORTSDIR}/x11-toolkits/qt201
USE_NEWGCC= yes
USE_X_PREFIX= yes
+MAKE_ENV= CXX="${CXX}" CC="${CC}"
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/toolbox ${PREFIX}/bin/toolbox