aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2010-05-15 00:56:13 +0800
committerbsam <bsam@FreeBSD.org>2010-05-15 00:56:13 +0800
commit7fec62fb26f23541a12087ffc8a2b1b9a6ff3583 (patch)
tree014c15b8d40fbd415f44cf45ec4e210f0823dc4a
parentd9f0971a4e0b01a0acf7ad4b6498fa6f6c87f437 (diff)
downloadfreebsd-ports-gnome-7fec62fb26f23541a12087ffc8a2b1b9a6ff3583.tar.gz
freebsd-ports-gnome-7fec62fb26f23541a12087ffc8a2b1b9a6ff3583.tar.zst
freebsd-ports-gnome-7fec62fb26f23541a12087ffc8a2b1b9a6ff3583.zip
comms/gammu-python:
. remove CATEGORIES (it's the same with master port); . run python script to create gammu/__init__.pyc file; . bump PORTREVISION. comms/gammu: . add gammu/__init__.pyc to pkg-plist (when WITH_PYTHON_GAMMU is defined, i.e. for comms/gammu-python port).
-rw-r--r--comms/gammu-python/Makefile6
-rw-r--r--comms/gammu/pkg-plist1
2 files changed, 6 insertions, 1 deletions
diff --git a/comms/gammu-python/Makefile b/comms/gammu-python/Makefile
index 2e320c057249..03fb243ca0c5 100644
--- a/comms/gammu-python/Makefile
+++ b/comms/gammu-python/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-CATEGORIES= comms
+PORTREVISION= 1
PKGNAMESUFFIX= -python
CONFLICTS= gammu-[1-9]* gammu-devel-[1-9]*
@@ -14,4 +14,8 @@ WITH_PYTHON_GAMMU= yes
MASTERDIR= ${.CURDIR}/../gammu
+post-install:
+ @${PYTHON_CMD} ${PYTHON_SITELIBDIR}/${PORTNAME}/__init__.py
+
+
.include "${MASTERDIR}/Makefile"
diff --git a/comms/gammu/pkg-plist b/comms/gammu/pkg-plist
index e825fbfd8770..76bfa4849071 100644
--- a/comms/gammu/pkg-plist
+++ b/comms/gammu/pkg-plist
@@ -37,6 +37,7 @@ lib/libgsmsd.a
libdata/pkgconfig/gammu.pc
libdata/pkgconfig/gammu-smsd.pc
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/__init__.py
+%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/__init__.pyc
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/_gammu.so
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Data.py
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Worker.py