aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2010-05-31 01:03:17 +0800
committermarcus <marcus@FreeBSD.org>2010-05-31 01:03:17 +0800
commit8015db04b9e5a848f42ba545c3ce096411abf28d (patch)
tree04a829ede4a27ad4952c5deb94412159b8300133
parent37415d8706d962f4f6fd4de6d3310e501759311e (diff)
downloadfreebsd-ports-gnome-8015db04b9e5a848f42ba545c3ce096411abf28d.tar.gz
freebsd-ports-gnome-8015db04b9e5a848f42ba545c3ce096411abf28d.tar.zst
freebsd-ports-gnome-8015db04b9e5a848f42ba545c3ce096411abf28d.zip
* Update to 2.1.1 [1]
* Make AppleTalk support optional (enabled by default) [1] * Convert to OPTIONS [1] * Add a CONFLICTS entry for uniconvertor [2] Big thanks to Stefan Bethke <stb@lassitu.de> for doing all of the heavy lifting on this update. PR: 146576 [1] 145724 [2] Submitted by: Stefan Bethke <stb@lassitu.de> [1]
-rw-r--r--net/netatalk/Makefile79
-rw-r--r--net/netatalk/distinfo6
-rw-r--r--net/netatalk/files/patch-config_Makefile.in27
-rw-r--r--net/netatalk/files/patch-config_netatalk.conf52
-rw-r--r--net/netatalk/files/patch-configure14
-rw-r--r--net/netatalk/files/patch-etc-uams_Makefile.in11
-rw-r--r--net/netatalk/files/patch-etc_afpd_afp_options.c13
-rw-r--r--net/netatalk/pkg-descr33
-rw-r--r--net/netatalk/pkg-plist107
9 files changed, 186 insertions, 156 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index ba2d268aad66..f487d4e5b1f3 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -6,31 +6,57 @@
#
PORTNAME= netatalk
-PORTVERSION= 2.0.5
+PORTVERSION= 2.1.1
PORTEPOCH= 1
CATEGORIES= net print
MASTER_SITES= SF
MAINTAINER= marcus@FreeBSD.org
-COMMENT= File and print server for AppleTalk networks
+COMMENT= File server for Mac OS X
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
USE_AUTOTOOLS= libtool:22
+USE_BDB= 46+
USE_BZIP2= yes
USE_ICONV= yes
-USE_BDB= 41+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PERL5= yes
USE_RC_SUBR= netatalk
+
CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc \
--with-libiconv=${LOCALBASE} \
- --with-libgcrypt-prefix=${LOCALBASE}
+ --with-libgcrypt-dir=${LOCALBASE} \
+ --with-uams-path=${LOCALBASE}/libexec/netatalk-uams \
+ --with-bdb=${LOCALBASE}
-OPTIONS= SRVLOC "Enable Service Location Protocol support" off \
+OPTIONS= APPLETALK "Enable AppleTalk protocol support" on \
+ SRVLOC "Enable Service Location Protocol support" off \
PAM "Enable PAM support" off \
TIMELORD "Enable Timelord network time service" off \
KRB5 "Enable Kerberos V UAM" off
+FILES= AppleVolumes.default AppleVolumes.system afpd.conf \
+ atalkd.conf papd.conf netatalk.conf
+LINKS= unbin unhex unsingle hqx2bin single2bin macbinary \
+ binheader nadheader
+MAN1= achfile.1 ad.1 aecho.1 afile.1 afppasswd.1 apple_cp.1 \
+ apple_dump.1 apple_mv.1 apple_rm.1 asip-status.pl.1 dbd.1 \
+ getzones.1 hqx2bin.1 macbinary.1 megatron.1 nbp.1 nbplkup.1 \
+ nbprgstr.1 nbpunrgstr.1 netatalk-config.1 pap.1 papstatus.1 \
+ psorder.1 single2bin.1 unbin.1 unhex.1 uniconv.1 unsingle.1
+MAN3= atalk_aton.3 nbp_name.3
+MAN4= atalk.4
+MAN5= AppleVolumes.5 AppleVolumes.default.5 \
+ AppleVolumes.system.5 afp_ldap.conf.5 afp_signature.conf.5 \
+ afpd.conf.5 atalkd.conf.5 netatalk.conf.5 papd.conf.5
+MAN8= afp_acls.8 afpd.8 atalkd.8 cnid_dbd.8 cnid_metad.8 papd.8 \
+ papstatus.8 psf.8 timelord.8
+
+CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-1* uniconvertor-1.*
+
.include <bsd.port.pre.mk>
.if defined(WITH_KRB5)
@@ -40,6 +66,12 @@ PLIST_SUB+= NETATALKKRB5=""
PLIST_SUB+= NETATALKKRB5="@comment "
.endif
+.if defined(WITH_APPLETALK)
+CONFIGURE_ARGS+= --with-ddp
+.else
+CONFIGURE_ARGS+= --without-ddp
+.endif
+
.if defined(WITH_PAM)
CONFIGURE_ARGS+= --with-pam
PLIST_SUB+= NETATALKPAM=""
@@ -47,46 +79,21 @@ PLIST_SUB+= NETATALKPAM=""
CONFIGURE_ARGS+= --without-pam
PLIST_SUB+= NETATALKPAM="@comment "
.endif
+
.if defined(WITH_SRVLOC)
-# Enable Service Location Protocol support. This allows MacOS X < 10.1 to
-# pickup afpd servers in the network.
-LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
CONFIGURE_ARGS+= --enable-srvloc=${LOCALBASE}
+LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
+SUB_LIST+= SRVLOC="slpd"
+.else
+SUB_LIST+= SRVLOC=""
.endif
-CONFIGURE_ARGS+= --with-bdb=${LOCALBASE}
+
.if defined (WITH_TIMELORD)
CONFIGURE_ARGS+= --enable-timelord
PLIST_SUB+= TIMELORD=""
.else
PLIST_SUB+= TIMELORD="@comment "
.endif
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_PERL5= yes
-FILES= AppleVolumes.default AppleVolumes.system afpd.conf \
- atalkd.conf papd.conf netatalk.conf
-LINKS= unbin unhex unsingle hqx2bin single2bin macbinary \
- binheader nadheader
-MAN1= achfile.1 aecho.1 afile.1 afppasswd.1 getzones.1 \
- megatron.1 nbp.1 pap.1 psorder.1 hqx2bin.1 macbinary.1 \
- nbplkup.1 nbprgstr.1 nbpunrgstr.1 papstatus.1 \
- single2bin.1 unbin.1 unhex.1 unsingle.1 acleandir.1 \
- netatalk-config.1 apple_cp.1 apple_mv.1 \
- apple_rm.1 uniconv.1 asip-status.pl.1 cnid_index.1
-MAN3= atalk_aton.3 nbp_name.3
-MAN4= atalk.4
-MAN5= AppleVolumes.default.5 afpd.conf.5 atalkd.conf.5 \
- netatalk.conf.5 papd.conf.5
-MAN8= afpd.8 atalkd.8 cnid_dbd.8 cnid_metad.8 papd.8 papstatus.8 \
- psf.8 timelord.8
-
-CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-1*
-
-.if defined(WITH_SRVLOC)
-SUB_LIST+= SRVLOC="slpd"
-.else
-SUB_LIST+= SRVLOC=""
-.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
diff --git a/net/netatalk/distinfo b/net/netatalk/distinfo
index 428c32c7f23c..14af516c2bcc 100644
--- a/net/netatalk/distinfo
+++ b/net/netatalk/distinfo
@@ -1,3 +1,3 @@
-MD5 (netatalk-2.0.5.tar.bz2) = 3bd8f4780abc373e0539ab7cd1f9950f
-SHA256 (netatalk-2.0.5.tar.bz2) = aa11b26ad5c6cfb6043458fc849ed82b13b6d13219191a6335fce1bc76288b37
-SIZE (netatalk-2.0.5.tar.bz2) = 993882
+MD5 (netatalk-2.1.1.tar.bz2) = d91913958970b4bcd72577aa52aa31be
+SHA256 (netatalk-2.1.1.tar.bz2) = 2445ee2a009768fa889235ff8ad1c55cc9575fe1be0d5fdc48d0e4d56646255f
+SIZE (netatalk-2.1.1.tar.bz2) = 1121436
diff --git a/net/netatalk/files/patch-config_Makefile.in b/net/netatalk/files/patch-config_Makefile.in
index eb71290a3725..4ae72a138d55 100644
--- a/net/netatalk/files/patch-config_Makefile.in
+++ b/net/netatalk/files/patch-config_Makefile.in
@@ -1,6 +1,15 @@
---- config/Makefile.in.orig Mon Mar 22 19:22:45 2004
-+++ config/Makefile.in Sat Jun 5 22:08:04 2004
-@@ -386,22 +386,11 @@
+--- config/Makefile.in.orig 2010-04-22 07:59:53.000000000 +0000
++++ config/Makefile.in 2010-05-20 20:21:51.000000000 +0000
+@@ -590,19 +590,15 @@
+
+ uninstall-local:
+ for f in $(CONFFILES) $(GENFILES); do \
+- echo rm -f $(DESTDIR)$(pkgconfdir)/$$f; \
+- rm -f $(DESTDIR)$(pkgconfdir)/$$f; \
++ echo rm -f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
++ rm -f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ done
+
install-config-files: $(CONFFILES) $(GENFILES)
$(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
for f in $(CONFFILES) $(GENFILES); do \
@@ -14,14 +23,4 @@
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
done
- @USE_PAM_TRUE@install-data-local: install-config-files $(PAMFILES)
--@USE_PAM_TRUE@ $(mkinstalldirs) $(DESTDIR)$(pamdir)
--@USE_PAM_TRUE@ if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pamdir)/netatalk; then \
--@USE_PAM_TRUE@ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pamdir)/netatalk"; \
--@USE_PAM_TRUE@ $(INSTALL_DATA) netatalk.pamd $(DESTDIR)$(pamdir)/netatalk || echo "WARNING: Can't install PAM files"; \
--@USE_PAM_TRUE@ else \
--@USE_PAM_TRUE@ echo "not overwriting $(DESTDIR)$(pamdir)/netatalk"; \
--@USE_PAM_TRUE@ fi;
-
- @USE_PAM_FALSE@install-data-local: install-config-files
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ install-webmin:
diff --git a/net/netatalk/files/patch-config_netatalk.conf b/net/netatalk/files/patch-config_netatalk.conf
index 4c007b859cf4..7b7afceb177a 100644
--- a/net/netatalk/files/patch-config_netatalk.conf
+++ b/net/netatalk/files/patch-config_netatalk.conf
@@ -1,47 +1,43 @@
---- config/netatalk.conf.orig 2009-04-30 05:30:13.000000000 -0400
-+++ config/netatalk.conf 2009-06-13 22:48:55.000000000 -0400
+--- config/netatalk.conf.orig 2010-04-19 11:35:26.000000000 +0000
++++ config/netatalk.conf 2010-05-20 19:14:32.000000000 +0000
@@ -1,4 +1,5 @@
--# Appletalk configuration
+-# Netatalk configuration
+# netatalk configuration
+# For details see man netatalk.conf
# Change this to increase the maximum number of clients that can connect:
- AFPD_MAX_CLIENTS=50
+ AFPD_MAX_CLIENTS=20
-@@ -8,17 +9,8 @@ AFPD_MAX_CLIENTS=50
- # NOTE: If Netatalk should register AppleTalk services in the standard zone
- # then you need not to specify a zone name here.
- #
--# If your zone has spaces in it, you're better off specifying
--# it in afpd.conf if you realize that your distribution doesn't
--# handle spaces correctly in the startup script. Remember to use
--# quotes here if the zone name contains spaces.
--#
- #ATALK_ZONE="@some zone"
+@@ -6,7 +7,7 @@
+ # NOTE: if your zone has spaces in it, you're better off specifying
+ # it in afpd.conf
+ #ATALK_ZONE=@zone
-ATALK_NAME=`echo ${HOSTNAME}|cut -d. -f1`
--
--# specify the Mac and unix charsets to be used
--ATALK_MAC_CHARSET='MAC_ROMAN'
--ATALK_UNIX_CHARSET='LOCALE'
+ATALK_NAME=`/bin/hostname -s`
- # specify this if you don't want dhx and dhx2
- # available options: uams_guest.so, uams_clrtxt.so,
-@@ -28,18 +20,3 @@ ATALK_UNIX_CHARSET='LOCALE'
-
+ # specify the Mac and unix charsets to be used
+ ATALK_MAC_CHARSET='MAC_ROMAN'
+@@ -20,24 +21,5 @@
# Change this to set the id of the guest user
AFPD_GUEST=nobody
--
--# Set which daemons to run (papd is dependent upon atalkd):
--ATALKD_RUN=yes
+
+-# Set which daemons to run.
+-# If you need legacy AppleTalk, run atalkd.
+-# papd, timelord and a2boot are dependent upon atalkd.
+-# If you use "AFP over TCP" server only, run only cnid_metad and afpd.
+-ATALKD_RUN=no
-PAPD_RUN=no
--CNID_METAD_RUN=yes
--AFPD_RUN=yes
-TIMELORD_RUN=no
-A2BOOT_RUN=no
+-CNID_METAD_RUN=yes
+-AFPD_RUN=yes
-
--# Control whether the daemons are started in the background
+-# Control whether the daemons are started in the background.
+-# If it is dissatisfied that atalkd starts slowly, set "yes".
-ATALK_BGROUND=no
-
-# export the charsets, read form ENV by apps
-export ATALK_MAC_CHARSET
-export ATALK_UNIX_CHARSET
+-
+ # config for cnid_metad. Default log config:
+ # CNID_CONFIG="-l log_note"
diff --git a/net/netatalk/files/patch-configure b/net/netatalk/files/patch-configure
index 604ea5d50c28..ff1e6b364410 100644
--- a/net/netatalk/files/patch-configure
+++ b/net/netatalk/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig 2009-03-29 03:24:33.000000000 -0400
-+++ configure 2009-06-13 22:52:07.000000000 -0400
-@@ -30193,7 +30193,7 @@ if test "x$bdb_required" = "xyes"; then
+--- configure.orig 2010-04-22 07:59:58.000000000 +0000
++++ configure 2010-05-20 19:17:21.000000000 +0000
+@@ -30958,7 +30958,7 @@
trybdbdir=""
dobdbsearch=yes
bdb_search_dirs="/usr/local /usr"
-- search_subdirs="/ /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4.3 /db43 /db4.2 /db42 /db4.1 /db41 /db4"
-+ search_subdirs="/%%DB_NAME%% / /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4.3 /db43 /db4.2 /db42 /db4.1 /db41 /db4"
+- search_subdirs="/ /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4"
++ search_subdirs="/%%DB_NAME%% / /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4"
- DB_MAJOR_REQ=4
- DB_MINOR_REQ=1
+ bdbfound=no
+ savedcflags="$CFLAGS"
diff --git a/net/netatalk/files/patch-etc-uams_Makefile.in b/net/netatalk/files/patch-etc-uams_Makefile.in
new file mode 100644
index 000000000000..abcc0a2b5d69
--- /dev/null
+++ b/net/netatalk/files/patch-etc-uams_Makefile.in
@@ -0,0 +1,11 @@
+--- etc/uams/Makefile.in.orig 2010-05-22 10:15:34.000000000 +0000
++++ etc/uams/Makefile.in 2010-05-22 10:15:51.000000000 +0000
+@@ -402,7 +402,7 @@
+ AM_CFLAGS = @SSL_CFLAGS@ @LIBGCRYPT_CFLAGS@
+ uams_pam_la_CFLAGS = @PAM_CFLAGS@
+ uams_dhx_pam_la_CFLAGS = @PAM_CFLAGS@
+-uams_dhx2_pam_la_CFLAGS = @PAM_CFLAGS@
++uams_dhx2_pam_la_CFLAGS = @PAM_CFLAGS@ @LIBGCRYPT_CFLAGS@
+ uams_gss_la_CFLAGS = @GSSAPI_CFLAGS@
+ uams_guest_la_LDFLAGS = -module -avoid-version
+ uams_randnum_la_LDFLAGS = -module -avoid-version @SSL_LIBS@
diff --git a/net/netatalk/files/patch-etc_afpd_afp_options.c b/net/netatalk/files/patch-etc_afpd_afp_options.c
new file mode 100644
index 000000000000..041f4a25a2f1
--- /dev/null
+++ b/net/netatalk/files/patch-etc_afpd_afp_options.c
@@ -0,0 +1,13 @@
+diff --git a/etc/afpd/afp_options.c etc/afpd/afp_options.c
+index ebc9a65..057a1a3 100644
+--- a/etc/afpd/afp_options.c
++++ etc/afpd/afp_options.c
+@@ -137,8 +137,6 @@ void afp_options_free(struct afp_options *opt,
+ free(opt->passwdfile);
+ if (opt->signatureopt && (opt->signatureopt != save->signatureopt))
+ free(opt->signatureopt);
+- if (opt->signature && (opt->signature != save->signature))
+- free(opt->signature);
+ if (opt->k5service && (opt->k5service != save->k5service))
+ free(opt->k5service);
+ if (opt->k5realm && (opt->k5realm != save->k5realm))
diff --git a/net/netatalk/pkg-descr b/net/netatalk/pkg-descr
index 6d49d2583a0b..ad933ec4bcd4 100644
--- a/net/netatalk/pkg-descr
+++ b/net/netatalk/pkg-descr
@@ -1,24 +1,19 @@
-netatalk - File and Print Server for AppleTalk networks
+Netatalk is an OpenSource software package, that can be used to turn an
+inexpensive *NIX machine into an extremely high-performance and reliable
+file server for Macintosh computers.
-Netatalk features include:
-o Access to the UNIX file system for Macintosh and other systems with
- AppleShare client software.
-o Spool PostScript print jobs to the lpd(8) spool system via Printer Access
- Protocol (PAP).
-o Output PostScript print jobs from the lpd(8) spool system via Printer
- Access Protocol (PAP).
-o Filter PostScript, ASCII, and various other formats to PostScript,
- including banner pages and page reversal.
-o Route AppleTalk between multiple Ethernet interfaces.
+Using Netatalk's AFP 3.2 compliant file-server leads to significantly higher
+transmission speeds compared with Macs accessing a server via SaMBa/NFS
+while providing clients with the best possible user experience (full support
+for Macintosh metadata, flawlessly supporting mixed environments of classic
+MacOS and MacOS X clients)
-This version includes Adrian Sun's improvements:
-o Access to the file server via AFP-over-TCP.
-o Support for volumes larger that 2GB.
-o Randnum- and 2-Way Randnum authentication methods (courtesy S. Hirsch)
-o Support for Apple II ProDOS.
-o A number of bug fixes.
+Due to Netatalk speaking AppleTalk, the print-server task can provide
+printing clients with full AppleTalk support as well as the server itself
+with printing capabilities for AppleTalk-only printers. Starting with
+version 2.0, Netatalk seamlessly interacts with CUPS on the server.
-Many other new features and bug fixes have also been integrated.
-Requires AppleTalk support in the kernel (FreeBSD 2.2 or newer).
+After all, Netatalk can be used to act as an AppleTalk router, providing
+both segmentation and zone names in Macintosh networks.
WWW: http://netatalk.sourceforge.net/
diff --git a/net/netatalk/pkg-plist b/net/netatalk/pkg-plist
index aa3b7df10bfb..ed1303fc7853 100644
--- a/net/netatalk/pkg-plist
+++ b/net/netatalk/pkg-plist
@@ -1,39 +1,39 @@
bin/achfile
-bin/acleandir.rc
+bin/ad
+bin/add_netatalk_printer
bin/adv1tov2
bin/aecho
bin/afile
bin/afppasswd
bin/apple_cp
+bin/apple_dump
bin/apple_mv
bin/apple_rm
bin/asip-status.pl
-bin/cleanappledouble.pl
bin/cnid2_create
-bin/cnid_index
-bin/cnid_maint
+bin/dbd
bin/getzones
+bin/logger_test
bin/macusers
bin/megatron
-@unexec rm -f %B/unbin
-@unexec rm -f %B/unhex
-@unexec rm -f %B/unsingle
-@unexec rm -f %B/hqx2bin
-@unexec rm -f %B/single2bin
-@unexec rm -f %B/macbinary
-@unexec rm -f %B/binheader
-@unexec rm -f %B/nadheader
-@exec cd %B && ln -s megatron unbin
-@exec cd %B && ln -s megatron unhex
-@exec cd %B && ln -s megatron unsingle
@exec cd %B && ln -s megatron hqx2bin
-@exec cd %B && ln -s megatron single2bin
@exec cd %B && ln -s megatron macbinary
-@exec cd %B && ln -s megatron binheader
@exec cd %B && ln -s megatron nadheader
+@exec cd %B && ln -s megatron single2bin
+@exec cd %B && ln -s megatron unbin
+@exec cd %B && ln -s megatron unhex
+@exec cd %B && ln -s megatron unsingle
+@unexec rm -f %B/hqx2bin
+@unexec rm -f %B/macbinary
+@unexec rm -f %B/nadheader
+@unexec rm -f %B/single2bin
+@unexec rm -f %B/unbin
+@unexec rm -f %B/unhex
+@unexec rm -f %B/unsingle
bin/nbplkup
bin/nbprgstr
bin/nbpunrgstr
+bin/netacnv
bin/netatalk-config
bin/pap
bin/papstatus
@@ -58,36 +58,37 @@ etc/netatalk.conf.dist
@unexec if cmp -s %D/etc/papd.conf %D/etc/papd.conf.dist; then rm -f %D/etc/papd.conf; fi
etc/papd.conf.dist
@exec [ ! -f %B/papd.conf ] && cp %B/%f %B/papd.conf
-etc/uams/uams_clrtxt.so
-etc/uams/uams_dhx.so
-etc/uams/uams_dhx2.so
-%%NETATALKPAM%%etc/uams/uams_dhx2_pam.a
-%%NETATALKPAM%%etc/uams/uams_dhx2_pam.la
-%%NETATALKPAM%%etc/uams/uams_dhx2_pam.so
-etc/uams/uams_dhx2_passwd.a
-etc/uams/uams_dhx2_passwd.la
-etc/uams/uams_dhx2_passwd.so
-%%NETATALKPAM%%etc/uams/uams_dhx_pam.a
-%%NETATALKPAM%%etc/uams/uams_dhx_pam.la
-%%NETATALKPAM%%etc/uams/uams_dhx_pam.so
-etc/uams/uams_dhx_passwd.a
-etc/uams/uams_dhx_passwd.la
-etc/uams/uams_dhx_passwd.so
-%%NETATALKKRB5%%etc/uams/uams_gss.a
-%%NETATALKKRB5%%etc/uams/uams_gss.la
-%%NETATALKKRB5%%etc/uams/uams_gss.so
-etc/uams/uams_guest.a
-etc/uams/uams_guest.la
-etc/uams/uams_guest.so
-%%NETATALKPAM%%etc/uams/uams_pam.a
-%%NETATALKPAM%%etc/uams/uams_pam.la
-%%NETATALKPAM%%etc/uams/uams_pam.so
-etc/uams/uams_passwd.a
-etc/uams/uams_passwd.la
-etc/uams/uams_passwd.so
-etc/uams/uams_randnum.a
-etc/uams/uams_randnum.la
-etc/uams/uams_randnum.so
+libexec/netatalk-uams/uams_clrtxt.so
+libexec/netatalk-uams/uams_dhx.so
+libexec/netatalk-uams/uams_dhx2.so
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx2_pam.a
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx2_pam.la
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx2_pam.so
+libexec/netatalk-uams/uams_dhx2_passwd.a
+libexec/netatalk-uams/uams_dhx2_passwd.la
+libexec/netatalk-uams/uams_dhx2_passwd.so
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx_pam.a
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx_pam.la
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx_pam.so
+libexec/netatalk-uams/uams_dhx_passwd.a
+libexec/netatalk-uams/uams_dhx_passwd.la
+libexec/netatalk-uams/uams_dhx_passwd.so
+%%NETATALKKRB5%%libexec/netatalk-uams/uams_gss.a
+%%NETATALKKRB5%%libexec/netatalk-uams/uams_gss.la
+%%NETATALKKRB5%%libexec/netatalk-uams/uams_gss.so
+libexec/netatalk-uams/uams_guest.a
+libexec/netatalk-uams/uams_guest.la
+libexec/netatalk-uams/uams_guest.so
+%%NETATALKPAM%%libexec/netatalk-uams/uams_pam.a
+%%NETATALKPAM%%libexec/netatalk-uams/uams_pam.la
+%%NETATALKPAM%%libexec/netatalk-uams/uams_pam.so
+libexec/netatalk-uams/uams_passwd.a
+libexec/netatalk-uams/uams_passwd.la
+libexec/netatalk-uams/uams_passwd.so
+libexec/netatalk-uams/uams_randnum.a
+libexec/netatalk-uams/uams_randnum.la
+libexec/netatalk-uams/uams_randnum.so
+include/atalk/acl.h
include/atalk/adouble.h
include/atalk/aep.h
include/atalk/afp.h
@@ -97,7 +98,11 @@ include/atalk/boolean.h
include/atalk/cnid.h
include/atalk/compat.h
include/atalk/ddp.h
+include/atalk/directory.h
include/atalk/dsi.h
+include/atalk/ea.h
+include/atalk/hash.h
+include/atalk/ldapconfig.h
include/atalk/list.h
include/atalk/logger.h
include/atalk/nbp.h
@@ -110,15 +115,19 @@ include/atalk/server_ipc.h
include/atalk/tdb.h
include/atalk/uam.h
include/atalk/unicode.h
+include/atalk/unix.h
include/atalk/util.h
+include/atalk/uuid.h
+include/atalk/vfs.h
include/atalk/volinfo.h
+include/atalk/volume.h
include/atalk/zip.h
include/netatalk/aarp.h
include/netatalk/at.h
include/netatalk/at_var.h
include/netatalk/ddp.h
-include/netatalk/endian.h
include/netatalk/ddp_var.h
+include/netatalk/endian.h
include/netatalk/phase2.h
lib/libatalk.a
lib/libatalk.la
@@ -156,4 +165,4 @@ share/aclocal/netatalk.m4
@dirrm share/netatalk
@dirrm include/netatalk
@dirrm include/atalk
-@dirrm etc/uams
+@dirrm libexec/netatalk-uams