aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-01-21 10:47:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-01-21 10:47:52 +0800
commit8033d412f9c4bb58209bb7a230e40b96a08913cf (patch)
tree6bb14e6856858f087af2344a74e59f1d869d11fd
parent2cd1afb9cc8e82bfb87b154de59b26cef4fd05d3 (diff)
downloadfreebsd-ports-gnome-8033d412f9c4bb58209bb7a230e40b96a08913cf.tar.gz
freebsd-ports-gnome-8033d412f9c4bb58209bb7a230e40b96a08913cf.tar.zst
freebsd-ports-gnome-8033d412f9c4bb58209bb7a230e40b96a08913cf.zip
- Add www/rubygem-net-http-pipeline
An HTTP/1.1 pipelining implementation atop Net::HTTP. A pipelined connection sends multiple requests to the HTTP server without waiting for the responses. The server will respond in-order. WWW: http://docs.seattlerb.org/net-http-pipeline/
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-net-http-pipeline/Makefile18
-rw-r--r--www/rubygem-net-http-pipeline/distinfo2
-rw-r--r--www/rubygem-net-http-pipeline/pkg-descr5
4 files changed, 26 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4ef472127555..b7afa504ddf7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1859,6 +1859,7 @@
SUBDIR += rubygem-net-http-digest_auth11
SUBDIR += rubygem-net-http-persistent
SUBDIR += rubygem-net-http-persistent25
+ SUBDIR += rubygem-net-http-pipeline
SUBDIR += rubygem-nicovideo
SUBDIR += rubygem-ntlm-http
SUBDIR += rubygem-pagerduty
diff --git a/www/rubygem-net-http-pipeline/Makefile b/www/rubygem-net-http-pipeline/Makefile
new file mode 100644
index 000000000000..e8df3b7198f6
--- /dev/null
+++ b/www/rubygem-net-http-pipeline/Makefile
@@ -0,0 +1,18 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= net-http-pipeline
+PORTVERSION= 1.0.1
+CATEGORIES= www net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= HTTP/1.1 pipelining implementation atop Net::HTTP
+
+LICENSE= MIT
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-net-http-pipeline/distinfo b/www/rubygem-net-http-pipeline/distinfo
new file mode 100644
index 000000000000..1455a6804215
--- /dev/null
+++ b/www/rubygem-net-http-pipeline/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/net-http-pipeline-1.0.1.gem) = 6923ce2f28bfde589a9f385e999395eead48ccfe4376d4a85d9a77e8c7f0b22f
+SIZE (rubygem/net-http-pipeline-1.0.1.gem) = 12800
diff --git a/www/rubygem-net-http-pipeline/pkg-descr b/www/rubygem-net-http-pipeline/pkg-descr
new file mode 100644
index 000000000000..41e7ee9a1590
--- /dev/null
+++ b/www/rubygem-net-http-pipeline/pkg-descr
@@ -0,0 +1,5 @@
+An HTTP/1.1 pipelining implementation atop Net::HTTP. A pipelined
+connection sends multiple requests to the HTTP server without waiting
+for the responses. The server will respond in-order.
+
+WWW: http://docs.seattlerb.org/net-http-pipeline/