aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-01-03 03:45:38 +0800
committerdinoex <dinoex@FreeBSD.org>2002-01-03 03:45:38 +0800
commit80636ea550371c82d524553e42be78dfd670d94f (patch)
tree9342360717c04821754c238df30317e4f17a0f70
parent7cf3f9075dca1ed3436f85aeabd9aa524316a0de (diff)
downloadfreebsd-ports-gnome-80636ea550371c82d524553e42be78dfd670d94f.tar.gz
freebsd-ports-gnome-80636ea550371c82d524553e42be78dfd670d94f.tar.zst
freebsd-ports-gnome-80636ea550371c82d524553e42be78dfd670d94f.zip
adding a knob to the OpenSSH port to allow people
to overwrite the ssh in the base system. make OPENSSH_OVERWRITE_BASE=yes Submitted by: n@nectar.cc (Jacques A. Vidrine)
-rw-r--r--security/hpn-ssh/Makefile6
-rw-r--r--security/openssh-portable/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 472fc894bde9..34b9e03d96df 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -36,6 +36,12 @@ CONFIGURE_ARGS+= --with-pam
CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
+.if defined(OPENSSH_OVERWRITE_BASE)
+PREFIX= /usr
+CONFIGURE_ARGS+= --mandir=${PREFIX}/share/man \
+ --sysconfdir=/etc/ssh --localstatedir=/var \
+.endif
+
.if defined(BATCH)
EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 472fc894bde9..34b9e03d96df 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -36,6 +36,12 @@ CONFIGURE_ARGS+= --with-pam
CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
+.if defined(OPENSSH_OVERWRITE_BASE)
+PREFIX= /usr
+CONFIGURE_ARGS+= --mandir=${PREFIX}/share/man \
+ --sysconfdir=/etc/ssh --localstatedir=/var \
+.endif
+
.if defined(BATCH)
EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif