aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-11-19 06:13:34 +0800
committerkris <kris@FreeBSD.org>2004-11-19 06:13:34 +0800
commit80811b630c64909faeb214710c9f4b87a6381bff (patch)
tree5d3ab334444ace3bc50b2447e3fc25c5952bcf8c
parentf044a5fb93a06c8d04b65a1200a250cf1f7a8095 (diff)
downloadfreebsd-ports-gnome-80811b630c64909faeb214710c9f4b87a6381bff.tar.gz
freebsd-ports-gnome-80811b630c64909faeb214710c9f4b87a6381bff.tar.zst
freebsd-ports-gnome-80811b630c64909faeb214710c9f4b87a6381bff.zip
BROKEN on 6.x: Does not build
-rw-r--r--mail/postfix20/Makefile8
-rw-r--r--sysutils/sleuthkit/Makefile8
-rw-r--r--sysutils/tct/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/mail/postfix20/Makefile b/mail/postfix20/Makefile
index 21503484bed0..3fdcd2592dd7 100644
--- a/mail/postfix20/Makefile
+++ b/mail/postfix20/Makefile
@@ -70,6 +70,12 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
MKDIR="${MKDIR}" \
POSTFIX_OPTIONS="${POSTFIX_OPTIONS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+BROKEN= "Does not build on FreeBSD >= 6.x"
+.endif
+
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.postfix
@@ -169,4 +175,4 @@ post-install:
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/sleuthkit/Makefile b/sysutils/sleuthkit/Makefile
index bb9773fc08ec..7dae0ab5129b 100644
--- a/sysutils/sleuthkit/Makefile
+++ b/sysutils/sleuthkit/Makefile
@@ -20,6 +20,12 @@ MAN1= dcalc.1 dcat.1 dls.1 dstat.1 ffind.1 \
fls.1 fsstat.1 hfind.1 icat.1 ifind.1 \
ils.1 istat.1 mactime.1 mmls.1 sorter.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+BROKEN= "Does not build on FreeBSD >= 6.x"
+.endif
+
do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/sleuthkit
@@ -32,4 +38,4 @@ do-install:
istat sha1 mmls file md5 ${PREFIX}/bin
cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/tct/Makefile b/sysutils/tct/Makefile
index 1c43c532a301..1f042ef50ae2 100644
--- a/sysutils/tct/Makefile
+++ b/sysutils/tct/Makefile
@@ -24,6 +24,10 @@ MYPORTDOCS= CHANGES COPYRIGHT INSTALL LICENSE MANIFEST OS-NOTES README.FIRST TOD
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 600000
+BROKEN= "Does not build on FreeBSD >= 6.x"
+.endif
+
post-patch:
${SED} -e 's,/usr/local,${PREFIX},g' pkg-message > ${PKGMESSAGE}