aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2001-11-18 22:44:21 +0800
committernaddy <naddy@FreeBSD.org>2001-11-18 22:44:21 +0800
commit80d6df590cf6ecee267844703b1d5316ec862bf4 (patch)
tree2388ecd1d7c142e7c5679f46ccf6d6b12c8f97e1
parent33c6c6830e14dfa2b7bacb4d124914e2248bae49 (diff)
downloadfreebsd-ports-gnome-80d6df590cf6ecee267844703b1d5316ec862bf4.tar.gz
freebsd-ports-gnome-80d6df590cf6ecee267844703b1d5316ec862bf4.tar.zst
freebsd-ports-gnome-80d6df590cf6ecee267844703b1d5316ec862bf4.zip
* madplay now has esd support; properly deal with esound dependency.
* gmake isn't required any longer; remove dependency. Reviewed by: maintainer Approved by: trevor
-rw-r--r--audio/mad/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/audio/mad/Makefile b/audio/mad/Makefile
index 3872cc5f2d3c..d0397214775a 100644
--- a/audio/mad/Makefile
+++ b/audio/mad/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mad
PORTVERSION= 0.14.2b
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.mars.org/pub/mpeg/
@@ -16,11 +17,10 @@ MAINTAINER= jason@mastaler.com
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+WANT_ESOUND= yes
-USE_GMAKE= yes
USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
+INSTALLS_SHLIB= yes
LIBTOOLFILES= configure libmad/configure libid3tag/configure
CONFIGURE_ARGS= --enable-shared \
--disable-debugging \
@@ -31,4 +31,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= abxtest.1 madplay.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_ESOUND)
+USE_ESOUND= yes
+.else
+CONFIGURE_ARGS+= --without-esd
+.endif
+
+.include <bsd.port.post.mk>