aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2005-09-12 10:50:49 +0800
committerhrs <hrs@FreeBSD.org>2005-09-12 10:50:49 +0800
commit811f2075300c297e1fa0bf28492e17da933e13a6 (patch)
tree4eeafe211af6ce7c3dd39abc0a2b5d9b2ec8894c
parent7ffd91627de257bf9e67b2938f56e411e934fd4f (diff)
downloadfreebsd-ports-gnome-811f2075300c297e1fa0bf28492e17da933e13a6.tar.gz
freebsd-ports-gnome-811f2075300c297e1fa0bf28492e17da933e13a6.tar.zst
freebsd-ports-gnome-811f2075300c297e1fa0bf28492e17da933e13a6.zip
Fix a bug in post-install which can be triggered when the browser_plugins
directory does not exist. Pointed out by: sf
-rw-r--r--japanese/acroread/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/japanese/acroread/Makefile b/japanese/acroread/Makefile
index a212f856a5df..eccf77869090 100644
--- a/japanese/acroread/Makefile
+++ b/japanese/acroread/Makefile
@@ -53,8 +53,10 @@ do-install:
${BRANDELF} -t Linux ${INSTALLDIR}/Reader/intellinux/bin/acroread
post-install:
- ${LN} -s -f \
+ if [ -d ${PREFIX}/${PLUGINDIR} ]; then \
+ ${LN} -s -f \
${PREFIX}/${ACRODIR}/Browser/intellinux/nppdf.so \
- ${PREFIX}/${PLUGINDIR}/nppdf.so
+ ${PREFIX}/${PLUGINDIR}/nppdf.so; \
+ fi
.include <bsd.port.mk>