aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-07-05 15:31:48 +0800
committersobomax <sobomax@FreeBSD.org>2001-07-05 15:31:48 +0800
commit8227c7b39766512d0113e77eac04b0443e41256c (patch)
tree145a66909384fa5a51463055ffd0dd725974d548
parent8163a3b9fc9d64fa96a41561452e652b73b68fca (diff)
downloadfreebsd-ports-gnome-8227c7b39766512d0113e77eac04b0443e41256c.tar.gz
freebsd-ports-gnome-8227c7b39766512d0113e77eac04b0443e41256c.tar.zst
freebsd-ports-gnome-8227c7b39766512d0113e77eac04b0443e41256c.zip
By default install only binaries with `-new' suffix applied. This provides an
easy way to compile/use newest packages that don't build with oldest gettext without the headache associated with making it possible to install fill-blown gettext and gettext-devel on the same machine at the same time. Usually the following should be sufficient to fix ports that doesn't build with oldest gettext: BUILD_DEPENDS+= msgfmt-new:${PORTS}/devel/gettext-devel CONFIGURE_ENV+= MSGFMT=${LOCALBASE}/bin/msgfmt-new \ XGETTEXT=${LOCALBASE}/bin/xgettext-new
-rw-r--r--devel/gettext-devel/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/devel/gettext-devel/Makefile b/devel/gettext-devel/Makefile
index 7d5e6529d904..aa610ffa0745 100644
--- a/devel/gettext-devel/Makefile
+++ b/devel/gettext-devel/Makefile
@@ -34,11 +34,29 @@ post-patch:
pre-configure:
${RM} ${WRKSRC}/doc/gettext.info*
+.if !defined(WANT_FULL_GETTEXT)
+BINFILES= gettext msgcmp msgcomm msgfmt msgmerge msgunfmt \
+ ngettext xgettext
+PLIST= ${WRKDIR}/PLIST
+LIBTOOLFLAGS= --disable-ltlibs --disable-shared
+.undef MAN3
+.undef INSTALLS_SHLIB
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/misc/gettextize \
+ ${PREFIX}/bin/gettextize-new
+ @${ECHO} bin/gettextize-new > ${WRKDIR}/PLIST
+.for file in ${BINFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${file} ${PREFIX}/bin/${file}-new
+ @${ECHO} bin/${file}-new >> ${WRKDIR}/PLIST
+.endfor
+.else
post-install:
@install-info ${PREFIX}/info/gettext.info ${PREFIX}/info/dir
${MKDIR} ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/misc/po-mode.el \
${PREFIX}/share/emacs/site-lisp/po-mode.el
${MKDIR} ${X11BASE}/share/locale
+.endif
.include <bsd.port.mk>