aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-12-26 22:09:13 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:14:19 +0800
commit82589f3f07d45939492f259efb75d57c6d6522e7 (patch)
treec7d6715ca3adec6b4c13de162f33b7fe7b22484d
parentedba39ae7e880da35ccb8c0eb5a0b6611c6717db (diff)
downloadfreebsd-ports-gnome-82589f3f07d45939492f259efb75d57c6d6522e7.tar.gz
freebsd-ports-gnome-82589f3f07d45939492f259efb75d57c6d6522e7.tar.zst
freebsd-ports-gnome-82589f3f07d45939492f259efb75d57c6d6522e7.zip
Add textproc/diff-so-fancy.
diff-so-fancy strives to make your diff's human readable instead of machine readable. This helps improve code quality and help you spot defects faster. WWW: https://github.com/so-fancy/diff-so-fancy/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/diff-so-fancy/Makefile35
-rw-r--r--textproc/diff-so-fancy/distinfo3
-rw-r--r--textproc/diff-so-fancy/files/pkg-message.in6
-rw-r--r--textproc/diff-so-fancy/pkg-descr4
-rw-r--r--textproc/diff-so-fancy/pkg-plist5
6 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 19f41ce89707..1d3022f7347a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -113,6 +113,7 @@
SUBDIR += dictem
SUBDIR += dictfmt
SUBDIR += dictionary
+ SUBDIR += diff-so-fancy
SUBDIR += diffmark
SUBDIR += diffsplit
SUBDIR += diffstat
diff --git a/textproc/diff-so-fancy/Makefile b/textproc/diff-so-fancy/Makefile
new file mode 100644
index 000000000000..adc11bd20a4b
--- /dev/null
+++ b/textproc/diff-so-fancy/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= diff-so-fancy
+PORTVERSION= 1.1.1
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= rakuco@FreeBSD.org
+COMMENT= Fancier diff output formatter
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= perl5 shebangfix
+USE_GITHUB= yes
+USE_PERL5= run
+
+GH_ACCOUNT= so-fancy
+NO_ARCH= yes
+NO_BUILD= yes
+NO_CONFIGURE= yes
+SHEBANG_FILES= ${WRKSRC}/diff-so-fancy
+SUB_FILES= pkg-message
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/diff-so-fancy ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/lib/DiffHighlight.pm \
+ ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ ${INSTALL_DATA} ${WRKSRC}/history.md ${WRKSRC}/pro-tips.md \
+ ${WRKSRC}/readme.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/diff-so-fancy/distinfo b/textproc/diff-so-fancy/distinfo
new file mode 100644
index 000000000000..41039fe29fac
--- /dev/null
+++ b/textproc/diff-so-fancy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514291242
+SHA256 (so-fancy-diff-so-fancy-v1.1.1_GH0.tar.gz) = 9505fa729e1e5a4e3ca9af22db3c07342e8544f5151c73ccf05c6b3b3f2e835f
+SIZE (so-fancy-diff-so-fancy-v1.1.1_GH0.tar.gz) = 38014
diff --git a/textproc/diff-so-fancy/files/pkg-message.in b/textproc/diff-so-fancy/files/pkg-message.in
new file mode 100644
index 000000000000..ac819dca5045
--- /dev/null
+++ b/textproc/diff-so-fancy/files/pkg-message.in
@@ -0,0 +1,6 @@
+diff-so-fancy is normally used to format git's diff output.
+
+In order to configure git to use diff-so-fancy automatically, you can run:
+ $ git config --global core.pager "diff-so-fancy | less -R"
+
+See %%DOCSDIR%%/readme.md for more information.
diff --git a/textproc/diff-so-fancy/pkg-descr b/textproc/diff-so-fancy/pkg-descr
new file mode 100644
index 000000000000..271d2cfbbb43
--- /dev/null
+++ b/textproc/diff-so-fancy/pkg-descr
@@ -0,0 +1,4 @@
+diff-so-fancy strives to make your diff's human readable instead of machine
+readable. This helps improve code quality and help you spot defects faster.
+
+WWW: https://github.com/so-fancy/diff-so-fancy/
diff --git a/textproc/diff-so-fancy/pkg-plist b/textproc/diff-so-fancy/pkg-plist
new file mode 100644
index 000000000000..3a29454fca1d
--- /dev/null
+++ b/textproc/diff-so-fancy/pkg-plist
@@ -0,0 +1,5 @@
+bin/diff-so-fancy
+%%SITE_PERL%%/DiffHighlight.pm
+%%DOCSDIR%%/history.md
+%%DOCSDIR%%/pro-tips.md
+%%DOCSDIR%%/readme.md