aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2016-01-21 12:02:59 +0800
committervanilla <vanilla@FreeBSD.org>2016-01-21 12:02:59 +0800
commit828f76bde4da8f5056ff577da71bc983bdcac5dc (patch)
treedca4b669ebeff4d101907a0f4da8abeee431870f
parentc32d928a6fcd40da5967c2c2c03e68ca87593878 (diff)
downloadfreebsd-ports-gnome-828f76bde4da8f5056ff577da71bc983bdcac5dc.tar.gz
freebsd-ports-gnome-828f76bde4da8f5056ff577da71bc983bdcac5dc.tar.zst
freebsd-ports-gnome-828f76bde4da8f5056ff577da71bc983bdcac5dc.zip
1: Upgrade to 0.6.
2: remove USE_GCC. Approved by: maintainer via twitter.
-rw-r--r--devel/pure-stllib/Makefile9
-rw-r--r--devel/pure-stllib/distinfo4
-rw-r--r--devel/pure-stllib/files/patch-Makefile18
3 files changed, 10 insertions, 21 deletions
diff --git a/devel/pure-stllib/Makefile b/devel/pure-stllib/Makefile
index baf8cd5fb341..6a90aad4a0c2 100644
--- a/devel/pure-stllib/Makefile
+++ b/devel/pure-stllib/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= pure-stllib
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 0.6
CATEGORIES= devel
-MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+MASTER_SITES= https://bitbucket.org/purelang/pure-lang/downloads/
DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
@@ -13,9 +12,7 @@ COMMENT= Pure interface to C++ STL map and vectors
LICENSE= BSD3CLAUSE
-USES= pure pkgconfig
-
-USE_GCC= yes
+USES= pkgconfig pure
PORTDOCS= *
diff --git a/devel/pure-stllib/distinfo b/devel/pure-stllib/distinfo
index e863af0fdc8f..662be4448fd8 100644
--- a/devel/pure-stllib/distinfo
+++ b/devel/pure-stllib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pure/pure-stllib-0.5.tar.gz) = 555d68f0d38905a4804116e5a6f37e14bec5bad3264c7b2beab3ab68b07beaef
-SIZE (pure/pure-stllib-0.5.tar.gz) = 335191
+SHA256 (pure/pure-stllib-0.6.tar.gz) = 1d550764fc2f8ba6ddbd1fbd3da2d6965b69e2c992747265d9ebe4f16aa5e455
+SIZE (pure/pure-stllib-0.6.tar.gz) = 333766
diff --git a/devel/pure-stllib/files/patch-Makefile b/devel/pure-stllib/files/patch-Makefile
index cd59ecea62c1..40c8f31b8e70 100644
--- a/devel/pure-stllib/files/patch-Makefile
+++ b/devel/pure-stllib/files/patch-Makefile
@@ -1,19 +1,11 @@
---- ./Makefile.orig 2013-08-28 18:17:41.000000000 +0200
-+++ ./Makefile 2013-10-16 22:49:25.000000000 +0200
-@@ -17,12 +17,12 @@
+--- Makefile.orig 2014-03-23 10:09:16 UTC
++++ Makefile
+@@ -17,7 +17,7 @@ installdir = $(addprefix $(DESTDIR), $(
MOD_CXXFLAGS = $(PIC) $(shell pkg-config pure --cflags) $(CFLAGS) $(CPPFLAGS)
MOD_LDFLAGS = $(shell pkg-config pure --libs) $(LDFLAGS)
-CFLAGS = -g -O2 -Wall -Wextra
+CFLAGS ?= -g -O2 -Wall -Wextra
--ifeq "$(DLL)" ".dylib"
-+#ifeq "$(DLL)" ".dylib"
- # OSX may need this (untested)
--DLL_FLAGS = -install_name "$(libdir)/pure/$@"
--endif
-+#DLL_FLAGS = -install_name "$(libdir)/pure/$@"
-+#endif
-
- # Basic rules to build the module, clean, check, install and uninstall.
-
+ ifeq "$(DLL)" ".dylib"
+ DLL_FLAGS = -install_name "$(libdir)/pure/$@"