aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-09-02 09:52:34 +0800
committerjylefort <jylefort@FreeBSD.org>2005-09-02 09:52:34 +0800
commit8296bf6f8381b117af4d40fbc7cc82530ef0cfe2 (patch)
tree48ab75ef892dfaa68bd66c75e3b8b4279c4ebc13
parentcfec90525a29e6170734ce7d0bbf93466b94a7a2 (diff)
downloadfreebsd-ports-gnome-8296bf6f8381b117af4d40fbc7cc82530ef0cfe2.tar.gz
freebsd-ports-gnome-8296bf6f8381b117af4d40fbc7cc82530ef0cfe2.tar.zst
freebsd-ports-gnome-8296bf6f8381b117af4d40fbc7cc82530ef0cfe2.zip
Add p5-Net-OpenID-Server.
OpenID is a decentralized identity system, but one that's actually decentralized and doesn't entirely crumble if one company turns evil or goes out of business. An OpenID identity is just a URL. You can have multiple identities in the same way you can have multiple URLs. All OpenID does is provide a way to prove that you own a URL (identity). Anybody can run their own site using OpenID, and anybody can be an OpenID server, and they all work with each other without having to register with or pay anybody to "get started". An owner of a URL can pick which OpenID server to use. WWW: http://www.openid.net PR: ports/85284 Submitted by: Alex Kapranoff <kappa@rambler-co.ru>
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Net-OpenID-Server/Makefile26
-rw-r--r--security/p5-Net-OpenID-Server/distinfo2
-rw-r--r--security/p5-Net-OpenID-Server/pkg-descr14
-rw-r--r--security/p5-Net-OpenID-Server/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7bff0805f04e..a94072624857 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -329,6 +329,7 @@
SUBDIR += p5-IO-Socket-SSL
SUBDIR += p5-MD5
SUBDIR += p5-Module-Signature
+ SUBDIR += p5-Net-OpenID-Server
SUBDIR += p5-Net-SSLeay
SUBDIR += p5-Nmap-Scanner
SUBDIR += p5-OpenCA-CRL
diff --git a/security/p5-Net-OpenID-Server/Makefile b/security/p5-Net-OpenID-Server/Makefile
new file mode 100644
index 000000000000..1c470de8feaa
--- /dev/null
+++ b/security/p5-Net-OpenID-Server/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-OpenID-Server
+# Date created: July 25th 2005
+# Whom: Alex Kapranoff <kappa@rambler-co.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenID-Server
+PORTVERSION= 0.09
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kappa@freebsd.org.ua
+COMMENT= Reference implementation of OpenID server
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Net::OpenID::Server.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Net-OpenID-Server/distinfo b/security/p5-Net-OpenID-Server/distinfo
new file mode 100644
index 000000000000..24e5d8f48a1b
--- /dev/null
+++ b/security/p5-Net-OpenID-Server/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-OpenID-Server-0.09.tar.gz) = 49efee1aa7b9ee4c22358bd108c68316
+SIZE (Net-OpenID-Server-0.09.tar.gz) = 13892
diff --git a/security/p5-Net-OpenID-Server/pkg-descr b/security/p5-Net-OpenID-Server/pkg-descr
new file mode 100644
index 000000000000..8deebd6a0e64
--- /dev/null
+++ b/security/p5-Net-OpenID-Server/pkg-descr
@@ -0,0 +1,14 @@
+OpenID is a decentralized identity system, but one that's actually
+decentralized and doesn't entirely crumble if one company turns evil
+or goes out of business.
+
+An OpenID identity is just a URL. You can have multiple identities in
+the same way you can have multiple URLs. All OpenID does is provide a
+way to prove that you own a URL (identity).
+
+Anybody can run their own site using OpenID, and anybody can be an
+OpenID server, and they all work with each other without having to
+register with or pay anybody to "get started". An owner of a URL can
+pick which OpenID server to use.
+
+WWW: http://www.openid.net
diff --git a/security/p5-Net-OpenID-Server/pkg-plist b/security/p5-Net-OpenID-Server/pkg-plist
new file mode 100644
index 000000000000..56bcd9a6b804
--- /dev/null
+++ b/security/p5-Net-OpenID-Server/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/OpenID/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Server/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Server
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net/OpenID 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true