aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-10-29 21:01:50 +0800
committerflo <flo@FreeBSD.org>2012-10-29 21:01:50 +0800
commit837bbeeb217fd75b048ce769e6cb9e988de798dc (patch)
treef4598c376181a461019a4ed826b108162c5f85e7
parent91bc84db85df8049137c7ac28336ca84abfa0967 (diff)
downloadfreebsd-ports-gnome-837bbeeb217fd75b048ce769e6cb9e988de798dc.tar.gz
freebsd-ports-gnome-837bbeeb217fd75b048ce769e6cb9e988de798dc.tar.zst
freebsd-ports-gnome-837bbeeb217fd75b048ce769e6cb9e988de798dc.zip
- Update to 1.6.2 for php 5.4 compatibility, remove custom patch for 5.4
compatibility - remove what looks like a leftover debug echo to fix BETTER_COMPRESSION option [1] PR: ports/170988 [1] Reported by: Andrea Venturoli <ml@netfence.it> [1] Feature safe: yes
-rw-r--r--archivers/pecl-lzf/Makefile10
-rw-r--r--archivers/pecl-lzf/distinfo4
-rw-r--r--archivers/pecl-lzf/files/patch-lzf.c11
3 files changed, 4 insertions, 21 deletions
diff --git a/archivers/pecl-lzf/Makefile b/archivers/pecl-lzf/Makefile
index 394519ee097c..6966dd7d231a 100644
--- a/archivers/pecl-lzf/Makefile
+++ b/archivers/pecl-lzf/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: pecl-lzf
-# Date created: 2006/09/07
-# Whom: chinsan <chinsan.tw@gmail.com>
-#
+# Created by: chinsan <chinsan.tw@gmail.com>
# $FreeBSD$
-#
PORTNAME= lzf
-PORTVERSION= 1.5.2
-PORTREVISION= 1
+PORTVERSION= 1.6.2
CATEGORIES= archivers pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -30,7 +25,6 @@ BETTER_COMPRESSION_DESC= Better compression ratio
.if ${PORT_OPTIONS:MBETTER_COMPRESSION}
CONFIGURE_ARGS+= --enable-lzf-better-compression
- @${ECHO_MSG} "--enable-lzf-better-compression"
.endif
.include <bsd.port.mk>
diff --git a/archivers/pecl-lzf/distinfo b/archivers/pecl-lzf/distinfo
index 9485e2c27b1f..c73c23f52c66 100644
--- a/archivers/pecl-lzf/distinfo
+++ b/archivers/pecl-lzf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/lzf-1.5.2.tgz) = b295c4eec62b269daf5715ebcd3a9596a551774ef5132e15965bc14239cf8495
-SIZE (PECL/lzf-1.5.2.tgz) = 11320
+SHA256 (PECL/lzf-1.6.2.tgz) = b381ac66cd12cc753e768c602f87d542fcd9718039cec4947d37f1229a7b93e3
+SIZE (PECL/lzf-1.6.2.tgz) = 13204
diff --git a/archivers/pecl-lzf/files/patch-lzf.c b/archivers/pecl-lzf/files/patch-lzf.c
deleted file mode 100644
index 2c9d46bd1f4b..000000000000
--- a/archivers/pecl-lzf/files/patch-lzf.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./lzf.c.orig 2009-03-02 17:53:17.000000000 +0300
-+++ ./lzf.c 2012-06-06 10:11:48.202502799 +0400
-@@ -37,7 +37,7 @@
- *
- * Every user visible function must have an entry in lzf_functions[].
- */
--function_entry lzf_functions[] = {
-+zend_function_entry lzf_functions[] = {
- PHP_FE(lzf_compress, NULL)
- PHP_FE(lzf_decompress, NULL)
- PHP_FE(lzf_optimized_for, NULL)