aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-11-20 15:09:24 +0800
committerkrion <krion@FreeBSD.org>2004-11-20 15:09:24 +0800
commit839ae919607e62cc4136274cf806defc2456b0c5 (patch)
tree4aee5cef2e0f7464548932552f3cf507fc8236e7
parentfcc584e755cc799b7ed5ede45fc1be199b5bf188 (diff)
downloadfreebsd-ports-gnome-839ae919607e62cc4136274cf806defc2456b0c5.tar.gz
freebsd-ports-gnome-839ae919607e62cc4136274cf806defc2456b0c5.tar.zst
freebsd-ports-gnome-839ae919607e62cc4136274cf806defc2456b0c5.zip
Fix package build.
Reported by: pointyhat
-rw-r--r--net-p2p/gnunet/Makefile13
-rw-r--r--net-p2p/gnunet/pkg-plist2
-rw-r--r--net/gnunet/Makefile13
-rw-r--r--net/gnunet/pkg-plist2
4 files changed, 26 insertions, 4 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index a78d0ea59200..0596916b280b 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnunet
PORTVERSION= 0.6.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.ovmj.org/GNUnet/download/ \
${MASTER_SITE_GNU}
@@ -83,8 +84,18 @@ PLIST_SUB+= WITH_IPV6=""
PLIST_SUB+= WITH_IPV6="@comment "
.endif
+.if defined(WITH_GUILE)
+LIB_DEPENDS+= guile.15:${PORTSDIR}/lang/guile
+CONFIGURE_ARGS+= --enable-guile
+MAN1+= gnunet-download-manager.1
+PLIST_SUB+= WITH_GUILE=""
+.else
+CONFIGURE_ARGS+= --disable-guile
+PLIST_SUB+= WITH_GUILE="@comment "
+.endif
+
MAN1= gnunet-chat.1 gnunet-check.1 gnunet-convert.1 \
- gnunet-delete.1 gnunet-directory.1 gnunet-download-manager.1 \
+ gnunet-delete.1 gnunet-directory.1 \
gnunet-download.1 gnunet-gtk.1 gnunet-insert.1 \
gnunet-peer-info.1 gnunet-pseudonym.1 \
gnunet-search.1 gnunet-stats.1 gnunet-tbench.1 \
diff --git a/net-p2p/gnunet/pkg-plist b/net-p2p/gnunet/pkg-plist
index 6201d1406370..7ff5c2b77282 100644
--- a/net-p2p/gnunet/pkg-plist
+++ b/net-p2p/gnunet/pkg-plist
@@ -6,7 +6,7 @@ bin/gnunet-dht-join
bin/gnunet-dht-query
bin/gnunet-directory
bin/gnunet-download
-bin/gnunet-download-manager.scm
+%%WITH_GUILE%%bin/gnunet-download-manager.scm
bin/gnunet-gtk
bin/gnunet-insert
bin/gnunet-peer-info
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index a78d0ea59200..0596916b280b 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnunet
PORTVERSION= 0.6.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.ovmj.org/GNUnet/download/ \
${MASTER_SITE_GNU}
@@ -83,8 +84,18 @@ PLIST_SUB+= WITH_IPV6=""
PLIST_SUB+= WITH_IPV6="@comment "
.endif
+.if defined(WITH_GUILE)
+LIB_DEPENDS+= guile.15:${PORTSDIR}/lang/guile
+CONFIGURE_ARGS+= --enable-guile
+MAN1+= gnunet-download-manager.1
+PLIST_SUB+= WITH_GUILE=""
+.else
+CONFIGURE_ARGS+= --disable-guile
+PLIST_SUB+= WITH_GUILE="@comment "
+.endif
+
MAN1= gnunet-chat.1 gnunet-check.1 gnunet-convert.1 \
- gnunet-delete.1 gnunet-directory.1 gnunet-download-manager.1 \
+ gnunet-delete.1 gnunet-directory.1 \
gnunet-download.1 gnunet-gtk.1 gnunet-insert.1 \
gnunet-peer-info.1 gnunet-pseudonym.1 \
gnunet-search.1 gnunet-stats.1 gnunet-tbench.1 \
diff --git a/net/gnunet/pkg-plist b/net/gnunet/pkg-plist
index 6201d1406370..7ff5c2b77282 100644
--- a/net/gnunet/pkg-plist
+++ b/net/gnunet/pkg-plist
@@ -6,7 +6,7 @@ bin/gnunet-dht-join
bin/gnunet-dht-query
bin/gnunet-directory
bin/gnunet-download
-bin/gnunet-download-manager.scm
+%%WITH_GUILE%%bin/gnunet-download-manager.scm
bin/gnunet-gtk
bin/gnunet-insert
bin/gnunet-peer-info