aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2012-10-17 10:06:42 +0800
committertj <tj@FreeBSD.org>2012-10-17 10:06:42 +0800
commit8486bcf4885f2030ca317bbdfe4fb681d21371f9 (patch)
tree67b5f64a980c22df124b9bce3a93e138107f4b9e
parentb499d9bf6737f62d2ce38c63cfae046b5c32e50f (diff)
downloadfreebsd-ports-gnome-8486bcf4885f2030ca317bbdfe4fb681d21371f9.tar.gz
freebsd-ports-gnome-8486bcf4885f2030ca317bbdfe4fb681d21371f9.tar.zst
freebsd-ports-gnome-8486bcf4885f2030ca317bbdfe4fb681d21371f9.zip
This module subclasses Log::Dispatch::File for logging to date/time stamped
files. WWW: http://search.cpan.org/dist/Log-Dispatch-File-Rolling/ Feature safe: yes Approved by: eadler (mentor)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Dispatch-File-Rolling/Makefile21
-rw-r--r--devel/p5-Log-Dispatch-File-Rolling/distinfo2
-rw-r--r--devel/p5-Log-Dispatch-File-Rolling/pkg-descr4
-rw-r--r--devel/p5-Log-Dispatch-File-Rolling/pkg-plist10
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 25057667dd97..959a801e3f5c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2122,6 +2122,7 @@
SUBDIR += p5-Log-Dispatch-DBI
SUBDIR += p5-Log-Dispatch-Dir
SUBDIR += p5-Log-Dispatch-Email-EmailSend
+ SUBDIR += p5-Log-Dispatch-File-Rolling
SUBDIR += p5-Log-Dispatch-File-Stamped
SUBDIR += p5-Log-Dispatch-FileRotate
SUBDIR += p5-Log-Dispatch-FileShared
diff --git a/devel/p5-Log-Dispatch-File-Rolling/Makefile b/devel/p5-Log-Dispatch-File-Rolling/Makefile
new file mode 100644
index 000000000000..dd056259455a
--- /dev/null
+++ b/devel/p5-Log-Dispatch-File-Rolling/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Log-Dispatch-File-Rolling
+PORTVERSION= 1.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Object for logging to date/time/pid stamped files
+
+BUILD_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Log4perl>=1.38:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Log4perl>=1.38:${PORTSDIR}/devel/p5-Log-Log4perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Dispatch::File::Rolling.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Dispatch-File-Rolling/distinfo b/devel/p5-Log-Dispatch-File-Rolling/distinfo
new file mode 100644
index 000000000000..88fdcf22853a
--- /dev/null
+++ b/devel/p5-Log-Dispatch-File-Rolling/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Log-Dispatch-File-Rolling-1.06.tar.gz) = 8475ded190eea61654c570a06179e01462b9e9a5c3c36007c0306e5d113ce119
+SIZE (Log-Dispatch-File-Rolling-1.06.tar.gz) = 6574
diff --git a/devel/p5-Log-Dispatch-File-Rolling/pkg-descr b/devel/p5-Log-Dispatch-File-Rolling/pkg-descr
new file mode 100644
index 000000000000..989645f56f23
--- /dev/null
+++ b/devel/p5-Log-Dispatch-File-Rolling/pkg-descr
@@ -0,0 +1,4 @@
+This module subclasses Log::Dispatch::File for logging to date/time stamped
+files.
+
+WWW: http://search.cpan.org/dist/Log-Dispatch-File-Rolling/
diff --git a/devel/p5-Log-Dispatch-File-Rolling/pkg-plist b/devel/p5-Log-Dispatch-File-Rolling/pkg-plist
new file mode 100644
index 000000000000..7da32bbf5898
--- /dev/null
+++ b/devel/p5-Log-Dispatch-File-Rolling/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Log/Dispatch/File/Rolling.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/File/Rolling/.packlist
+@dirrm %%SITE_PERL%%/Log/Dispatch/File/Rolling
+@dirrmtry %%SITE_PERL%%/Log/Dispatch/File
+@dirrmtry %%SITE_PERL%%/Log/Dispatch
+@dirrmtry %%SITE_PERL%%/Log
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/File/Rolling
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log