aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-05-20 18:22:32 +0800
committervanilla <vanilla@FreeBSD.org>2014-05-20 18:22:32 +0800
commit84ef461e7e4077ec2fcfde3d43e118a096ead23f (patch)
tree7b76ba83fb8544c82eda047bf63f076b1e40e0c1
parent2f3d39a53aca9a0c87f23f1cdd210ca6b2410dfc (diff)
downloadfreebsd-ports-gnome-84ef461e7e4077ec2fcfde3d43e118a096ead23f.tar.gz
freebsd-ports-gnome-84ef461e7e4077ec2fcfde3d43e118a096ead23f.tar.zst
freebsd-ports-gnome-84ef461e7e4077ec2fcfde3d43e118a096ead23f.zip
Support staging.
Approved by: portmgr@
-rw-r--r--dns/dnsmax-perl/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/dns/dnsmax-perl/Makefile b/dns/dnsmax-perl/Makefile
index 7997a28ca6bc..421af3bfb746 100644
--- a/dns/dnsmax-perl/Makefile
+++ b/dns/dnsmax-perl/Makefile
@@ -15,20 +15,17 @@ BUILD_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
NO_BUILD= yes
-USES= perl5 zip
+USES= perl5 zip shebangfix
+SHEBANG_FILES= dnsmax.pl
PLIST_FILES= bin/dnsmax-perl
PORTDOCS= LICENSE INSTALL README
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/dnsmax.pl ${PREFIX}/bin/dnsmax-perl
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/dnsmax.pl ${STAGEDIR}${PREFIX}/bin/dnsmax-perl
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKDIR}/${DISTNAME} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKDIR}/${DISTNAME} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>