aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-12 14:27:41 +0800
committeraz <az@FreeBSD.org>2013-09-12 14:27:41 +0800
commit8651fae3b8dc39295cf7c6175a868826d4344747 (patch)
tree6e473a930c60d1c8d5c8a722b75b4e61c883d3e7
parentc42e716ffe041e92016227906ead822296f08b3c (diff)
downloadfreebsd-ports-gnome-8651fae3b8dc39295cf7c6175a868826d4344747.tar.gz
freebsd-ports-gnome-8651fae3b8dc39295cf7c6175a868826d4344747.tar.zst
freebsd-ports-gnome-8651fae3b8dc39295cf7c6175a868826d4344747.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
-rw-r--r--comms/gscmxx/Makefile9
-rw-r--r--comms/o2sms/Makefile9
-rw-r--r--comms/p5-Cisco-UCS/Makefile3
-rw-r--r--comms/p5-Device-Gsm/Makefile9
-rw-r--r--comms/p5-SMS-Send-DeviceGsm/Makefile9
-rw-r--r--comms/p5-SMS-Send-NexmoUnicode/Makefile9
-rw-r--r--comms/p5-SMS-Send-TW-HiAir/Makefile9
-rw-r--r--comms/p5-SMS-Send-TW-PChome/Makefile9
-rw-r--r--comms/p5-SMS-Send-TW-Qma/Makefile9
-rw-r--r--comms/p5-SMS-Send-TW-Socket2Air/Makefile3
-rw-r--r--comms/p5-SMS-Send-TW-chtsns/Makefile9
-rw-r--r--comms/p5-SMS-Send-TW-emome/Makefile9
-rw-r--r--comms/uird/Makefile8
-rw-r--r--comms/yfklog/Makefile8
-rw-r--r--shells/p5-Shell-Perl/Makefile9
-rw-r--r--shells/psh/Makefile3
-rw-r--r--shells/shell-include/Makefile8
-rw-r--r--shells/vshnu/Makefile10
18 files changed, 48 insertions, 94 deletions
diff --git a/comms/gscmxx/Makefile b/comms/gscmxx/Makefile
index 89b905aaf2bc..9663777de12d 100644
--- a/comms/gscmxx/Makefile
+++ b/comms/gscmxx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gscmxx
-# Date created: 13 May 2003
-# Whom: svmohr
-#
+# Created by: svmohr
# $FreeBSD$
-#
PORTNAME= gscmxx
PORTVERSION= 0.4.1
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Image-Size>=0:${PORTSDIR}/graphics/p5-Image-Size \
scmxx:${PORTSDIR}/comms/scmxx \
convert:${PORTSDIR}/graphics/ImageMagick
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
USE_GNOME= gtk12
MAN1= gscmxx.1
diff --git a/comms/o2sms/Makefile b/comms/o2sms/Makefile
index e75f8fdf3a1b..95b229757125 100644
--- a/comms/o2sms/Makefile
+++ b/comms/o2sms/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: o2sms
-# Date created: June 13th, 2006
-# Whom: Conor McDermottroe <ports@mcdermottroe.com>
-#
+# Created by: Conor McDermottroe <ports@mcdermottroe.com>
# $FreeBSD$
-#
PORTNAME= o2sms
PORTVERSION= 3.36
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-TestGen4Web-Runner>=0:${PORTSDIR}/www/p5-TestGen4Web-Runner
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= aftsms.1 \
o2sms.1 \
diff --git a/comms/p5-Cisco-UCS/Makefile b/comms/p5-Cisco-UCS/Makefile
index b82330346a34..93c10a443c35 100644
--- a/comms/p5-Cisco-UCS/Makefile
+++ b/comms/p5-Cisco-UCS/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Cisco::UCS.3 Cisco::UCS::Blade.3 Cisco::UCS::Chassis.3 \
Cisco::UCS::Common::EthernetPort.3 Cisco::UCS::Common::Fan.3 \
diff --git a/comms/p5-Device-Gsm/Makefile b/comms/p5-Device-Gsm/Makefile
index e92d009687aa..6782e3bb7a95 100644
--- a/comms/p5-Device-Gsm/Makefile
+++ b/comms/p5-Device-Gsm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Device-Gsm
-# Date created: 09 May 2006
-# Whom: Anders Nordby <anders@FreeBSD.org>
-#
+# Created by: Anders Nordby <anders@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Device-Gsm
PORTVERSION= 1.60
@@ -17,7 +13,8 @@ COMMENT= Perl interface to GSM phones/modems on serial ports
BUILD_DEPENDS= p5-Device-Modem>=0:${PORTSDIR}/comms/p5-Device-Modem
RUN_DEPENDS= p5-Device-Modem>=0:${PORTSDIR}/comms/p5-Device-Modem
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Device::Gsm::Sms.3 Device::Gsm::Pdu.3 Device::Gsm.3
diff --git a/comms/p5-SMS-Send-DeviceGsm/Makefile b/comms/p5-SMS-Send-DeviceGsm/Makefile
index ab08646b2c82..7ec29492b4ce 100644
--- a/comms/p5-SMS-Send-DeviceGsm/Makefile
+++ b/comms/p5-SMS-Send-DeviceGsm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-DeviceGsm
-# Date created: 2007-09-22
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-DeviceGsm
PORTVERSION= 1.06
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-SMS-Send>=0.04:${PORTSDIR}/comms/p5-SMS-Send \
p5-Device-Gsm>=1.45:${PORTSDIR}/comms/p5-Device-Gsm
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::DeviceGsm.3
diff --git a/comms/p5-SMS-Send-NexmoUnicode/Makefile b/comms/p5-SMS-Send-NexmoUnicode/Makefile
index 917418f35623..c3caea11ed18 100644
--- a/comms/p5-SMS-Send-NexmoUnicode/Makefile
+++ b/comms/p5-SMS-Send-NexmoUnicode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-NexmoUnicode
-# Date created: 2011-12-01
-# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
-#
+# Created by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-NexmoUnicode
PORTVERSION= 0.01
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Nexmo-SMS>=0.04:${PORTSDIR}/comms/p5-Nexmo-SMS \
p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::NexmoUnicode.3
diff --git a/comms/p5-SMS-Send-TW-HiAir/Makefile b/comms/p5-SMS-Send-TW-HiAir/Makefile
index 5737235ad7a5..da5b4e8066b4 100644
--- a/comms/p5-SMS-Send-TW-HiAir/Makefile
+++ b/comms/p5-SMS-Send-TW-HiAir/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-TW-HiAir
-# Date created: 2010-01-06
-# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
-#
+# Created by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-TW-HiAir
PORTVERSION= 0.02
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::TW::HiAir.3
diff --git a/comms/p5-SMS-Send-TW-PChome/Makefile b/comms/p5-SMS-Send-TW-PChome/Makefile
index c42f6584289d..d62ac0bfcaf8 100644
--- a/comms/p5-SMS-Send-TW-PChome/Makefile
+++ b/comms/p5-SMS-Send-TW-PChome/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-TW-PChome
-# Date created: 2007-04-06
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-TW-PChome
PORTVERSION= 0.03
@@ -20,7 +16,8 @@ RUN_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::TW::PChome.3
diff --git a/comms/p5-SMS-Send-TW-Qma/Makefile b/comms/p5-SMS-Send-TW-Qma/Makefile
index 4aef0797a529..e8e67250eccd 100644
--- a/comms/p5-SMS-Send-TW-Qma/Makefile
+++ b/comms/p5-SMS-Send-TW-Qma/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-TW-Qma
-# Date created: 2011-03-20
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-TW-Qma
PORTVERSION= 0.01
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::TW::Qma.3
diff --git a/comms/p5-SMS-Send-TW-Socket2Air/Makefile b/comms/p5-SMS-Send-TW-Socket2Air/Makefile
index 2b101d35994c..e48c8b482979 100644
--- a/comms/p5-SMS-Send-TW-Socket2Air/Makefile
+++ b/comms/p5-SMS-Send-TW-Socket2Air/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::TW::Socket2Air.3
diff --git a/comms/p5-SMS-Send-TW-chtsns/Makefile b/comms/p5-SMS-Send-TW-chtsns/Makefile
index 2d26f6a6a2aa..daed4d7c57c9 100644
--- a/comms/p5-SMS-Send-TW-chtsns/Makefile
+++ b/comms/p5-SMS-Send-TW-chtsns/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-TW-chtsns
-# Date created: 2010-01-06
-# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
-#
+# Created by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-TW-chtsns
PORTVERSION= 0.03
@@ -21,7 +17,8 @@ RUN_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::TW::chtsns.3
diff --git a/comms/p5-SMS-Send-TW-emome/Makefile b/comms/p5-SMS-Send-TW-emome/Makefile
index 7aae34bb2d3d..35b7d0e85b9d 100644
--- a/comms/p5-SMS-Send-TW-emome/Makefile
+++ b/comms/p5-SMS-Send-TW-emome/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SMS-Send-TW-emome
-# Date created: 2007-10-10
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= SMS-Send-TW-emome
PORTVERSION= 0.04
@@ -20,7 +16,8 @@ RUN_DEPENDS= p5-SMS-Send>=0.03:${PORTSDIR}/comms/p5-SMS-Send \
p5-Text-Iconv>=:${PORTSDIR}/converters/p5-Text-Iconv
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SMS::Send::TW::emome.3
diff --git a/comms/uird/Makefile b/comms/uird/Makefile
index aa38dd8023e4..051d340face8 100644
--- a/comms/uird/Makefile
+++ b/comms/uird/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: uird
-# Date created: 2005-11-21
-# Whom: David Thiel <lx@redundancy.redundancy.org>
-#
+# Created by: David Thiel <lx@redundancy.redundancy.org>
# $FreeBSD$
-#
PORTNAME= uird
PORTVERSION= 1.1
@@ -16,7 +12,7 @@ MAINTAINER= lx@FreeBSD.org
COMMENT= The Universal IR Receiver Daemon
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= ${PORTNAME}
diff --git a/comms/yfklog/Makefile b/comms/yfklog/Makefile
index 714968cfeb13..008d2ab2c26b 100644
--- a/comms/yfklog/Makefile
+++ b/comms/yfklog/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: yflklog
-# Date created: 17 October 2007
-# Whom: db
-#
+# Created by: db
# $FreeBSD$
-#
PORTNAME= yfklog
PORTVERSION= 0.3.5
@@ -25,7 +21,7 @@ RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses \
hamlib>=0:${PORTSDIR}/comms/hamlib \
p5-Net-FTP-File>=0:${PORTSDIR}/net/p5-Net-FTP-File
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
MAN1= yfklog.1
diff --git a/shells/p5-Shell-Perl/Makefile b/shells/p5-Shell-Perl/Makefile
index b50a4707a147..a5fc9d0ebb01 100644
--- a/shells/p5-Shell-Perl/Makefile
+++ b/shells/p5-Shell-Perl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Shell-Perl
-# Date created: 2008-02-27
-# Whom: Shinsuke Matsui <smatsui@karashi.org>
-#
+# Created by: Shinsuke Matsui <smatsui@karashi.org>
# $FreeBSD$
-#
PORTNAME= Shell-Perl
PORTVERSION= 0.0022
@@ -25,7 +21,8 @@ BUILD_DEPENDS= p5-Test-Script>=0:${PORTSDIR}/devel/p5-Test-Script \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
p5-Test-Expect>=0:${PORTSDIR}/devel/p5-Test-Expect
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN1= pirl.1
MAN3= Shell::Perl.3 Shell::Perl::Dumper.3
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
index 08031ba5dd74..2f6425a67b92 100644
--- a/shells/psh/Makefile
+++ b/shells/psh/Makefile
@@ -11,7 +11,8 @@ MASTER_SITE_SUBDIR= CPAN:GREGOR
MAINTAINER= garga@FreeBSD.org
COMMENT= New shell made entirely out of a Perl script
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
SUB_FILES= pkg-install pkg-deinstall
diff --git a/shells/shell-include/Makefile b/shells/shell-include/Makefile
index c470584c3acc..fbc730af2ad7 100644
--- a/shells/shell-include/Makefile
+++ b/shells/shell-include/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qar-bufo
-# Date created: 18 April 2007
-# Whom: Zane C. Bowers
-#
+# Created by: Zane C. Bowers
# $FreeBSD$
-#
PORTNAME= shell-include
PORTVERSION= 0.1.2
@@ -14,7 +10,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= vvelox@vvelox.net
COMMENT= A include system for shell scripts
-USE_PERL5= yes
+USES= perl5
MAN3= random::shortIntRandom.3 \
random.3 \
diff --git a/shells/vshnu/Makefile b/shells/vshnu/Makefile
index bb0746ca8914..d83c01004ba1 100644
--- a/shells/vshnu/Makefile
+++ b/shells/vshnu/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: vshnu
-# Date created: Feb 26, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= vshnu
PORTVERSION= 1.0305
@@ -18,6 +13,7 @@ COMMENT= New Visual Shell
BUILD_DEPENDS= p5-Term-Screen>=0:${PORTSDIR}/devel/p5-Term-Screen
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>