aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2016-01-21 20:20:10 +0800
committervg <vg@FreeBSD.org>2016-01-21 20:20:10 +0800
commit8726bfcf1d1445d08514aa8f17d9eff25c5343fb (patch)
treef8eba0471310be52404e797da47bfe0df531ab53
parentbb5313ad41857b0b764a13012d5feecdd2621392 (diff)
downloadfreebsd-ports-gnome-8726bfcf1d1445d08514aa8f17d9eff25c5343fb.tar.gz
freebsd-ports-gnome-8726bfcf1d1445d08514aa8f17d9eff25c5343fb.tar.zst
freebsd-ports-gnome-8726bfcf1d1445d08514aa8f17d9eff25c5343fb.zip
- Update to 1.6.8.371
-rw-r--r--databases/tarantool/Makefile24
-rw-r--r--databases/tarantool/distinfo4
-rw-r--r--databases/tarantool/files/extra-patch-src_trivia_config.h.cmake16
-rw-r--r--databases/tarantool/files/patch-cmake_compiler.cmake13
-rw-r--r--databases/tarantool/files/patch-extra_dist_CMakeLists.txt51
-rw-r--r--databases/tarantool/files/patch-extra_dist_default_tarantool.in13
-rw-r--r--databases/tarantool/files/patch-extra_dist_tarantoolctl44
-rw-r--r--databases/tarantool/files/patch-src_box_lua_load__cfg.lua20
-rw-r--r--databases/tarantool/files/patch-src_lib_csv_csv.h10
-rw-r--r--databases/tarantool/files/patch-third__party_libev_ev.c11
-rw-r--r--databases/tarantool/files/patch-third__party_luajit_src_Makefile30
-rw-r--r--databases/tarantool/pkg-plist5
12 files changed, 60 insertions, 181 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 5d4c5e153b66..356c85ff81f3 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -2,20 +2,17 @@
# $FreeBSD$
PORTNAME= tarantool
-PORTVERSION= 1.6.6
+PORTVERSION= 1.6.8.371
CATEGORIES= databases
-MASTER_SITES= http://tarantool.org/dist/master/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${TR_REV}-src
+MASTER_SITES= http://tarantool.org/dist/1.6/
MAINTAINER= vg@FreeBSD.org
COMMENT= NoSQL database running in a Lua application server
LICENSE= BSD2CLAUSE
-TR_REV= 130-ge3f2420
MAKE_JOBS_UNSAFE=yes
USES= cmake compiler:c++11-lang gettext gmake perl5 readline
-USE_GCC= yes # clang bug PR/201270
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
@@ -25,9 +22,9 @@ TT_RUNDIR?= /var/run/tarantool
TT_LOGDIR?= /var/log/tarantool
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man \
- -DCMAKE_INSTALL_SYSCONFDIR=${ETCDIR} \
- -DCMAKE_LOCALSTATE_DIR=${DATADIR} \
- -DTARANTOOL_DATADIR="${TT_DATADIR}"
+ -DCMAKE_INSTALL_FULL_SYSCONFDIR=${ETCDIR} \
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
+ -DENABLE_DIST=ON
USERS= tarantool
GROUPS= tarantool
@@ -52,11 +49,6 @@ NOT_FOR_ARCHS_REASON= not yet ported to this architecture
.include <bsd.port.options.mk>
-.include "${.CURDIR}/../../Mk/bsd.default-versions.mk"
-.if defined(USE_GCC) && ${USE_GCC} == yes && ${GCC_DEFAULT} == 4.8
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_trivia_config.h.cmake
-.endif
-
.if ${PORT_OPTIONS:MDEBUG}
CMAKE_BUILD_TYPE= RelWithDebugInfo
CMAKE_ARGS+= -DENABLE_BACKTRACE=ON
@@ -65,10 +57,4 @@ CMAKE_BUILD_TYPE= Rel
CMAKE_ARGS+= -DENABLE_BACKTRACE=OFF
.endif
-post-install:
- ${MKDIR} ${STAGEDIR}${TT_LOGDIR} \
- ${STAGEDIR}${TT_DATADIR} \
- ${STAGEDIR}${TT_RUNDIR} \
- ${STAGEDIR}${ETCDIR}/instances.enabled
-
.include <bsd.port.mk>
diff --git a/databases/tarantool/distinfo b/databases/tarantool/distinfo
index 23a599a3666f..883ed6ceaf33 100644
--- a/databases/tarantool/distinfo
+++ b/databases/tarantool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tarantool-1.6.6-130-ge3f2420-src.tar.gz) = a14f5a89c1a7e4695df4f02b963f30d7d537bd6bc0a3ae862c88ffc80e2cf499
-SIZE (tarantool-1.6.6-130-ge3f2420-src.tar.gz) = 3791681
+SHA256 (tarantool-1.6.8.371.tar.gz) = 73ffe8d960e2a17528d5743aaf273dc0f33f27714f9e2a24bb5c8133b092131c
+SIZE (tarantool-1.6.8.371.tar.gz) = 4894701
diff --git a/databases/tarantool/files/extra-patch-src_trivia_config.h.cmake b/databases/tarantool/files/extra-patch-src_trivia_config.h.cmake
deleted file mode 100644
index 15ffb26126c5..000000000000
--- a/databases/tarantool/files/extra-patch-src_trivia_config.h.cmake
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/trivia/config.h.cmake.orig 2015-05-15 14:01:37 UTC
-+++ src/trivia/config.h.cmake
-@@ -21,6 +21,13 @@
- #cmakedefine TARGET_OS_LINUX 1
- /* Defined if building for FreeBSD */
- #cmakedefine TARGET_OS_FREEBSD 1
-+#if defined(TARGET_OS_FREEBSD)
-+/*
-+ * Fix build with GCC 4.8 when _ThreadRuneLocale undeclared
-+ * on FreeBSD.
-+ */
-+#define __RUNETYPE_INTERNAL
-+#endif
- /* Defined if building for Darwin */
- #cmakedefine TARGET_OS_DARWIN 1
- /*
diff --git a/databases/tarantool/files/patch-cmake_compiler.cmake b/databases/tarantool/files/patch-cmake_compiler.cmake
deleted file mode 100644
index aadc2c84cb0e..000000000000
--- a/databases/tarantool/files/patch-cmake_compiler.cmake
+++ /dev/null
@@ -1,13 +0,0 @@
---- cmake/compiler.cmake.orig 2015-08-22 18:47:17 UTC
-+++ cmake/compiler.cmake
-@@ -129,6 +129,10 @@ macro(enable_tnt_compile_flags)
- if (CMAKE_COMPILER_IS_GNUCC)
- # A workaround for Redhat Developer Toolset 2.x on RHEL/CentOS 5.x
- add_compile_flags("C" "-fno-gnu89-inline")
-+ if (NOT CMAKE_SIZEOF_VOID_P EQUAL 8)
-+ add_compile_flags("C;CXX"
-+ "-march=i686")
-+ endif()
- endif()
-
- add_definitions("-D__STDC_FORMAT_MACROS=1")
diff --git a/databases/tarantool/files/patch-extra_dist_CMakeLists.txt b/databases/tarantool/files/patch-extra_dist_CMakeLists.txt
new file mode 100644
index 000000000000..fb7c769035ae
--- /dev/null
+++ b/databases/tarantool/files/patch-extra_dist_CMakeLists.txt
@@ -0,0 +1,51 @@
+--- extra/dist/CMakeLists.txt.orig 2016-01-20 16:22:43 UTC
++++ extra/dist/CMakeLists.txt
+@@ -5,7 +5,11 @@ include(systemd)
+ #
+
+ # Default path to data in default/tarantool
+-set(TARANTOOL_DATADIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/lib/tarantool")
++if (TARGET_OS_FREEBSD)
++ set(TARANTOOL_DATADIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/db/tarantool")
++else()
++ set(TARANTOOL_DATADIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/lib/tarantool")
++endif()
+ message (STATUS "tarantoolctl datadir: ${TARANTOOL_DATADIR}")
+ set(TARANTOOL_LOGDIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/log/tarantool")
+ message (STATUS "tarantoolctl logdir: ${TARANTOOL_LOGDIR}")
+@@ -13,7 +17,9 @@ set(TARANTOOL_RUNDIR "${CMAKE_INSTALL_FU
+ message (STATUS "tarantoolctl rundir: ${TARANTOOL_RUNDIR}")
+
+ # config file for tarantoolctl
+-if (NOT IS_DIRECTORY "${CMAKE_INSTALL_SYSCONFDIR}/sysconfig")
++if (TARGET_OS_FREEBSD)
++ set(SYSCONFIG_DEFAULT "tarantool/default")
++elseif (NOT IS_DIRECTORY "${CMAKE_INSTALL_SYSCONFDIR}/sysconfig")
+ # Debian/Ubuntu/etc.
+ set(SYSCONFIG_DEFAULT "default")
+ else()
+@@ -58,6 +64,7 @@ install(DIRECTORY DESTINATION ${TARANTOO
+ install(DIRECTORY DESTINATION ${TARANTOOL_LOGDIR})
+ install(DIRECTORY DESTINATION ${TARANTOOL_RUNDIR})
+
++if (NOT TARGET_OS_FREEBSD)
+ # logrotate files
+ configure_file(tarantool.logrotate.in tarantool.logrotate @ONLY)
+ install (FILES ${PROJECT_BINARY_DIR}/extra/dist/tarantool.logrotate
+@@ -67,6 +74,7 @@ install (FILES ${PROJECT_BINARY_DIR}/ext
+ OWNER_READ OWNER_WRITE
+ GROUP_READ
+ WORLD_READ)
++endif()
+
+ # man page for tarantoolctl
+ pod2man (
+@@ -106,6 +114,8 @@ if (WITH_SYSTEMD)
+ GROUP_READ GROUP_READ
+ WORLD_READ WORLD_READ)
+
++elseif(TARGET_OS_FREEBSD)
++ message (STATUS "Skip installing init.d scripts on FreeBSD")
+ else() # sysvinit
+ message (STATUS "Using scripts for sysvinit")
+ install (FILES tarantool.init DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/init.d/
diff --git a/databases/tarantool/files/patch-extra_dist_default_tarantool.in b/databases/tarantool/files/patch-extra_dist_default_tarantool.in
deleted file mode 100644
index dbf140e30408..000000000000
--- a/databases/tarantool/files/patch-extra_dist_default_tarantool.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- extra/dist/default/tarantool.in.orig 2015-07-07 14:38:20 UTC
-+++ extra/dist/default/tarantool.in
-@@ -6,8 +6,9 @@ default_cfg = {
- sophia_dir = "@TARANTOOL_DATADIR@", -- will become sophia_dir/sophia/instance/
- logger = "/var/log/tarantool", -- logger/instance .. '.log'
- username = "tarantool",
-+ groupname = "tarantool",
- }
-
--instance_dir = "@CMAKE_INSTALL_SYSCONFDIR@/tarantool/instances.enabled"
-+instance_dir = "@CMAKE_INSTALL_SYSCONFDIR@/instances.enabled"
-
- -- vim: set ft=lua :
diff --git a/databases/tarantool/files/patch-extra_dist_tarantoolctl b/databases/tarantool/files/patch-extra_dist_tarantoolctl
deleted file mode 100644
index 509da0634cfd..000000000000
--- a/databases/tarantool/files/patch-extra_dist_tarantoolctl
+++ /dev/null
@@ -1,44 +0,0 @@
---- extra/dist/tarantoolctl.orig 2015-07-07 14:38:20 UTC
-+++ extra/dist/tarantoolctl
-@@ -39,6 +39,7 @@ The file contains common default instanc
- logger = "/var/log/tarantool",
-
- username = "tarantool",
-+ groupname = "tarantool",
- }
-
- instance_dir = "/etc/tarantool/instances.enabled"
-@@ -259,7 +260,8 @@ function load_default_file(default_file)
-
- if not usermode then
- -- change user name only if not running locally
-- d.username = d.username and d.username or "tarantool"
-+ d.username = d.username and d.username or "tarantool"
-+ d.groupname = d.groupname and d.groupname or "tarantool"
- --
- -- instance_dir must be set in the defaults file,
- -- but don't try to set it to the global instance dir
-@@ -310,9 +312,9 @@ local function mkdir(dirname)
- os.exit(-1)
- end
-
-- if not usermode and not fio.chown(dirname, default_cfg.username, default_cfg.username) then
-+ if not usermode and not fio.chown(dirname, default_cfg.username, default_cfg.groupname) then
- log.error("Can't chown(%s, %s, %s): %s",
-- default_cfg.username, default_cfg.username, dirname, errno.strerror())
-+ default_cfg.username, default_cfg.groupname, dirname, errno.strerror())
- end
- end
-
-@@ -367,8 +369,9 @@ local function wrapper_cfg(cfg)
- --
- -- force these startup options
- --
-- cfg.pid_file = default_cfg.pid_file
-- cfg.username = default_cfg.username
-+ cfg.pid_file = default_cfg.pid_file
-+ cfg.username = default_cfg.username
-+ cfg.groupname = default_cfg.groupname
- if cfg.background == nil then
- cfg.background = true
- end
diff --git a/databases/tarantool/files/patch-src_box_lua_load__cfg.lua b/databases/tarantool/files/patch-src_box_lua_load__cfg.lua
deleted file mode 100644
index 0511c73d656d..000000000000
--- a/databases/tarantool/files/patch-src_box_lua_load__cfg.lua
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/box/lua/load_cfg.lua.orig 2015-05-28 22:07:40 UTC
-+++ src/box/lua/load_cfg.lua
-@@ -54,7 +54,8 @@ local default_cfg = {
- custom_proc_title = nil,
- pid_file = nil,
- background = false,
-- username = nil ,
-+ username = nil,
-+ groupname = nil,
- coredump = false,
-
- -- snapshot_daemon
-@@ -101,6 +102,7 @@ local template_cfg = {
- pid_file = 'string',
- background = 'boolean',
- username = 'string',
-+ groupname = 'string',
- coredump = 'boolean',
- snapshot_period = 'number',
- snapshot_count = 'number',
diff --git a/databases/tarantool/files/patch-src_lib_csv_csv.h b/databases/tarantool/files/patch-src_lib_csv_csv.h
deleted file mode 100644
index b0b4288daa04..000000000000
--- a/databases/tarantool/files/patch-src_lib_csv_csv.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/lib/csv/csv.h.orig 2015-08-28 14:36:01 UTC
-+++ src/lib/csv/csv.h
-@@ -30,6 +30,7 @@
- * THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- * SUCH DAMAGE.
- */
-+#include "trivia/config.h"
- #include <stdio.h>
-
- #if defined(__cplusplus)
diff --git a/databases/tarantool/files/patch-third__party_libev_ev.c b/databases/tarantool/files/patch-third__party_libev_ev.c
deleted file mode 100644
index a1c48c7ecd35..000000000000
--- a/databases/tarantool/files/patch-third__party_libev_ev.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- third_party/libev/ev.c.orig 2015-07-10 10:15:23 UTC
-+++ third_party/libev/ev.c
-@@ -2225,7 +2225,7 @@ ev_recommended_backends (void) EV_THROW
- {
- unsigned int flags = ev_supported_backends ();
-
--#if !defined(__NetBSD__) && !defined(__FreeBSD__)
-+#if !defined(__NetBSD__)
- /* kqueue is borked on everything but netbsd apparently */
- /* it usually doesn't work correctly on anything but sockets and pipes */
- flags &= ~EVBACKEND_KQUEUE;
diff --git a/databases/tarantool/files/patch-third__party_luajit_src_Makefile b/databases/tarantool/files/patch-third__party_luajit_src_Makefile
deleted file mode 100644
index 42fd11b184f0..000000000000
--- a/databases/tarantool/files/patch-third__party_luajit_src_Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
---- third_party/luajit/src/Makefile.orig 2015-05-18 09:43:16 UTC
-+++ third_party/luajit/src/Makefile
-@@ -25,7 +25,7 @@ NODOTABIVER= 51
- # with "make clean", followed by "make" if you change any options.
- #
- # LuaJIT builds as a native 32 or 64 bit binary by default.
--CC= gcc
-+#CC= gcc
- #
- # Use this if you want to force a 32 bit build on a 64 bit multilib OS.
- #CC= gcc -m32
-@@ -34,7 +34,7 @@ CC= gcc
- # to slow down the C part by not omitting it. Debugging, tracebacks and
- # unwinding are not affected -- the assembler part has frame unwind
- # information and GCC emits it where needed (x64) or with -g (see CCDEBUG).
--CCOPT= -O2 -fomit-frame-pointer
-+#CCOPT= -O2 -fomit-frame-pointer
- # Use this if you want to generate a smaller binary (but it's slower):
- #CCOPT= -Os -fomit-frame-pointer
- # Note: it's no longer recommended to use -O3 with GCC 4.x.
-@@ -48,7 +48,8 @@ CCOPT= -O2 -fomit-frame-pointer
- # x86/x64 only: For GCC 4.2 or higher and if you don't intend to distribute
- # the binaries to a different machine you could also use: -march=native
- #
--CCOPT_x86= -march=i686
-+#CCOPT_x86= -march=i686
-+CCOPT_x86=
- CCOPT_x64=
- CCOPT_arm=
- CCOPT_ppc=
diff --git a/databases/tarantool/pkg-plist b/databases/tarantool/pkg-plist
index fd3258d46fd1..9e3905d601f0 100644
--- a/databases/tarantool/pkg-plist
+++ b/databases/tarantool/pkg-plist
@@ -1,17 +1,16 @@
bin/tarantool
bin/tarantoolctl
%%ETCDIR%%/default/tarantool
+%%ETCDIR%%/instances.available/example.lua
include/tarantool/lauxlib.h
include/tarantool/lua.h
include/tarantool/lua.hpp
include/tarantool/luaconf.h
include/tarantool/luajit.h
include/tarantool/lualib.h
-include/tarantool/tarantool.h
+include/tarantool/module.h
man/man1/tarantool.1.gz
man/man1/tarantoolctl.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README.md
@dir %%ETCDIR%%/instances.enabled
@dir(%%TT_USER%%,%%TT_GROUP%%,) %%TT_DATADIR%%
@dir(%%TT_USER%%,%%TT_GROUP%%,) %%TT_LOGDIR%%