aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2015-07-04 17:09:32 +0800
committerohauer <ohauer@FreeBSD.org>2015-07-04 17:09:32 +0800
commit88ae755c30fc678866b3150fcb5439a70b4d8b83 (patch)
tree2f6c16d0128bbf4f28119c7433f20e96195b1178
parent2c49763cd88c14ecc745f5edaf239462077d59cc (diff)
downloadfreebsd-ports-gnome-88ae755c30fc678866b3150fcb5439a70b4d8b83.tar.gz
freebsd-ports-gnome-88ae755c30fc678866b3150fcb5439a70b4d8b83.tar.zst
freebsd-ports-gnome-88ae755c30fc678866b3150fcb5439a70b4d8b83.zip
- add port py-paho-mqtt
This port replace the replace mosquitto python driver Python MQTT version 3.1/3.1.1 client class The MQTT protocol is a machine-to-machine (M2M)/"Internet of Things" connectivity protocol. Designed as an extremely lightweight publish/subscribe messaging transport, it is useful for connections with remote locations where a small code footprint is required and/or network bandwidth is at a premium. WWW: http://eclipse.org/paho PR: 200540 Submitted by: ohauer Approved by: Joseph Benden <joe@thrallingpenguin.com> (maintainer, via PM)
-rw-r--r--net/Makefile1
-rw-r--r--net/py-paho-mqtt/Makefile18
-rw-r--r--net/py-paho-mqtt/distinfo2
-rw-r--r--net/py-paho-mqtt/pkg-descr8
4 files changed, 29 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2d99e51a775b..2f0fa908cf08 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -931,6 +931,7 @@
SUBDIR += py-novaclient
SUBDIR += py-oauth
SUBDIR += py-oauth2
+ SUBDIR += py-paho-mqtt
SUBDIR += py-pcap
SUBDIR += py-pcapy
SUBDIR += py-pcs
diff --git a/net/py-paho-mqtt/Makefile b/net/py-paho-mqtt/Makefile
new file mode 100644
index 000000000000..f384b2594fee
--- /dev/null
+++ b/net/py-paho-mqtt/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= paho-mqtt
+PORTVERSION= 1.1
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= joe@thrallingpenguin.com
+COMMENT= MQTT version 3.1/3.1.1 client class
+
+LICENSE= EPL
+
+USES= shebangfix python
+USE_PYTHON= distutils autoplist
+SHEBANG_FILES= examples/*.py
+
+.include <bsd.port.mk>
diff --git a/net/py-paho-mqtt/distinfo b/net/py-paho-mqtt/distinfo
new file mode 100644
index 000000000000..6a8607882367
--- /dev/null
+++ b/net/py-paho-mqtt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (paho-mqtt-1.1.tar.gz) = 0f7a629efe6e3a2c61b59d3550aa9f2c4529b5689a65fde45e6f1ac36b9a261e
+SIZE (paho-mqtt-1.1.tar.gz) = 41788
diff --git a/net/py-paho-mqtt/pkg-descr b/net/py-paho-mqtt/pkg-descr
new file mode 100644
index 000000000000..b511274ce9ae
--- /dev/null
+++ b/net/py-paho-mqtt/pkg-descr
@@ -0,0 +1,8 @@
+Python MQTT version 3.1/3.1.1 client class
+
+The MQTT protocol is a machine-to-machine (M2M)/"Internet of Things"
+connectivity protocol. Designed as an extremely lightweight publish/subscribe
+messaging transport, it is useful for connections with remote locations where
+a small code footprint is required and/or network bandwidth is at a premium.
+
+WWW: http://eclipse.org/paho