aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-05-16 14:39:55 +0800
committermezz <mezz@FreeBSD.org>2005-05-16 14:39:55 +0800
commit89f670ec51e82458157a6462d70b1f666a11addf (patch)
tree754a1a4d63fba5a55b38967893fa8c23b2862e3b
parent876319406dfc12e2bc15f4eaffb3c86fbb405bf5 (diff)
downloadfreebsd-ports-gnome-89f670ec51e82458157a6462d70b1f666a11addf.tar.gz
freebsd-ports-gnome-89f670ec51e82458157a6462d70b1f666a11addf.tar.zst
freebsd-ports-gnome-89f670ec51e82458157a6462d70b1f666a11addf.zip
Tomboy is a desktop note-taking application for Linux and Unix. Simple
and easy to use, but with potential to help you organize the ideas and information you deal with every day. The key to Tomboy's usefulness lies in the ability to relate notes and ideas together. Using a WikiWiki-like linking system, organizing ideas is as simple as typing a name. Branching an idea off is easy as pressing the Link button. And links between your ideas won't break, even when renaming and reorganizing them. WWW: http://www.beatniksoftware.com/tomboy/ BSD# - Project by: http://www.mono-project.com/Mono:FreeBSD
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/tomboy/Makefile32
-rw-r--r--deskutils/tomboy/distinfo2
-rw-r--r--deskutils/tomboy/files/patch-Tomboy::Trie.cs11
-rw-r--r--deskutils/tomboy/pkg-descr11
-rw-r--r--deskutils/tomboy/pkg-plist37
6 files changed, 94 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index ae52c9f66ce0..006e638874af 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -131,6 +131,7 @@
SUBDIR += taskjuggler
SUBDIR += teapot
SUBDIR += timer-applet
+ SUBDIR += tomboy
SUBDIR += treeline
SUBDIR += tuxcards
SUBDIR += vym
diff --git a/deskutils/tomboy/Makefile b/deskutils/tomboy/Makefile
new file mode 100644
index 000000000000..8040638e3a1b
--- /dev/null
+++ b/deskutils/tomboy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tomboy
+# Date created: 20041011
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $Id: Makefile,v 1.7 2005/05/13 00:56:00 tmclau02 Exp $
+# $FreeBSD$
+#
+
+PORTNAME= tomboy
+PORTVERSION= 0.3.2
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://www.beatniksoftware.com/tomboy/releases/
+
+MAINTAINER= tmclaugh@sdf.lonestar.org
+COMMENT= Personal note taking systemfor the GNOME desktop
+
+LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
+BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp \
+ ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= gnomehack gnometarget intltool gnomeprefix
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= tomboy.schemas
+
+.include <bsd.port.mk>
diff --git a/deskutils/tomboy/distinfo b/deskutils/tomboy/distinfo
new file mode 100644
index 000000000000..ba3196931cd0
--- /dev/null
+++ b/deskutils/tomboy/distinfo
@@ -0,0 +1,2 @@
+MD5 (tomboy-0.3.2.tar.gz) = cb4c48860601e636e075644c40b973de
+SIZE (tomboy-0.3.2.tar.gz) = 549963
diff --git a/deskutils/tomboy/files/patch-Tomboy::Trie.cs b/deskutils/tomboy/files/patch-Tomboy::Trie.cs
new file mode 100644
index 000000000000..0899b43f479f
--- /dev/null
+++ b/deskutils/tomboy/files/patch-Tomboy::Trie.cs
@@ -0,0 +1,11 @@
+--- Tomboy/Trie.cs.orig Tue Jan 18 02:33:54 2005
++++ Tomboy/Trie.cs Thu May 12 20:07:03 2005
+@@ -186,7 +186,7 @@
+ MatchHandler match_handler)
+ {
+ TrieState q = root;
+- TrieMatch m;
++ TrieMatch m = null;
+ int idx = 0, start_idx = 0, last_idx = 0;
+
+ while (idx < haystack.Length) {
diff --git a/deskutils/tomboy/pkg-descr b/deskutils/tomboy/pkg-descr
new file mode 100644
index 000000000000..528fc8436b06
--- /dev/null
+++ b/deskutils/tomboy/pkg-descr
@@ -0,0 +1,11 @@
+Tomboy is a desktop note-taking application for Linux and Unix. Simple
+and easy to use, but with potential to help you organize the ideas and
+information you deal with every day.
+
+The key to Tomboy's usefulness lies in the ability to relate notes and
+ideas together. Using a WikiWiki-like linking system, organizing ideas
+is as simple as typing a name. Branching an idea off is easy as pressing
+the Link button. And links between your ideas won't break, even when
+renaming and reorganizing them.
+
+WWW: http://www.beatniksoftware.com/tomboy/
diff --git a/deskutils/tomboy/pkg-plist b/deskutils/tomboy/pkg-plist
new file mode 100644
index 000000000000..b4542e29ec47
--- /dev/null
+++ b/deskutils/tomboy/pkg-plist
@@ -0,0 +1,37 @@
+bin/tomboy
+lib/dbus-1.0/services/com.beatniksoftware.Tomboy.service
+lib/tomboy/Plugins/PrintNotes.dll
+lib/tomboy/Tomboy.exe
+lib/tomboy/Tomboy.exe.config
+lib/tomboy/libtomboy.so
+libdata/bonobo/servers/GNOME_TomboyApplet.server
+libdata/pkgconfig/tomboy-plugins.pc
+share/gnome/gnome-2.0/ui/GNOME_TomboyApplet.xml
+share/gnome/pixmaps/tintin.png
+share/locale/bg/LC_MESSAGES/tomboy.mo
+share/locale/ca/LC_MESSAGES/tomboy.mo
+share/locale/cs/LC_MESSAGES/tomboy.mo
+share/locale/da/LC_MESSAGES/tomboy.mo
+share/locale/de/LC_MESSAGES/tomboy.mo
+share/locale/en_CA/LC_MESSAGES/tomboy.mo
+share/locale/en_GB/LC_MESSAGES/tomboy.mo
+share/locale/es/LC_MESSAGES/tomboy.mo
+share/locale/fr/LC_MESSAGES/tomboy.mo
+share/locale/hu/LC_MESSAGES/tomboy.mo
+share/locale/is/LC_MESSAGES/tomboy.mo
+share/locale/it/LC_MESSAGES/tomboy.mo
+share/locale/ja/LC_MESSAGES/tomboy.mo
+share/locale/ko/LC_MESSAGES/tomboy.mo
+share/locale/lt/LC_MESSAGES/tomboy.mo
+share/locale/nb/LC_MESSAGES/tomboy.mo
+share/locale/nl/LC_MESSAGES/tomboy.mo
+share/locale/no/LC_MESSAGES/tomboy.mo
+share/locale/pa/LC_MESSAGES/tomboy.mo
+share/locale/pl/LC_MESSAGES/tomboy.mo
+share/locale/pt_BR/LC_MESSAGES/tomboy.mo
+share/locale/rw/LC_MESSAGES/tomboy.mo
+share/locale/sq/LC_MESSAGES/tomboy.mo
+share/locale/sv/LC_MESSAGES/tomboy.mo
+share/locale/zh_CN/LC_MESSAGES/tomboy.mo
+@dirrm lib/tomboy/Plugins
+@dirrm lib/tomboy