aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2003-12-20 13:11:02 +0800
committerache <ache@FreeBSD.org>2003-12-20 13:11:02 +0800
commit8a470ec6168abd43a73bb706cdc631750b643604 (patch)
treef541f6098960995b358a5ae1f13b2d1b2c96c9a6
parentd9d4c3ba3b4d1e3e83ba4091707c5b866f3db1bd (diff)
downloadfreebsd-ports-gnome-8a470ec6168abd43a73bb706cdc631750b643604.tar.gz
freebsd-ports-gnome-8a470ec6168abd43a73bb706cdc631750b643604.tar.zst
freebsd-ports-gnome-8a470ec6168abd43a73bb706cdc631750b643604.zip
Add optional DO_NOT_DECODE_SUBJECT knob (allows to catch unwanted charsets)
-rw-r--r--mail/sentinel/Makefile4
-rw-r--r--mail/sentinel/files/patch-aa13
2 files changed, 17 insertions, 0 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index f83e3f210e65..0048dda21a06 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -24,6 +24,10 @@ IGNORE= requires Sendmail 8.12
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.if defined(WITHOUT_SENTINEL_DECODE_SUBJECT)
+CFLAGS+= -DDO_NOT_DECODE_SUBJECT
+.endif
+
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} ${PTHREAD_CFLAGS} \
diff --git a/mail/sentinel/files/patch-aa b/mail/sentinel/files/patch-aa
new file mode 100644
index 000000000000..dc3328b409b3
--- /dev/null
+++ b/mail/sentinel/files/patch-aa
@@ -0,0 +1,13 @@
+--- sentinel.c.bak Mon Oct 27 02:03:32 2003
++++ sentinel.c Sat Dec 20 07:59:32 2003
+@@ -3135,8 +3135,10 @@
+ /* check if a rule defined for this header in [headers] section */
+ for (smfhl = smfHeader_list[message->cfgNdx]; smfhl; smfhl = smfhl->next) {
+ if (!strcasecmp(smfhl->name, headerf)) {
++#ifndef DO_NOT_DECODE_SUBJECT
+ if (!strcasecmp(headerf, "Subject"))
+ headerv = smfMimeDecodeString(headerv, message->buf);
++#endif
+ if (headerv) {
+ for (smfel = smfhl->entr; smfel; smfel = smfel->next) {
+ if (!smfPatternMatch(message, headerv, smfel->event)) {