aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2011-08-06 19:57:02 +0800
committernobutaka <nobutaka@FreeBSD.org>2011-08-06 19:57:02 +0800
commit8a73dd150d99c5854a7669ce63f5625495cf8c46 (patch)
tree11455f48d06f4460d66a136ec9cb33159600827b
parentccedcd4e75900e67e84b9053f9266a49f357bb03 (diff)
downloadfreebsd-ports-gnome-8a73dd150d99c5854a7669ce63f5625495cf8c46.tar.gz
freebsd-ports-gnome-8a73dd150d99c5854a7669ce63f5625495cf8c46.tar.zst
freebsd-ports-gnome-8a73dd150d99c5854a7669ce63f5625495cf8c46.zip
Add uim-gtk3, GTK+ 3.x modules of uim input method.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/uim-gtk3/Makefile40
-rw-r--r--textproc/uim-gtk3/pkg-descr3
-rw-r--r--textproc/uim-gtk3/pkg-plist12
4 files changed, 56 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 705dd7c17992..3e993f37803c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1335,6 +1335,7 @@
SUBDIR += uim-el-xemacs21-mule
SUBDIR += uim-gnome
SUBDIR += uim-gtk
+ SUBDIR += uim-gtk3
SUBDIR += uim-kde
SUBDIR += uim-kde4
SUBDIR += uim-m17nlib
diff --git a/textproc/uim-gtk3/Makefile b/textproc/uim-gtk3/Makefile
new file mode 100644
index 000000000000..46fce2fb9a16
--- /dev/null
+++ b/textproc/uim-gtk3/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: uim-gtk3
+# Date created: 6 August 2011
+# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -gtk3
+
+COMMENT= GTK+ 3.x modules of uim input method
+
+USE_GNOME= gtk30
+LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
+
+MASTERDIR= ${.CURDIR}/../../textproc/uim
+PKGDIR= ${.CURDIR}
+CONFIGURE_ARGS= --with-gtk3 --enable-pref --enable-default-toolkit=gtk3
+
+UIM_SLAVE= yes
+
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-gtk3_candwin_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk3_dict_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk3_immodule_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk3_pad_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk3_pref_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk3_switcher_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk3_toolbar_Makefile.in
+
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
+do-build:
+ (cd ${WRKSRC}/uim && ${GMAKE} libuim-x-util.la libuim-counted-init.la)
+ (cd ${WRKSRC}/gtk3 && ${GMAKE})
+
+do-install:
+ (cd ${WRKSRC}/gtk3 && ${GMAKE} install)
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/uim-gtk3/pkg-descr b/textproc/uim-gtk3/pkg-descr
new file mode 100644
index 000000000000..cc16b03df475
--- /dev/null
+++ b/textproc/uim-gtk3/pkg-descr
@@ -0,0 +1,3 @@
+GTK+ 3.x modules of uim input method.
+
+WWW: http://code.google.com/p/uim/
diff --git a/textproc/uim-gtk3/pkg-plist b/textproc/uim-gtk3/pkg-plist
new file mode 100644
index 000000000000..03eb449ba855
--- /dev/null
+++ b/textproc/uim-gtk3/pkg-plist
@@ -0,0 +1,12 @@
+bin/uim-im-switcher-gtk3
+bin/uim-input-pad-ja-gtk3
+bin/uim-pref-gtk3
+bin/uim-toolbar-gtk3
+bin/uim-toolbar-gtk3-systray
+lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-uim.a
+lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-uim.la
+lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-uim.so
+libexec/uim-candwin-gtk3
+libexec/uim-candwin-tbl-gtk3
+@exec gtk-query-immodules-3.0 > %D/etc/gtk-3.0/gtk.immodules
+@unexec gtk-query-immodules-3.0 > %D/etc/gtk-3.0/gtk.immodules